summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-15 16:16:10 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-15 16:16:10 +0000
commit5cf6ba75be2af52c16fb8ed8b9cdb986a5a50175 (patch)
treecd599001225134b48df8aa520cb03211ccd61520 /net-wireless/bluez-hcidump
parentx86 stable wrt security bug #366697 (diff)
downloadgentoo-2-5cf6ba75be2af52c16fb8ed8b9cdb986a5a50175.tar.gz
gentoo-2-5cf6ba75be2af52c16fb8ed8b9cdb986a5a50175.tar.bz2
gentoo-2-5cf6ba75be2af52c16fb8ed8b9cdb986a5a50175.zip
Version bump wrt #364707 with a upstream patch to fix building with recent bluez wrt #363945.
(Portage version: 2.2.0_alpha33/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless/bluez-hcidump')
-rw-r--r--net-wireless/bluez-hcidump/ChangeLog11
-rw-r--r--net-wireless/bluez-hcidump/bluez-hcidump-2.0.ebuild25
-rw-r--r--net-wireless/bluez-hcidump/files/bluez-hcidump-2.0-bluez-4.9x.patch25
3 files changed, 59 insertions, 2 deletions
diff --git a/net-wireless/bluez-hcidump/ChangeLog b/net-wireless/bluez-hcidump/ChangeLog
index 711fad9a4af9..211ac501e099 100644
--- a/net-wireless/bluez-hcidump/ChangeLog
+++ b/net-wireless/bluez-hcidump/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-wireless/bluez-hcidump
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-hcidump/ChangeLog,v 1.48 2010/06/11 12:09:08 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-hcidump/ChangeLog,v 1.49 2011/05/15 16:16:10 ssuominen Exp $
+
+*bluez-hcidump-2.0 (15 May 2011)
+
+ 15 May 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +bluez-hcidump-2.0.ebuild, +files/bluez-hcidump-2.0-bluez-4.9x.patch:
+ Version bump wrt #364707 with a upstream patch to fix building with recent
+ bluez wrt #363945.
11 Jun 2010; Samuli Suominen <ssuominen@gentoo.org>
bluez-hcidump-1.42.ebuild:
diff --git a/net-wireless/bluez-hcidump/bluez-hcidump-2.0.ebuild b/net-wireless/bluez-hcidump/bluez-hcidump-2.0.ebuild
new file mode 100644
index 000000000000..0d19ca5322c9
--- /dev/null
+++ b/net-wireless/bluez-hcidump/bluez-hcidump-2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-hcidump/bluez-hcidump-2.0.ebuild,v 1.1 2011/05/15 16:16:10 ssuominen Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Bluetooth HCI packet analyzer"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="mirror://kernel/linux/bluetooth/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-wireless/bluez-4.90"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-bluez-4.9x.patch
+}
diff --git a/net-wireless/bluez-hcidump/files/bluez-hcidump-2.0-bluez-4.9x.patch b/net-wireless/bluez-hcidump/files/bluez-hcidump-2.0-bluez-4.9x.patch
new file mode 100644
index 000000000000..11d7db3761d4
--- /dev/null
+++ b/net-wireless/bluez-hcidump/files/bluez-hcidump-2.0-bluez-4.9x.patch
@@ -0,0 +1,25 @@
+--- src/hcidump.c
++++ src/hcidump.c
+@@ -50,22 +50,6 @@
+ #include "parser/parser.h"
+ #include "parser/sdp.h"
+
+-#if __BYTE_ORDER == __LITTLE_ENDIAN
+-static inline uint64_t ntoh64(uint64_t n)
+-{
+- uint64_t h;
+- uint64_t tmp = ntohl(n & 0x00000000ffffffff);
+- h = ntohl(n >> 32);
+- h |= tmp << 32;
+- return h;
+-}
+-#elif __BYTE_ORDER == __BIG_ENDIAN
+-#define ntoh64(x) (x)
+-#else
+-#error "Unknown byte order"
+-#endif
+-#define hton64(x) ntoh64(x)
+-
+ #define SNAP_LEN HCI_MAX_FRAME_SIZE
+ #define DEFAULT_PORT "10839";
+