summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-06-29 07:47:07 +0000
committerRoy Marples <uberlord@gentoo.org>2007-06-29 07:47:07 +0000
commit092f8abde957f792ad6a337ef208b8e01f8042d6 (patch)
tree77febcc35ad3a9c4b93c5924b2ddc25f6ec7fdd5 /net-wireless/wpa_supplicant
parentstable x86, bug 183102 (diff)
downloadgentoo-2-092f8abde957f792ad6a337ef208b8e01f8042d6.tar.gz
gentoo-2-092f8abde957f792ad6a337ef208b8e01f8042d6.tar.bz2
gentoo-2-092f8abde957f792ad6a337ef208b8e01f8042d6.zip
Don't hardcode path to qmake, #182867 thanks to Thomas Capricelli.
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog6
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild8
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild8
3 files changed, 13 insertions, 9 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index 4b44ababb6c8..8a9f85b45e72 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.95 2007/06/19 07:54:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.96 2007/06/29 07:47:07 uberlord Exp $
+
+ 29 Jun 2007; Roy Marples <uberlord@gentoo.org>
+ wpa_supplicant-0.5.7.ebuild, wpa_supplicant-0.6.0.ebuild:
+ Don't hardcode path to qmake, #182867 thanks to Thomas Capricelli.
19 Jun 2007; Stefan Schweizer <genstef@gentoo.org>
wpa_supplicant-0.5.7.ebuild, wpa_supplicant-0.6.0.ebuild:
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild
index 0dd437f74837..fa1476ad411b 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild,v 1.6 2007/06/19 07:54:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.7.ebuild,v 1.7 2007/06/29 07:47:07 uberlord Exp $
-inherit eutils toolchain-funcs
+inherit eutils qt3 toolchain-funcs
DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
@@ -151,8 +151,8 @@ src_compile() {
cd "${S}"/wpa_gui-qt4
emake || die "emake wpa_gui-qt4 failed"
elif use qt3 ; then
- [[ -d ${QTDIR}/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
- /usr/qt/3/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
+ [[ -d "${QTDIR}"/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
+ "${QTDIR}"/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
cd "${S}"/wpa_gui
emake || die "emake wpa_gui failed"
fi
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild
index 0de295fb632b..9337d3ef12d9 100644
--- a/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild,v 1.2 2007/06/19 07:54:17 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.6.0.ebuild,v 1.3 2007/06/29 07:47:07 uberlord Exp $
-inherit eutils toolchain-funcs
+inherit eutils qt3 toolchain-funcs
DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
@@ -151,8 +151,8 @@ src_compile() {
cd "${S}"/wpa_gui-qt4
emake || die "emake wpa_gui-qt4 failed"
elif use qt3 ; then
- [[ -d ${QTDIR}/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
- /usr/qt/3/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
+ [[ -d "${QTDIR}"/etc/settings ]] && addwrite "${QTDIR}"/etc/settings
+ "${QTDIR}"/bin/qmake -o "${S}"/wpa_gui/Makefile "${S}"/wpa_gui/wpa_gui.pro
cd "${S}"/wpa_gui
emake || die "emake wpa_gui failed"
fi