summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenrik Brix Andersen <brix@gentoo.org>2006-06-21 19:58:07 +0000
committerHenrik Brix Andersen <brix@gentoo.org>2006-06-21 19:58:07 +0000
commit32d8ff89dc5f4fbafd28289a55ba2b2f00a16249 (patch)
treeb81845f4b5880ec9f6dc6df63f45786a0abdf6a9 /net-wireless/wpa_supplicant
parentnew cvs snapshot (diff)
downloadgentoo-2-32d8ff89dc5f4fbafd28289a55ba2b2f00a16249.tar.gz
gentoo-2-32d8ff89dc5f4fbafd28289a55ba2b2f00a16249.tar.bz2
gentoo-2-32d8ff89dc5f4fbafd28289a55ba2b2f00a16249.zip
New developer snapshot.
(Portage version: 2.1)
Diffstat (limited to 'net-wireless/wpa_supplicant')
-rw-r--r--net-wireless/wpa_supplicant/ChangeLog8
-rw-r--r--net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.32
-rw-r--r--net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.43
-rw-r--r--net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh45
-rw-r--r--net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild158
5 files changed, 215 insertions, 1 deletions
diff --git a/net-wireless/wpa_supplicant/ChangeLog b/net-wireless/wpa_supplicant/ChangeLog
index bdfd05a05fb5..d781860bff6a 100644
--- a/net-wireless/wpa_supplicant/ChangeLog
+++ b/net-wireless/wpa_supplicant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/wpa_supplicant
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.60 2006/05/27 20:01:35 brix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/ChangeLog,v 1.61 2006/06/21 19:58:07 brix Exp $
+
+*wpa_supplicant-0.5.4 (21 Jun 2006)
+
+ 21 Jun 2006; Henrik Brix Andersen <brix@gentoo.org>
+ +files/wpa_supplicant-0.5.4-wpa_cli.sh, +wpa_supplicant-0.5.4.ebuild:
+ New developer snapshot.
*wpa_supplicant-0.4.9 (27 May 2006)
diff --git a/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.3 b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.3
index f614e4793998..a210581e2059 100644
--- a/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.3
+++ b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.3
@@ -1 +1,3 @@
MD5 f30cd996ebdd9f1f6aeab65f8cfac3c3 wpa_supplicant-0.5.3.tar.gz 543322
+RMD160 d3911460fcd4b3cc85bfc41bfb98235c447bfd43 wpa_supplicant-0.5.3.tar.gz 543322
+SHA256 cf29745c4c11fd8d7668d9a7ad0f698160b1f8f0988146175908d877dda71236 wpa_supplicant-0.5.3.tar.gz 543322
diff --git a/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4 b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4
new file mode 100644
index 000000000000..6277e57aa0a6
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/digest-wpa_supplicant-0.5.4
@@ -0,0 +1,3 @@
+MD5 eaf78fa5dde04ee20e718a8e94eed827 wpa_supplicant-0.5.4.tar.gz 630779
+RMD160 34074a4d1ebab4d455eb021a18ef9012943b1fd9 wpa_supplicant-0.5.4.tar.gz 630779
+SHA256 6c14c9c6c68acc40aa1c860d4fde58424c57b48ea90700da189e6cf5c1dd6bd7 wpa_supplicant-0.5.4.tar.gz 630779
diff --git a/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh
new file mode 100644
index 000000000000..996aa94f2278
--- /dev/null
+++ b/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh
@@ -0,0 +1,45 @@
+#!/bin/sh
+# Copyright 1999-2006 Gentoo Foundation
+# Written by Roy Marples <uberlord@gentoo.org>
+# Distributed under the terms of the GNU General Public License v2
+# Alternatively, this file may be distributed under the terms of the BSD License
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/files/wpa_supplicant-0.5.4-wpa_cli.sh,v 1.1 2006/06/21 19:58:07 brix Exp $
+
+if [ -z "$1" -o -z "$2" ]; then
+ echo "Insufficient parameters" > /dev/stderr
+ exit 1
+fi
+
+INTERFACE="$1"
+ACTION="$2"
+
+# Note, the below action must NOT mark the interface down via ifconfig, ip or
+# similar. Addresses can be removed, changed and daemons can be stopped, but
+# the interface must remain up for wpa_supplicant to work.
+
+if [ -f /etc/gentoo-release ]; then
+ EXEC="/etc/init.d/net.${INTERFACE} --quiet"
+else
+ echo "I don't know what to do with this distro!" > /dev/stderr
+ exit 1
+fi
+
+case ${ACTION} in
+ CONNECTED)
+ EXEC="${EXEC} start"
+ ;;
+ DISCONNECTED)
+ EXEC="${EXEC} stop"
+ ;;
+ *)
+ echo "Unknown action ${ACTION}" > /dev/stderr
+ exit 1
+ ;;
+esac
+
+# ${EXEC} can use ${IN_BACKGROUND} so that it knows that the user isn't
+# stopping the interface and a background process - like wpa_cli - is.
+export IN_BACKGROUND=true
+
+logger -t wpa_cli "interface ${INTERFACE} ${ACTION}"
+${EXEC} || logger -t wpa_cli "executing '${EXEC}' failed"
diff --git a/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild
new file mode 100644
index 000000000000..d98b767f1e42
--- /dev/null
+++ b/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/wpa_supplicant/wpa_supplicant-0.5.4.ebuild,v 1.1 2006/06/21 19:58:07 brix Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="IEEE 802.1X/WPA supplicant for secure wireless transfers"
+HOMEPAGE="http://hostap.epitest.fi/wpa_supplicant/"
+SRC_URI="http://hostap.epitest.fi/releases/${P}.tar.gz"
+LICENSE="|| ( GPL-2 BSD )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="dbus gsm madwifi qt readline ssl"
+
+RDEPEND="dbus? ( sys-apps/dbus )
+ gsm? ( sys-apps/pcsc-lite )
+ qt? ( =x11-libs/qt-4* )
+ readline? ( sys-libs/ncurses sys-libs/readline )
+ ssl? ( dev-libs/openssl )
+ kernel_linux? ( madwifi? ( || ( net-wireless/madwifi-ng net-wireless/madwifi-old ) ) )
+ !kernel_linux? ( net-libs/libpcap )"
+DEPEND="sys-apps/sed
+ ${RDEPEND}"
+
+src_unpack() {
+ local CONFIG=${S}/.config
+
+ unpack ${A}
+
+ # net/bpf.h needed for net-libs/libpcap on Gentoo FreeBSD
+ sed -i \
+ -e "s:\(#include <pcap\.h>\):#include <net/bpf.h>\n\1:" \
+ ${S}/l2_packet_freebsd.c
+
+ # toolchain setup
+ echo "CC = $(tc-getCC)" > ${CONFIG}
+
+ # basic setup
+ echo "CONFIG_CTRL_IFACE=y" >> ${CONFIG}
+ echo "CONFIG_BACKEND=file" >> ${CONFIG}
+
+ # basic authentication methods
+ echo "CONFIG_EAP_GTC=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MD5=y" >> ${CONFIG}
+ echo "CONFIG_EAP_OTP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PAX=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PSK=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TLV=y" >> ${CONFIG}
+ echo "CONFIG_IEEE8021X_EAPOL=y" >> ${CONFIG}
+ echo "CONFIG_PKCS12=y" >> ${CONFIG}
+ echo "CONFIG_PEERKEY=y" >> ${CONFIG}
+
+ if use dbus; then
+ echo "CONFIG_CTRL_IFACE_DBUS=y" >> ${CONFIG}
+ fi
+
+ if use gsm; then
+ # smart card authentication
+ echo "CONFIG_EAP_SIM=y" >> ${CONFIG}
+ echo "CONFIG_EAP_AKA=y" >> ${CONFIG}
+ echo "CONFIG_PCSC=y" >> ${CONFIG}
+ fi
+
+ if use readline; then
+ # readline/history support for wpa_cli
+ echo "CONFIG_READLINE=y" >> ${CONFIG}
+ fi
+
+ if use ssl; then
+ # SSL authentication methods
+ echo "CONFIG_EAP_LEAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_MSCHAPV2=y" >> ${CONFIG}
+ echo "CONFIG_EAP_PEAP=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TLS=y" >> ${CONFIG}
+ echo "CONFIG_EAP_TTLS=y" >> ${CONFIG}
+ echo "CONFIG_SMARTCARD=y" >> ${CONFIG}
+ fi
+
+ if use kernel_linux; then
+ # Linux specific drivers
+ echo "CONFIG_DRIVER_ATMEL=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_HOSTAP=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_IPW=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_NDISWRAPPER=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_PRISM54=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_WEXT=y" >> ${CONFIG}
+ echo "CONFIG_DRIVER_WIRED=y" >> ${CONFIG}
+
+ if use madwifi; then
+ # Add include path for madwifi-driver headers
+ echo "CFLAGS += -I${ROOT}/usr/include/madwifi" >> ${CONFIG}
+ echo "CONFIG_DRIVER_MADWIFI=y" >> ${CONFIG}
+ fi
+ fi
+
+ if use kernel_FreeBSD; then
+ # FreeBSD specific driver
+ echo "CONFIG_DRIVER_BSD=y" >> ${CONFIG}
+ fi
+
+ # people seem to take the example configuration file too literally
+ # bug #102361
+ sed -i \
+ -e "s:^\(opensc_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_engine_path\):#\1:" \
+ -e "s:^\(pkcs11_module_path\):#\1:" \
+ ${S}/wpa_supplicant.conf || die
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use qt; then
+ qmake -o "${S}"/wpa_gui-qt4/Makefile "${S}"/wpa_gui-qt4/wpa_gui.pro
+ cd "${S}"/wpa_gui-qt4
+ emake || die "emake wpa_gui-qt4 failed"
+ fi
+}
+
+src_install() {
+ into /
+ dosbin wpa_supplicant
+ dobin wpa_cli wpa_passphrase
+
+ exeinto /etc/wpa_supplicant/
+ newexe ${FILESDIR}/${P}-wpa_cli.sh wpa_cli.sh
+
+ # compatibility symlink for older baselayout
+ dosym /etc/wpa_supplicant/wpa_cli.sh /sbin/wpa_cli.action
+
+ if use qt; then
+ into /usr
+ dobin wpa_gui-qt4/wpa_gui
+ fi
+
+ dodoc ChangeLog COPYING eap_testing.txt README todo.txt
+ newdoc wpa_supplicant.conf wpa_supplicant.conf.example
+
+ doman doc/docbook/*.8
+ doman doc/docbook/*.5
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use ${MY_P} you must create the configuration file"
+ einfo "/etc/wpa_supplicant/wpa_supplicant.conf"
+ einfo
+ einfo "An example configuration file is available as"
+ einfo "/usr/share/doc/${PF}/wpa_supplicant.conf.example.gz"
+ einfo
+ if use madwifi; then
+ einfo "This package now compiles against the headers installed by"
+ einfo "the madwifi driver. You should reemerge ${PN} after"
+ einfo "upgrading your madwifi driver."
+ einfo
+ fi
+}