summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2006-04-21 13:10:30 +0000
committerJoseph Jezak <josejx@gentoo.org>2006-04-21 13:10:30 +0000
commit0ac5effb2e5dad526045ab0da04ce5477ae4091f (patch)
tree24900ce283aa9c4caf10b8b5e1247bc056954fcb /net-wireless
parentFixed keywords to match bcm43xx ebuild. (diff)
downloadgentoo-2-0ac5effb2e5dad526045ab0da04ce5477ae4091f.tar.gz
gentoo-2-0ac5effb2e5dad526045ab0da04ce5477ae4091f.tar.bz2
gentoo-2-0ac5effb2e5dad526045ab0da04ce5477ae4091f.zip
Fixed dependencies to depend on the fwcutter ebuild.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/bcm43xx/ChangeLog6
-rw-r--r--net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild23
-rw-r--r--net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild26
3 files changed, 11 insertions, 44 deletions
diff --git a/net-wireless/bcm43xx/ChangeLog b/net-wireless/bcm43xx/ChangeLog
index 6384ffd980e8..1ea74993e1f6 100644
--- a/net-wireless/bcm43xx/ChangeLog
+++ b/net-wireless/bcm43xx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-wireless/bcm43xx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/ChangeLog,v 1.9 2006/03/30 01:14:57 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/ChangeLog,v 1.10 2006/04/21 13:10:30 josejx Exp $
+
+ 21 Apr 2006; Joseph Jezak <josejx@gentoo.org>
+ bcm43xx-0.0.1-r20060125.ebuild, bcm43xx-0.0.1-r20060329.ebuild:
+ Fixed dependencies to depend on the fwcutter ebuild.
30 Mar 2006; Joseph Jezak <josejx@gentoo.org>
bcm43xx-0.0.1-r20060329.ebuild:
diff --git a/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild
index 5faaaff31f41..d020f4a45cc8 100644
--- a/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild
+++ b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild,v 1.4 2006/03/01 21:44:10 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060125.ebuild,v 1.5 2006/04/21 13:10:30 josejx Exp $
inherit linux-mod eutils
DESCRIPTION="Driver for Broadcom 43xx based wireless network devices"
HOMEPAGE="http://bcm43xx.berlios.de"
-SRC_URI="mirror://gentoo/${PN}-${PR#r}.tar.bz2
- mirror://gentoo/${PN}-fwcutter-${PR#r}.tar.bz2"
+SRC_URI="mirror://gentoo/${PN}-${PR#r}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -16,6 +15,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
DEPEND=">=net-wireless/ieee80211softmac-0.1-r2006125"
RDEPEND="${DEPEND}
+ net-wireless/bcm43xx-fwcutter
>=net-wireless/wireless-tools-28_pre4
>=sys-apps/hotplug-20040923-r1"
@@ -29,8 +29,6 @@ ERROR_FW_LOADER="${P} requires \"Hotplug firmware loading support (CONFIG_FW_LOA
ERROR_DEBUG_FS="${P} requires Debug Filesystem support (CONFIG_DEBUG_FS) for
buidling with USE=\"debug\"."
-FWCUTTER_DIR="${WORKDIR}/bcm43xx-fwcutter-${PR#r}"
-
S="${WORKDIR}/${PN}-${PR#r}"
pkg_setup() {
@@ -50,16 +48,9 @@ src_unpack() {
src_compile() {
BUILD_PARAMS="DEBUG=$(use debug && echo y || echo n) KSRC=${KV_DIR} KSRC_OUTPUT=${KV_OUT_DIR} SOFTMAC_DIR=/usr/include/softmac" linux-mod_src_compile
- cd ${FWCUTTER_DIR}
- make || die "Can't compile fwcutter."
}
src_install() {
- # Install fwcutter
- exeinto /usr/bin
- doexe ${FWCUTTER_DIR}/fwcutter
- dodoc ${FWCUTTER_DIR}/README
-
# Install the module
linux-mod_src_install
}
@@ -76,14 +67,6 @@ pkg_postinst() {
einfo
fi
- if ! [ -f /lib/firmware/${PN}_microcode2.fw ]; then
- einfo
- einfo "You'll need to use fwcutter to install the bcm43xx firmware."
- einfo "Please read the fwcutter readme for more details:"
- einfo "/usr/share/doc/${PN}-${PVR}/README.gz"
- einfo
- fi
-
einfo "Please read this forum thread for help and troubleshooting:"
einfo "http://forums.gentoo.org/viewtopic-t-409194.html"
einfo
diff --git a/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild
index 88ac2c28e11f..d04956ee810f 100644
--- a/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild
+++ b/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild
@@ -1,15 +1,12 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild,v 1.2 2006/03/30 01:14:57 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bcm43xx/bcm43xx-0.0.1-r20060329.ebuild,v 1.3 2006/04/21 13:10:30 josejx Exp $
inherit linux-mod eutils
-FWCUTTER_VERSION="004"
-
DESCRIPTION="Driver for Broadcom 43xx based wireless network devices"
HOMEPAGE="http://bcm43xx.berlios.de"
-SRC_URI="http://tara.shadowpimps.net/~bcm43xx/bcm43xx-snapshots/standalone/${PN}/${PN}-standalone-${PR#r20}.tar.bz2
- http://download.berlios.de/${PN}/${PN}-fwcutter-${FWCUTTER_VERSION}.tar.bz2"
+SRC_URI="http://tara.shadowpimps.net/~bcm43xx/bcm43xx-snapshots/standalone/${PN}/${PN}-standalone-${PR#r20}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
@@ -18,6 +15,7 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="debug"
DEPEND=">=net-wireless/ieee80211softmac-0.1-r${PR#r20}"
RDEPEND="${DEPEND}
+ net-wireless/bcm43xx-fwcutter
>=net-wireless/wireless-tools-28_pre4
>=sys-apps/hotplug-20040923-r1"
@@ -30,8 +28,6 @@ ERROR_NET_RADIO="${P} requires support for \"Wireless LAN drivers (non-hamradio)
ERROR_FW_LOADER="${P} requires \"Hotplug firmware loading support (CONFIG_FW_LOADER)\"."
ERROR_DEBUG_FS="${P} requires Debug Filesystem support (CONFIG_DEBUG_FS) for building with USE=\"debug\"."
-FWCUTTER_DIR="${WORKDIR}/bcm43xx-fwcutter-${FWCUTTER_VERSION}"
-
S="${WORKDIR}/${PN}-standalone-${PR#r20}"
pkg_setup() {
@@ -59,17 +55,9 @@ src_compile() {
BUILD_PARAMS="DEBUG=$(use debug && echo y || echo n) KSRC=${KV_DIR} \
KSRC_OUTPUT=${KV_OUT_DIR} KDIR=${ROOT}/lib/modules/${KV_FULL}/build" \
linux-mod_src_compile
- cd ${FWCUTTER_DIR}
- make || die "Can't compile fwcutter."
}
src_install() {
- # Install fwcutter
- exeinto /usr/bin
- doexe ${FWCUTTER_DIR}/${PN}-fwcutter
- doman ${FWCUTTER_DIR}/${PN}-fwcutter.1
- dodoc ${FWCUTTER_DIR}/README
-
# Install the module
linux-mod_src_install
}
@@ -86,14 +74,6 @@ pkg_postinst() {
einfo
fi
- if ! [ -f /lib/firmware/${PN}_microcode2.fw ]; then
- einfo
- einfo "You'll need to use bcm43xx-fwcutter to install the bcm43xx firmware."
- einfo "Please read the bcm43xx-fwcutter readme for more details:"
- einfo "/usr/share/doc/${PN}-${PVR}/README.gz"
- einfo
- fi
-
einfo "Please read this forum thread for help and troubleshooting:"
einfo "http://forums.gentoo.org/viewtopic-t-409194.html"
einfo