summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Klimaszewski <steev@gentoo.org>2012-02-17 04:52:21 +0000
committerStephen Klimaszewski <steev@gentoo.org>2012-02-17 04:52:21 +0000
commit83e1e2b101f66a2c2f0645b8ab3233b17ff15c90 (patch)
tree35d45f8474d0d39f49e667e6dd832415abbaecfb /net-wireless
parentDepend on >=libgcrypt-1.4.2 (bug #404167, thanks to Wille Kuutti for reportin... (diff)
downloadgentoo-2-83e1e2b101f66a2c2f0645b8ab3233b17ff15c90.tar.gz
gentoo-2-83e1e2b101f66a2c2f0645b8ab3233b17ff15c90.tar.bz2
gentoo-2-83e1e2b101f66a2c2f0645b8ab3233b17ff15c90.zip
New Kismet release, courtesy of ZeroChaos of Pentoo. He's also offered to proxy-maintain, so add him as proxy-maintainer, myself as committer.
(Portage version: 2.1.10.46/cvs/Linux x86_64)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/kismet/ChangeLog13
-rw-r--r--net-wireless/kismet/files/bluechanfix_r3184.patch15
-rw-r--r--net-wireless/kismet/files/kismet-console-scrolling-backport.patch12
-rw-r--r--net-wireless/kismet/files/makefile.patch119
-rw-r--r--net-wireless/kismet/files/plugins-ldflags.patch10
-rw-r--r--net-wireless/kismet/kismet-2011.03.2.ebuild160
-rw-r--r--net-wireless/kismet/metadata.xml42
7 files changed, 357 insertions, 14 deletions
diff --git a/net-wireless/kismet/ChangeLog b/net-wireless/kismet/ChangeLog
index db38fdd6eadc..332d17dae741 100644
--- a/net-wireless/kismet/ChangeLog
+++ b/net-wireless/kismet/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-wireless/kismet
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet/ChangeLog,v 1.109 2011/10/27 16:10:23 jer Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet/ChangeLog,v 1.110 2012/02/17 04:52:21 steev Exp $
+
+*kismet-2011.03.2 (17 Feb 2012)
+
+ 17 Feb 2012; Steev Klimaszewsk <steev@gentoo.org>
+ +files/bluechanfix_r3184.patch, +kismet-2011.03.2.ebuild,
+ +files/kismet-console-scrolling-backport.patch, +files/makefile.patch,
+ +files/plugins-ldflags.patch, metadata.xml:
+ New Kismet release, courtesy of ZeroChaos of Pentoo. He's also offered to
+ proxy-maintain, so add him as proxy-maintainer, myself as committer.
27 Oct 2011; Jeroen Roovers <jer@gentoo.org> kismet-2010.01.1.ebuild,
kismet-2010.01.1-r1.ebuild:
diff --git a/net-wireless/kismet/files/bluechanfix_r3184.patch b/net-wireless/kismet/files/bluechanfix_r3184.patch
new file mode 100644
index 000000000000..bdc05cb0b51f
--- /dev/null
+++ b/net-wireless/kismet/files/bluechanfix_r3184.patch
@@ -0,0 +1,15 @@
+Index: packetsourcetracker.cc
+===================================================================
+--- packetsourcetracker.cc (revision 3183)
++++ packetsourcetracker.cc (working copy)
+@@ -151,7 +151,10 @@
+ break;
+
+ case SOURCE_channel:
+- osstr << psrc->channel;
++ if (psrc->strong_source != NULL)
++ osstr << psrc->strong_source->FetchChannel();
++ else
++ osstr << psrc->channel;
+ cache->Cache(fnum, osstr.str());
+ break;
diff --git a/net-wireless/kismet/files/kismet-console-scrolling-backport.patch b/net-wireless/kismet/files/kismet-console-scrolling-backport.patch
new file mode 100644
index 000000000000..01baea0bb735
--- /dev/null
+++ b/net-wireless/kismet/files/kismet-console-scrolling-backport.patch
@@ -0,0 +1,12 @@
+diff -Naur kismet-2011-03-R2-orig/kis_panel_windows.cc kismet-2011-03-R2/kis_panel_windows.cc
+--- kismet-2011-03-R2-orig/kis_panel_windows.cc 2011-03-02 17:04:05.000000000 -0500
++++ kismet-2011-03-R2/kis_panel_windows.cc 2012-02-07 11:53:39.634360668 -0500
+@@ -1936,7 +1936,7 @@
+
+ // Import the existing console
+ constext->SetFollowTail(1);
+- constext->SetMaxText(50);
++ constext->SetMaxText(250);
+ if (kpinterface->FetchServerFramework() == NULL) {
+ constext->SetText("Kismet server not started (or not started via this client)");
+ textcb = -1;
diff --git a/net-wireless/kismet/files/makefile.patch b/net-wireless/kismet/files/makefile.patch
new file mode 100644
index 000000000000..5580c58346f8
--- /dev/null
+++ b/net-wireless/kismet/files/makefile.patch
@@ -0,0 +1,119 @@
+diff -Naur kismet-2011-03-R2-orig/plugin-autowep/Makefile kismet-2011-03-R2/plugin-autowep/Makefile
+--- kismet-2011-03-R2-orig/plugin-autowep/Makefile 2009-11-05 21:50:32.000000000 -0500
++++ kismet-2011-03-R2/plugin-autowep/Makefile 2011-05-31 21:15:06.000000000 -0400
+@@ -1,6 +1,7 @@
+ # You will need kismet newcore sources
+ KIS_SRC_DIR ?= /usr/src/kismet
+ KIS_INC_DIR ?= $(KIS_SRC_DIR)
++LIBDIR ?= /lib
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
+@@ -21,8 +22,8 @@
+ $(LD) $(PLUGINLDFLAGS) $(PLUGOBJS) -o $(PLUGOUT) $(LIBS)
+
+ install: $(PLUGOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$^
+
+ userinstall: $(PLUGOUT)
+ mkdir -p ${HOME}/.kismet/plugins/
+diff -Naur kismet-2011-03-R2-orig/plugin-btscan/Makefile kismet-2011-03-R2/plugin-btscan/Makefile
+--- kismet-2011-03-R2-orig/plugin-btscan/Makefile 2010-04-28 15:31:26.000000000 -0400
++++ kismet-2011-03-R2/plugin-btscan/Makefile 2011-05-31 21:23:55.000000000 -0400
+@@ -1,6 +1,7 @@
+ # You will need kismet newcore sources
+ KIS_SRC_DIR ?= /usr/src/kismet
+ KIS_INC_DIR ?= $(KIS_SRC_DIR)
++LIBDIR ?= /lib
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
+@@ -27,10 +28,10 @@
+ $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
+
+ install: $(SRVOUT) $(CLIOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet_client/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/lib/kismet_client/$(CLIOUT)
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/$(CLIOUT)
+
+ userinstall: $(SRVOUT) $(CLIOUT)
+ mkdir -p ${HOME}/.kismet/plugins/
+diff -Naur kismet-2011-03-R2-orig/plugin-dot15d4/Makefile kismet-2011-03-R2/plugin-dot15d4/Makefile
+--- kismet-2011-03-R2-orig/plugin-dot15d4/Makefile 2010-07-29 20:59:16.000000000 -0400
++++ kismet-2011-03-R2/plugin-dot15d4/Makefile 2011-05-31 21:17:25.000000000 -0400
+@@ -1,6 +1,7 @@
+ # You will need kismet newcore sources
+ KIS_SRC_DIR ?= /usr/src/kismet
+ KIS_INC_DIR ?= $(KIS_SRC_DIR)
++LIBDIR ?= /lib
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
+@@ -26,8 +27,8 @@
+ $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
+
+ install: $(SRVOUT) $(CLIOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
+
+ userinstall: $(SRVOUT) $(CLIOUT)
+ mkdir -p ${HOME}/.kismet/plugins/
+diff -Naur kismet-2011-03-R2-orig/plugin-ptw/Makefile kismet-2011-03-R2/plugin-ptw/Makefile
+--- kismet-2011-03-R2-orig/plugin-ptw/Makefile 2010-04-28 15:31:26.000000000 -0400
++++ kismet-2011-03-R2/plugin-ptw/Makefile 2011-05-31 21:18:14.000000000 -0400
+@@ -1,6 +1,7 @@
+ # You will need kismet newcore sources
+ KIS_SRC_DIR ?= /usr/src/kismet
+ KIS_INC_DIR ?= $(KIS_SRC_DIR)
++LIBDIR ?= /lib
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
+@@ -21,9 +22,8 @@
+ $(LD) $(PLUGINLDFLAGS) $(PLUGOBJS) -o $(PLUGOUT) $(LIBS)
+
+ install: $(PLUGOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
+-
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/lib/kismet/$^
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $^ $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$^
+
+ userinstall: $(PLUGOUT)
+ mkdir -p ${HOME}/.kismet/plugins/
+diff -Naur kismet-2011-03-R2-orig/plugin-spectools/Makefile kismet-2011-03-R2/plugin-spectools/Makefile
+--- kismet-2011-03-R2-orig/plugin-spectools/Makefile 2010-01-07 18:33:30.000000000 -0500
++++ kismet-2011-03-R2/plugin-spectools/Makefile 2011-05-31 21:19:09.000000000 -0400
+@@ -1,6 +1,7 @@
+ # You will need kismet newcore sources
+ KIS_SRC_DIR ?= /usr/src/kismet
+ KIS_INC_DIR ?= $(KIS_SRC_DIR)
++LIBDIR ?= /lib
+
+ include $(KIS_SRC_DIR)/Makefile.inc
+
+@@ -27,10 +28,10 @@
+ $(LD) $(PLUGINLDFLAGS) $(SRVOBJS) -o $(SRVOUT) $(LIBS)
+
+ install: $(SRVOUT) $(CLIOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/lib/kismet/$(SRVOUT)
+- mkdir -p $(DESTDIR)$(prefix)/lib/kismet_client/
+- install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/lib/kismet_client/$(CLIOUT)
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(SRVOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet/$(SRVOUT)
++ mkdir -p $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/
++ install -o $(INSTUSR) -g $(INSTGRP) -m 644 $(CLIOUT) $(DESTDIR)$(prefix)/$(LIBDIR)/kismet_client/$(CLIOUT)
+
+ userinstall: $(SRVOUT) $(CLIOUT)
+ mkdir -p ${HOME}/.kismet/plugins/
diff --git a/net-wireless/kismet/files/plugins-ldflags.patch b/net-wireless/kismet/files/plugins-ldflags.patch
new file mode 100644
index 000000000000..001ab78dab06
--- /dev/null
+++ b/net-wireless/kismet/files/plugins-ldflags.patch
@@ -0,0 +1,10 @@
+diff -Naur kismet-2011-03-R2-orig/Makefile.inc.in kismet-2011-03-R2/Makefile.inc.in
+--- kismet-2011-03-R2-orig/Makefile.inc.in 2009-11-05 21:43:30.000000000 -0500
++++ kismet-2011-03-R2/Makefile.inc.in 2011-06-01 00:13:13.000000000 -0400
+@@ -38,5 +38,5 @@
+ MAN = ${DESTDIR}@mandir@
+ WAV = ${SHARE}/wav/
+
+-PLUGINLDFLAGS = @PLUGINLDFLAGS@
++PLUGINLDFLAGS = @LDFLAGS@ @PLUGINLDFLAGS@
+
diff --git a/net-wireless/kismet/kismet-2011.03.2.ebuild b/net-wireless/kismet/kismet-2011.03.2.ebuild
new file mode 100644
index 000000000000..d03fa109dcb5
--- /dev/null
+++ b/net-wireless/kismet/kismet-2011.03.2.ebuild
@@ -0,0 +1,160 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet/kismet-2011.03.2.ebuild,v 1.1 2012/02/17 04:52:21 steev Exp $
+
+EAPI=4
+
+inherit toolchain-funcs linux-info eutils
+
+MY_P=${P/\./-}
+MY_P=${MY_P/./-R}
+S=${WORKDIR}/${MY_P}
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="https://www.kismetwireless.net/code/svn/trunk"
+ inherit subversion
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+fi
+
+DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
+HOMEPAGE="http://www.kismetwireless.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+ncurses +pcre speech +plugin-autowep +plugin-btscan +plugin-dot15d4 +plugin-ptw +plugin-spectools +ruby +suid"
+
+RDEPEND="net-wireless/wireless-tools
+ kernel_linux? ( sys-libs/libcap
+ >=dev-libs/libnl-1.1 )
+ net-libs/libpcap
+ pcre? ( dev-libs/libpcre )
+ suid? ( sys-libs/libcap )
+ ncurses? ( sys-libs/ncurses )
+ !arm? ( speech? ( app-accessibility/flite ) )
+ ruby? ( dev-lang/ruby )
+ plugin-btscan? ( net-wireless/bluez \
+ !=net-wireless/bluez-4.98-r1 )
+ plugin-dot15d4? ( <dev-libs/libusb-1 )
+ plugin-spectools? ( net-wireless/spectools )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
+ conf/kismet.conf.in
+
+ # Don't strip and set correct mangrp
+ sed -i -e 's| -s||g' \
+ -e 's|@mangrp@|root|g' Makefile.in
+
+ epatch "${FILESDIR}"/makefile.patch
+ epatch "${FILESDIR}"/plugins-ldflags.patch
+ epatch "${FILESDIR}"/bluechanfix_r3184.patch
+ epatch "${FILESDIR}"/kismet-console-scrolling-backport.patch
+}
+
+src_configure() {
+ if ! use ncurses; then
+ myconf="${myconf} --disable-curses --disable-panel"
+ fi
+
+ if ! use pcre; then
+ myconf="${myconf} --disable-pcre"
+ fi
+
+ econf ${myconf} \
+ --with-linuxheaders="${KV_DIR}"
+}
+
+src_compile() {
+ emake dep
+ emake
+
+ if use plugin-autowep; then
+ cd "${S}"/plugin-autowep
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-btscan; then
+ cd "${S}"/plugin-btscan
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-dot15d4; then
+ cd "${S}"/plugin-dot15d4
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-ptw; then
+ cd "${S}"/plugin-ptw
+ KIS_SRC_DIR="${S}" emake
+ fi
+ if use plugin-spectools; then
+ cd "${S}"/plugin-spectools
+ KIS_SRC_DIR="${S}" emake
+ fi
+}
+
+src_install() {
+ if use plugin-autowep; then
+ cd "${S}"/plugin-autowep
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-btscan; then
+ cd "${S}"/plugin-btscan
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-dot15d4; then
+ cd "${S}"/plugin-dot15d4
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-ptw; then
+ cd "${S}"/plugin-ptw
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use plugin-spectools; then
+ cd "${S}"/plugin-spectools
+ KIS_SRC_DIR="${S}" emake DESTDIR="${ED}" LIBDIR="$(get_libdir)" install
+ fi
+ if use ruby; then
+ cd "${S}"/ruby
+ dobin *.rb
+ fi
+
+ cd "${S}"
+ emake DESTDIR="${D}" commoninstall
+
+ ##dragorn would prefer I set fire to my head than do this, but it works
+ ##all external kismet plugins (read: kismet-ubertooth) must be rebuilt when kismet is
+ ##is there an automatic way to force this?
+ # install headers for external plugins
+ insinto /usr/include/kismet
+ doins *.h || die "Header installation failed"
+ doins Makefile.inc
+ #todo write a plugin finder that tells you what needs to be rebuilt when kismet is updated, etc
+
+ dodoc CHANGELOG RELEASENOTES.txt README* docs/DEVEL.client docs/README.newcore || die
+ newinitd "${FILESDIR}"/${PN}.initd kismet
+ newconfd "${FILESDIR}"/${PN}.confd kismet
+
+ insinto /etc
+ doins conf/kismet{,_drone}.conf || die
+
+ if use suid; then
+ dobin kismet_capture || die
+ fi
+}
+
+pkg_preinst() {
+ if use suid; then
+ enewgroup kismet
+ fowners root:kismet /usr/bin/kismet_capture || die
+ # Need to set the permissions after chowning.
+ # See chown(2)
+ fperms 4550 /usr/bin/kismet_capture || die
+ elog "Kismet has been installed with a setuid-root helper binary"
+ elog "to enable minimal-root operation. Users need to be part of"
+ elog "the 'kismet' group to perform captures from physical devices."
+ fi
+}
diff --git a/net-wireless/kismet/metadata.xml b/net-wireless/kismet/metadata.xml
index 0f220e806d7c..fa9726313772 100644
--- a/net-wireless/kismet/metadata.xml
+++ b/net-wireless/kismet/metadata.xml
@@ -1,16 +1,34 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>mobile</herd>
- <use>
- <flag name="client">Build the ncurses-based user interface</flag>
- <flag name="pcap">
- Enable packet capturing support using <pkg>net-libs/libpcap</pkg>
- </flag>
- <flag name="suid">
- Install a setuid root helper binary with limited functionality;
- this allows running kismet as a normal user, significantly
- reducing security risks
- </flag>
- </use>
+ <herd>mobile</herd>
+ <maintainer>
+ <email>sidhayn@gmail.com</email>
+ <description>Proxied maintainer, assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>steev@gentoo.org</email>
+ <name>Steev Klimaszewski</name>
+ <description>Proxy-maintainer, CC him on bugs</description>
+ </maintainer>
+ <use>
+ <flag name="client">Build the ncurses-based user interface</flag>
+ <flag name="pcap">
+ Enable packet capturing support using <pkg>net-libs/libpcap</pkg>
+ </flag>
+ <flag name="suid">
+ Install a setuid root helper binary with limited functionality;
+ this allows running kismet as a normal user, significantly
+ reducing security risks
+ </flag>
+ <flag name="ncurses">Build the ncurses-based user interface</flag>
+ <flag name="pcre">Build with pcre support</flag>
+ <flag name="speech">Audio support using <pkg>app-accessibility/flite</pkg></flag>
+ <flag name="plugin-autowep">Build the autowep plugin</flag>
+ <flag name="plugin-btscan">Build the btscan plugin</flag>
+ <flag name="plugin-dot15d4">Build the dot15d4 plugin</flag>
+ <flag name="plugin-ptw">Build the ptw plugin</flag>
+ <flag name="plugin-spectools">Build the spectools plugin. This uses <pkg>net-wireless/spectools</pkg></flag>
+ <flag name="ruby">Build extras which are written in ruby, example plugins and the like.</flag>
+ </use>
</pkgmetadata>