summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Bennett <spb@gentoo.org>2008-02-07 20:58:42 +0000
committerStephen Bennett <spb@gentoo.org>2008-02-07 20:58:42 +0000
commitf7428dbe034c2482f79677da469b7571e2a87efa (patch)
tree77b4dd3a08f0a8942330b7f543247f8abfd9b0d8 /net-wireless
parentChanged dependency on virtual/ghostscript to app-text/ghostscript-gpl. Fixes ... (diff)
downloadgentoo-2-f7428dbe034c2482f79677da469b7571e2a87efa.tar.gz
gentoo-2-f7428dbe034c2482f79677da469b7571e2a87efa.tar.bz2
gentoo-2-f7428dbe034c2482f79677da469b7571e2a87efa.zip
Version bump, thanks to Geoffrey Clements in bug #196664
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-wireless')
-rw-r--r--net-wireless/acx/ChangeLog10
-rw-r--r--net-wireless/acx/acx-0.3.37_p20080112.ebuild48
-rw-r--r--net-wireless/acx/files/acx-0.3.37_p20080112.patch38
3 files changed, 94 insertions, 2 deletions
diff --git a/net-wireless/acx/ChangeLog b/net-wireless/acx/ChangeLog
index f1e36a84aa83..a4f94f187df8 100644
--- a/net-wireless/acx/ChangeLog
+++ b/net-wireless/acx/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-wireless/acx
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.12 2007/07/27 06:21:23 genstef Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/ChangeLog,v 1.13 2008/02/07 20:58:41 spb Exp $
+
+*acx-0.3.37_p20080112 (07 Feb 2008)
+
+ 07 Feb 2008; Stephen Bennett <spb@gentoo.org>
+ +files/acx-0.3.37_p20080112.patch, +acx-0.3.37_p20080112.ebuild:
+ Version bump, thanks to Geoffrey Clements in bug #196664
27 Jul 2007; Stefan Schweizer <genstef@gentoo.org>
-files/acx-0.3.35-2.6.18.patch, +files/acx-0.3.35_p20070101-2.6.22.patch,
diff --git a/net-wireless/acx/acx-0.3.37_p20080112.ebuild b/net-wireless/acx/acx-0.3.37_p20080112.ebuild
new file mode 100644
index 000000000000..3b943c8a4d82
--- /dev/null
+++ b/net-wireless/acx/acx-0.3.37_p20080112.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/acx/acx-0.3.37_p20080112.ebuild,v 1.1 2008/02/07 20:58:41 spb Exp $
+
+inherit linux-mod
+
+PATCHLEVEL=${PV##*_p}
+
+DESCRIPTION="Driver for the ACX100 and ACX111 wireless chipset (CardBus, PCI, USB)"
+HOMEPAGE="http://acx100.sourceforge.net/"
+SRC_URI="http://downloads.sourceforge.net/acx100/${PN}-${PATCHLEVEL}-2.tar.bz2"
+
+LICENSE="GPL-2 as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="debug"
+
+RDEPEND="net-wireless/wireless-tools
+ net-wireless/acx-firmware"
+
+S=${WORKDIR}/${PN}-${PATCHLEVEL}
+
+MODULE_NAMES="acx(net:${S})"
+CONFIG_CHECK="WIRELESS_EXT FW_LOADER"
+BUILD_TARGETS="modules"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="-C ${KV_DIR} SUBDIRS=${S}"
+}
+
+src_unpack() {
+ unpack ${A}
+ chmod ug+w . -R
+
+ # The default acx_config.h has some rather over-zealous debug output.
+ cd $S
+ if ! use debug; then
+ sed -i '/^#define ACX_DEBUG/s/2/0/' acx_config.h || die "Failed to disable debug support"
+ fi
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dodoc README
+}
diff --git a/net-wireless/acx/files/acx-0.3.37_p20080112.patch b/net-wireless/acx/files/acx-0.3.37_p20080112.patch
new file mode 100644
index 000000000000..ecfbd3c8a9e4
--- /dev/null
+++ b/net-wireless/acx/files/acx-0.3.37_p20080112.patch
@@ -0,0 +1,38 @@
+--- acx-20080112/pci.c.orig
++++ acx-20080112/pci.c
+@@ -1632,8 +1632,10 @@
+ acx_show_card_eeprom_id(adev);
+ #endif /* NONESSENTIAL_FEATURES */
+
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ #ifdef SET_MODULE_OWNER
+- SET_MODULE_OWNER(ndev);
++ SET_MODULE_OWNER(ndev);
++#endif
+ #endif
+ SET_NETDEV_DEV(ndev, &pdev->dev);
+
+@@ -2128,7 +2130,11 @@
+ /* TODO: pci_set_power_state(pdev, PCI_D0); ? */
+
+ /* request shared IRQ handler */
++ #if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,21))
++ if (request_irq(ndev->irq, acxpci_i_interrupt, IRQF_SHARED, ndev->name, ndev)) {
++ #else
+ if (request_irq(ndev->irq, acxpci_i_interrupt, SA_SHIRQ, ndev->name, ndev)) {
++ #endif
+ printk("%s: request_irq FAILED\n", ndev->name);
+ result = -EAGAIN;
+ goto done;
+--- acx-20080112/usb.c.orig
++++ acx-20080112/usb.c
+@@ -859,7 +859,9 @@
+ ndev->watchdog_timeo = 4 * HZ;
+ #endif
+ ndev->change_mtu = &acx_e_change_mtu;
++#if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,24))
+ SET_MODULE_OWNER(ndev);
++#endif
+
+ /* Setup private driver context */
+