summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-08-28 22:32:13 +0000
committerBen Lutgens <lamer@gentoo.org>2001-08-28 22:32:13 +0000
commit9ffb9743c862c6ab924bb84800d17c7054a3d007 (patch)
tree16dab5e3d0f13ee69e5d834a59e0bb00d1a4e2c1 /net-www/lynx
parentfixing digest for fixed archive (diff)
downloadgentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.tar.gz
gentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.tar.bz2
gentoo-2-9ffb9743c862c6ab924bb84800d17c7054a3d007.zip
added new category x11-misc and updated portage.py to reflect that.
changed "try make" to "make || die" in xinetd. The rest got moved out of incomming and into main tree. fakeidentd has a shitty init script, and leafnode don't have one at all yet.
Diffstat (limited to 'net-www/lynx')
-rw-r--r--net-www/lynx/files/digest-lynx-2.8.4a-r12
-rw-r--r--net-www/lynx/lynx-2.8.4a-r1.ebuild55
2 files changed, 57 insertions, 0 deletions
diff --git a/net-www/lynx/files/digest-lynx-2.8.4a-r1 b/net-www/lynx/files/digest-lynx-2.8.4a-r1
new file mode 100644
index 000000000000..3d9b6bf8f96a
--- /dev/null
+++ b/net-www/lynx/files/digest-lynx-2.8.4a-r1
@@ -0,0 +1,2 @@
+MD5 6916c0127839f1e454052b683e4691c4 lynx2.8.4.tar.bz2
+MD5 b0b269efc9ff697e40a10f99919599ea lynx2.8.4rel.1a.patch
diff --git a/net-www/lynx/lynx-2.8.4a-r1.ebuild b/net-www/lynx/lynx-2.8.4a-r1.ebuild
new file mode 100644
index 000000000000..7f864e535d55
--- /dev/null
+++ b/net-www/lynx/lynx-2.8.4a-r1.ebuild
@@ -0,0 +1,55 @@
+ # Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Woodchip
+# $Header: /var/cvsroot/gentoo-x86/net-www/lynx/lynx-2.8.4a-r1.ebuild,v 1.1 2001/08/28 22:32:13 lamer Exp $
+
+A="lynx2.8.4.tar.bz2 lynx2.8.4rel.1a.patch"
+S=${WORKDIR}/lynx2-8-4
+HOMEPAGE="http://lynx.browser.org/"
+SRC_URI="ftp://lynx.isc.org/lynx/lynx2.8.4/lynx2.8.4.tar.bz2
+ ftp://lynx.isc.org/lynx/lynx2.8.4/patches/lynx2.8.4rel.1a.patch"
+
+DESCRIPTION="An excellent console-based web browser"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3
+
+ nls? ( sys-devel/gettext )
+ ssl? ( >= dev-libs/openssl-0.9.6 )"
+
+src_unpack() {
+ unpack lynx2.8.4.tar.bz2
+ cd ${S}
+ patch -p1 < ${DISTDIR}/lynx2.8.4rel.1a.patch || die
+}
+
+src_compile() {
+ local myconf
+ use nls && myconf="${myconf} --enable-nls"
+ use ssl && myconf="${myconf} --with-ssl=/usr"
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ ./configure --prefix=/usr --mandir=/usr/share/man --datadir=/usr/share \
+ --libdir=/etc/lynx --enable-cgi-links --enable-prettysrc \
+ --enable-nsl-fork --enable-file-upload --enable-read-eta \
+ --enable-libjs --enable-color-style --enable-scrollbar \
+ --enable-included-msgs --with-zlib --host=${CHOST} ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr datadir=${D}/usr/share mandir=${D}/usr/share/man \
+ libdir=${D}/etc/lynx install || die
+
+ dodoc CHANGES COPYHEADER COPYING INSTALLATION PROBLEMS README
+ docinto docs
+ dodoc docs/*
+ docinto lynx_help
+ dodoc lynx_help/*.txt
+ docinto html
+ dodoc lynx_help/*.html
+ docinto html/keystrokes
+ dodoc lynx_help/keystrokes/*.html
+}