summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
committerDonny Davies <woodchip@gentoo.org>2002-11-28 20:34:47 +0000
commit8dd3251fa7dae793784328bd9ee3dd785e0ae7d1 (patch)
treec0e41921790ed05d7deb4377b5c14d0bc7ce00cc /net-www/mod_auth_kerb
parentnew Apache2 module (diff)
downloadgentoo-2-8dd3251fa7dae793784328bd9ee3dd785e0ae7d1.tar.gz
gentoo-2-8dd3251fa7dae793784328bd9ee3dd785e0ae7d1.tar.bz2
gentoo-2-8dd3251fa7dae793784328bd9ee3dd785e0ae7d1.zip
new Apache2 module
Diffstat (limited to 'net-www/mod_auth_kerb')
-rw-r--r--net-www/mod_auth_kerb/ChangeLog8
-rw-r--r--net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf7
-rw-r--r--net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.111
-rw-r--r--net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch21
-rw-r--r--net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild37
5 files changed, 74 insertions, 0 deletions
diff --git a/net-www/mod_auth_kerb/ChangeLog b/net-www/mod_auth_kerb/ChangeLog
new file mode 100644
index 000000000000..969639b639f4
--- /dev/null
+++ b/net-www/mod_auth_kerb/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-www/mod_auth_kerb
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/ChangeLog,v 1.1 2002/11/28 20:30:59 woodchip Exp $
+
+*mod_auth_kerb-4.11 (28 Nov 2002)
+
+ 28 Nov 2002; Donny Davies <woodchip@gentoo.org> :
+ Initial import; created by me.
diff --git a/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
new file mode 100644
index 000000000000..58e117c84fd0
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/11_mod_auth_kerb.conf
@@ -0,0 +1,7 @@
+<IfDefine AUTH_KERB>
+ <IfModule !mod_auth_kerb.c>
+ LoadModule kerb_auth_module extramodules/mod_auth_kerb.so
+ </IfModule>
+</IfDefine>
+
+#Place configuration directives here
diff --git a/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11 b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11
new file mode 100644
index 000000000000..4464766cbc16
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/digest-mod_auth_kerb-4.11
@@ -0,0 +1 @@
+MD5 2f2c8a52117bfa6248a2c688efb52621 mod_auth_kerb-4.11.tar.gz 14053
diff --git a/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch b/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch
new file mode 100644
index 000000000000..c696324d8b4b
--- /dev/null
+++ b/net-www/mod_auth_kerb/files/mod_auth_kerb_register.patch
@@ -0,0 +1,21 @@
+--- src/modules/kerberos/mod_auth_kerb.c.orig 2002-09-05 08:21:45.000000000 -0400
++++ src/modules/kerberos/mod_auth_kerb.c 2002-09-05 08:24:25.000000000 -0400
+@@ -1932,11 +1932,18 @@
+ return rec;
+ }
+
++static int kerbauth_init_handler(apr_pool_t *p, apr_pool_t *plog,
++ apr_pool_t *ptemp, server_rec *s)
++{
++ ap_add_version_component(p, "auth_kerberos/4.11");
++ return OK;
++}
+
+ /* register the functions in the correct places */
+ #ifdef APXS2
+ static void register_hooks(apr_pool_t *p)
+ {
++ ap_hook_post_config(kerbauth_init_handler, NULL, NULL, APR_HOOK_MIDDLE);
+ ap_hook_check_user_id(kerb_authenticate_user, NULL, NULL, APR_HOOK_MIDDLE);
+ #ifdef HESIOD
+ ap_hook_access_checker(check_user_access, NULL, NULL, APR_HOOK_MIDDLE);
diff --git a/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild b/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild
new file mode 100644
index 000000000000..541c46664e81
--- /dev/null
+++ b/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mod_auth_kerb/mod_auth_kerb-4.11.ebuild,v 1.1 2002/11/28 20:30:59 woodchip Exp $
+
+inherit eutils
+
+DESCRIPTION="An Apache2 authentication DSO using Kerberos"
+HOMEPAGE="http://modauthkerb.sourceforge.net/"
+
+S=${WORKDIR}/src
+SRC_URI="mirror://sourceforge/modauthkerb/${P}.tar.gz"
+DEPEND="app-crypt/krb5 =net-www/apache-2*"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE=""
+SLOT="0"
+
+src_unpack() {
+ unpack ${A} || die; cd ${S} || die;
+ epatch ${FILESDIR}/mod_auth_kerb_register.patch
+}
+
+src_compile() {
+ cd modules/kerberos
+ apxs2 -DAPXS2 -DKRB5 -DKRB5_SAVE_CREDENTIALS \
+ -DKRB_DEF_REALM=\\\"EOS.NCSU.EDU\\\" \
+ -ldl -lkrb5 -lcom_err -lk5crypto -c ${PN}.c || die
+}
+
+src_install() {
+ exeinto /usr/lib/apache2-extramodules
+ doexe modules/kerberos/.libs/${PN}.so
+ insinto /etc/apache2/conf/modules.d
+ doins ${FILESDIR}/11_mod_auth_kerb.conf
+ dodoc ${FILESDIR}/11_mod_auth_kerb.conf
+ #thats all the docs there is right now!
+}