summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Holzer <mholzer@gentoo.org>2004-04-21 21:51:19 +0000
committerMartin Holzer <mholzer@gentoo.org>2004-04-21 21:51:19 +0000
commitde7401c3013fbb50727aaef9acd5affc7a954a67 (patch)
tree2a53d89a5f161a0f54122691981c7252cefc28bd /net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild
parentpostinst() fix (Manifest recommit) (diff)
downloadgentoo-2-de7401c3013fbb50727aaef9acd5affc7a954a67.tar.gz
gentoo-2-de7401c3013fbb50727aaef9acd5affc7a954a67.tar.bz2
gentoo-2-de7401c3013fbb50727aaef9acd5affc7a954a67.zip
Version bumped.
Diffstat (limited to 'net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild')
-rw-r--r--net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild b/net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild
new file mode 100644
index 000000000000..4a8a8d0acbca
--- /dev/null
+++ b/net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/mplayerplug-in/mplayerplug-in-2.60.ebuild,v 1.1 2004/04/21 21:51:19 mholzer Exp $
+
+inherit nsplugins
+
+S=${WORKDIR}/${PN}
+GECKO_SDK="gecko-sdk-i686-pc-linux-gnu-1.6.tar.gz"
+
+DESCRIPTION="mplayer plug-in for Mozilla"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ x86? ( ftp://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.6/${GECKO_SDK} ) "
+HOMEPAGE="http://mplayerplug-in.sourceforge.net/"
+
+KEYWORDS="~x86 ~amd64 ~ia64 ~ppc ~sparc ~alpha ~hppa ~mips"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=media-video/mplayer-0.92"
+
+src_compile() {
+ local myconf
+ use x86 && myconf="${myconf} --with-gecko-sdk=${WORKDIR}/gecko-sdk"
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ exeinto /opt/netscape/plugins
+ doexe mplayerplug-in.so
+ inst_plugin /opt/netscape/plugins/mplayerplug-in.so
+
+ insinto /etc
+ doins mplayerplug-in.conf
+
+ dodoc ChangeLog INSTALL LICENSE README
+}