summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFerry Meyndert <m0rpheus@gentoo.org>2002-02-25 13:12:34 +0000
committerFerry Meyndert <m0rpheus@gentoo.org>2002-02-25 13:12:34 +0000
commitc815876a2814e91175fd4a540cf9be3b1dabcc26 (patch)
treed09638d77d41981066c0f9c84ebd09ef6410c2d0 /net-www/squid
parentinitial ebuild for perl SDL binding (diff)
downloadgentoo-2-c815876a2814e91175fd4a540cf9be3b1dabcc26.tar.gz
gentoo-2-c815876a2814e91175fd4a540cf9be3b1dabcc26.tar.bz2
gentoo-2-c815876a2814e91175fd4a540cf9be3b1dabcc26.zip
new version fix some bugs en overflows that can cause probs in the near
furture
Diffstat (limited to 'net-www/squid')
-rw-r--r--net-www/squid/files/digest-squid-2.4.3s1
-rw-r--r--net-www/squid/squid-2.4.3s.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/net-www/squid/files/digest-squid-2.4.3s b/net-www/squid/files/digest-squid-2.4.3s
new file mode 100644
index 000000000000..f6155beb26c7
--- /dev/null
+++ b/net-www/squid/files/digest-squid-2.4.3s
@@ -0,0 +1 @@
+MD5 5fdaf22d66d7b776325902adc0fd438d squid-2.4.STABLE3-src.tar.gz 1081040
diff --git a/net-www/squid/squid-2.4.3s.ebuild b/net-www/squid/squid-2.4.3s.ebuild
new file mode 100644
index 000000000000..0332294312b6
--- /dev/null
+++ b/net-www/squid/squid-2.4.3s.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-www/squid/squid-2.4.3s.ebuild,v 1.1 2002/02/25 13:12:34 m0rpheus Exp $
+
+DESCRIPTION="A caching web proxy, with advanced features"
+HOMEPAGE="http://www.squid-cache.org/"
+
+P=squid-2.4.STABLE3
+S=${WORKDIR}/${P}
+SRC_URI="ftp://ftp.squid-cache.org/pub/squid-2/STABLE/${P}-src.tar.gz
+ ftp://sunsite.auc.dk/pub/infosystems/squid/squid-2/STABLE/${P}-src.tar.gz"
+
+RDEPEND="virtual/glibc
+ ldap? ( >=net-nds/openldap-1.2.11 )
+ pam? ( >=sys-libs/pam-0.72 )"
+DEPEND="$RDEPEND sys-devel/perl"
+
+
+src_compile() {
+
+ local myconf mymodules="getpwnam,YP,NCSA,SMB"
+ use pam && mymodules="PAM,${mymodules}"
+ use ldap && mymodules="LDAP,${mymodules}"
+ use snmp && myconf="--enable-snmp"
+
+ ./configure \
+ --prefix=/ \
+ --bindir=/usr/sbin \
+ --exec-prefix=/usr \
+ --localstatedir=/var \
+ --sysconfdir=/etc/squid \
+ --libexecdir=/usr/lib/squid \
+ --enable-auth-modules=${mymodules} \
+ --enable-storeio="ufs,diskd,coss,aufs,null" \
+ --enable-removal-policies="lru,heap" \
+ --enable-linux-netfilter \
+ --disable-ident-lookups \
+ --enable-useragent-log \
+ --enable-delay-pools \
+ --enable-referer-log \
+ --enable-truncate \
+ --enable-arp-acl \
+ --with-pthreads \
+ --enable-htcp \
+ --enable-carp \
+ --enable-icmp \
+ --host=${CHOST} ${myconf} || die
+
+ make || die "compile problem :("
+}
+
+src_install() {
+
+ make \
+ prefix=${D}/usr \
+ bindir=${D}/usr/sbin \
+ localstatedir=${D}/var \
+ sysconfdir=${D}/etc/squid \
+ libexecdir=${D}/usr/lib/squid \
+ install || die
+
+ make -C src install-pinger libexecdir=${D}/usr/lib/squid || die
+
+ # We need to do this after install, else it gets removed again
+ dodir /var/log /var/spool
+ diropts -m 770 -o root -g squid ; dodir /var/log/squid
+ diropts -m 770 -o root -g squid ; dodir /var/spool/squid
+
+
+ # some cleanup action
+ mv ${D}/usr/sbin/*_auth* ${D}/usr/lib/squid
+ mv ${D}/etc/squid/errors ${D}/usr/lib/squid
+
+ # pinger needs root to bind to privelaged ports
+ chown root.squid ${D}/usr/lib/squid/pinger
+ chmod 4750 ${D}/usr/lib/squid/pinger
+ # pam_auth needs root to authenticate everybody. i think the others
+ # do too so just do them all now. keep an eye on these things..
+ chown root.squid ${D}/usr/lib/squid/*_auth*
+ chmod 4750 ${D}/usr/lib/squid/*_auth*
+
+ dodoc README QUICKSTART CONTRIBUTORS COPYRIGHT
+ dodoc COPYING CREDITS ChangeLog TODO
+ newdoc auth_modules/SMB/README SMB.auth.readme
+ newdoc auth_modules/LDAP/README LDAP.auth.readme
+ doman auth_modules/LDAP/*.8 doc/tree.3
+ docinto txt ; dodoc doc/*.txt
+
+ insinto /etc/pam.d ; newins ${FILESDIR}/squid.pam squid
+ exeinto /etc/init.d ; newexe ${FILESDIR}/squid.rc6 squid
+ insinto /etc/conf.d ; newins ${FILESDIR}/squid.confd squid
+}