summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-02-28 06:42:23 +0000
committerMike Frysinger <vapier@gentoo.org>2003-02-28 06:42:23 +0000
commit36bf408a34e1ef7e281a207cfc2a2613e719060c (patch)
tree231a8f42ee550921e0a04a00336fdd04c4272857 /net-www
parentChanged to x86 (diff)
downloadgentoo-2-36bf408a34e1ef7e281a207cfc2a2613e719060c.tar.gz
gentoo-2-36bf408a34e1ef7e281a207cfc2a2613e719060c.tar.bz2
gentoo-2-36bf408a34e1ef7e281a207cfc2a2613e719060c.zip
initial ebuild for #16423
Diffstat (limited to 'net-www')
-rw-r--r--net-www/plb/ChangeLog8
-rw-r--r--net-www/plb/files/digest-plb-0.31
-rw-r--r--net-www/plb/files/plb.conf84
-rw-r--r--net-www/plb/files/plb.rc619
-rw-r--r--net-www/plb/plb-0.3.ebuild38
5 files changed, 150 insertions, 0 deletions
diff --git a/net-www/plb/ChangeLog b/net-www/plb/ChangeLog
new file mode 100644
index 000000000000..a1e0a443879f
--- /dev/null
+++ b/net-www/plb/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for net-misc/plb
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/plb/ChangeLog,v 1.1 2003/02/28 06:42:23 vapier Exp $
+
+*plb-0.3 (28 Feb 2003)
+
+ 28 Feb 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by the maintainer of plb for #16423.
diff --git a/net-www/plb/files/digest-plb-0.3 b/net-www/plb/files/digest-plb-0.3
new file mode 100644
index 000000000000..92f29169bd4b
--- /dev/null
+++ b/net-www/plb/files/digest-plb-0.3
@@ -0,0 +1 @@
+MD5 74c1dee5387afc6cff169b0cf8767bbd plb-0.3.tar.gz 101701
diff --git a/net-www/plb/files/plb.conf b/net-www/plb/files/plb.conf
new file mode 100644
index 000000000000..52fb134832aa
--- /dev/null
+++ b/net-www/plb/files/plb.conf
@@ -0,0 +1,84 @@
+
+#
+# PURE LOAD BALANCER - Sample configuration file
+#
+# Put this file into /etc/plb.conf, or run the load balancer with
+# plb -c /path/to/plb.conf
+#
+
+
+
+# This is the IP address and port the load balancer answers on.
+# To listen to all interfaces, just use 0.0.0.0 for the IP address.
+
+listen_ip 0.0.0.0
+listen_port 80
+
+# Bind family. 0 for IPv4, 1 for IPv6.
+
+bind_ipv6 0
+
+# Protocol to balance : HTTP (SMTP is not implemented yet)
+
+protocol HTTP
+
+# IP addresses of the real web servers. Use space as a separator.
+# IPv4 and IPv6 addresses are allowed.
+
+servers_ip 10.1.1.1 10.1.1.2 10.1.1.3
+servers_port 80
+
+# After binding ports, the load balancer chroots to an empty (recommended)
+# directory, and drops privileges.
+
+user nobody
+group nobody
+chroot_dir /var/empty
+
+# Timeouts to avoid clients use unneeded slots on your servers
+# with idle connections. Values are in seconds.
+
+timeout_header_client_read 30
+timeout_header_client_write 30
+timeout_header_server_read 30
+timeout_header_server_write 30
+timeout_forward_client_read 30
+timeout_forward_client_write 30
+timeout_forward_server_read 30
+timeout_forward_server_write 30
+
+# When a server goes down, the load balancer will try to probe it at regular
+# interval in order to bring it back to life.
+# This is the delay, in seconds, between probes.
+
+timeout_cleanup 15
+
+# Really mark a server down after this many consecutive failures.
+
+server_retry 5
+
+# The total maximal number of clients to allow
+
+max_clients 1000
+
+# The backlog. Try something like (max_clients / 10) for extreme cases.
+
+backlog 100
+
+# The log file verbosity.
+# 0 => everything, including debugging info (not recommended)
+# 1 => all errors, all warnings, all common notifications
+# 2 => all errors, all warnings
+# 3 => quiet mode, fatal errors only
+# default is 2. Leave this commented if you want to override it with
+# the -d command-line switch.
+
+# log_level 2
+
+# By default, PLB will send error to the standard error file descriptor,
+# thus making it possible to use software like multilog.
+# If you want the load balancer to directly write to a file, uncomment the
+# following line :
+
+# log_file /var/log/plb.log
+
diff --git a/net-www/plb/files/plb.rc6 b/net-www/plb/files/plb.rc6
new file mode 100644
index 000000000000..e7ecee02db71
--- /dev/null
+++ b/net-www/plb/files/plb.rc6
@@ -0,0 +1,19 @@
+#!/sbin/runscript
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting plb"
+ start-stop-daemon --start --quiet --exec /usr/bin/plb -- --daemonize --config=/etc/plb.conf
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping plb"
+ start-stop-daemon --stop --quiet --pidfile /var/run/plb.pid
+ eend $?
+}
diff --git a/net-www/plb/plb-0.3.ebuild b/net-www/plb/plb-0.3.ebuild
new file mode 100644
index 000000000000..808810fa46b0
--- /dev/null
+++ b/net-www/plb/plb-0.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/plb/plb-0.3.ebuild,v 1.1 2003/02/28 06:42:23 vapier Exp $
+
+DESCRIPTION="A free high-performance HTTP load balancer"
+SRC_URI="http://plb.sunsite.dk/files/${P}.tar.gz"
+HOMEPAGE="http://plb.sunsite.dk/"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE=""
+
+DEPEND="virtual/glibc
+ >=dev-libs/libevent-0.6"
+
+src_compile() {
+ econf || die
+ emake || die "compile problem"
+}
+
+src_install() {
+ einstall || die
+
+ dodoc AUTHORS CONTACT ChangeLog README NEWS THANKS
+
+ insinto /etc/
+ doins ${FILESDIR}/plb.conf
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/plb.rc6 plb
+}
+
+pkg_postinst() {
+ einfo "Before starting Pure Load Balancer, you have to edit the /etc/plb.conf file."
+ echo
+ ewarn "It's *really* important to read the README provided with the software."
+ ewarn "Just point your browser at http://plb.sunsite.dk/README"
+}