summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChuck Short <zul@gentoo.org>2004-05-25 13:22:19 +0000
committerChuck Short <zul@gentoo.org>2004-05-25 13:22:19 +0000
commit71ea750e94dfb38d15bd371d43d92b245aa06b21 (patch)
treedc7c063d1cabd863ad8471eee8b8f5309c3ccc1d /net-www
parentAdded USE_DVD= to keep people from overriding USE_DVD on the command line. T... (diff)
downloadgentoo-2-71ea750e94dfb38d15bd371d43d92b245aa06b21.tar.gz
gentoo-2-71ea750e94dfb38d15bd371d43d92b245aa06b21.tar.bz2
gentoo-2-71ea750e94dfb38d15bd371d43d92b245aa06b21.zip
Added static support for adding mod_ldap.
Diffstat (limited to 'net-www')
-rw-r--r--net-www/apache/ChangeLog5
-rw-r--r--net-www/apache/apache-2.0.49-r2.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/net-www/apache/ChangeLog b/net-www/apache/ChangeLog
index 368deb36c6ab..3f073194f662 100644
--- a/net-www/apache/ChangeLog
+++ b/net-www/apache/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-www/apache
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.170 2004/05/24 08:47:56 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/ChangeLog,v 1.171 2004/05/25 13:22:19 zul Exp $
+
+ 25 May 2004; <chuck@gentoo.org> apache-2.0.49-r2.ebuild:
+ Added static support for adding mod_ldap.
24 May 2004; Bryan Østergaard <kloeri@gentoo.org> apache-1.3.31.ebuild:
Stable on alpha.
diff --git a/net-www/apache/apache-2.0.49-r2.ebuild b/net-www/apache/apache-2.0.49-r2.ebuild
index 0d5ef715fcfe..cb04f3f42f4e 100644
--- a/net-www/apache/apache-2.0.49-r2.ebuild
+++ b/net-www/apache/apache-2.0.49-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r2.ebuild,v 1.5 2004/05/23 16:44:18 zul Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.49-r2.ebuild,v 1.6 2004/05/25 13:22:19 zul Exp $
inherit flag-o-matic eutils fixheadtails gnuconfig
@@ -26,7 +26,7 @@ DEPEND="dev-util/yacc
gdbm? ( sys-libs/gdbm )
doc? ( =app-doc/apache-manual-2.0.49-r1 )
!mips? ( ldap? ( =net-nds/openldap-2* ) )"
-IUSE="berkdb gdbm ldap threads ipv6 doc"
+IUSE="berkdb gdbm ldap threads ipv6 doc static"
apache_setup_vars() {
# Sets the USERDIR to default.
@@ -119,7 +119,11 @@ src_compile() {
sleep 5s
else
einfo "Enabling LDAP"
- myconf="--with-ldap --enable-auth-ldap=shared --enable-ldap=shared"
+ if use static;
+ then
+ myconf="--with-ldap --enable-auth-ldap=static --enable-ldap=static"
+ else
+ myconf="--with-ldap --enable-auth-ldap=shared --enable-ldap=shared"
fi
fi