summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2003-05-10 06:57:17 +0000
committerGeorge Shapovalov <george@gentoo.org>2003-05-10 06:57:17 +0000
commit825871fc78b68675de8cfd992d6ee04f7dab1145 (patch)
tree958a365b8882c82f9c28c64c2ce1ebf98aec7de0 /net-www
parentUpdated ebuild. Closes #15721 (~x86 masked) (diff)
downloadgentoo-2-825871fc78b68675de8cfd992d6ee04f7dab1145.tar.gz
gentoo-2-825871fc78b68675de8cfd992d6ee04f7dab1145.tar.bz2
gentoo-2-825871fc78b68675de8cfd992d6ee04f7dab1145.zip
fix to make phoenix install under /opt, per FHS
Diffstat (limited to 'net-www')
-rw-r--r--net-www/phoenix-bin/ChangeLog7
-rw-r--r--net-www/phoenix-bin/files/digest-phoenix-bin-0.5-r11
-rw-r--r--net-www/phoenix-bin/files/phoenix-opt20
-rw-r--r--net-www/phoenix-bin/phoenix-bin-0.5-r1.ebuild54
4 files changed, 81 insertions, 1 deletions
diff --git a/net-www/phoenix-bin/ChangeLog b/net-www/phoenix-bin/ChangeLog
index 1b6923ad1860..7ccc6d3e3a5d 100644
--- a/net-www/phoenix-bin/ChangeLog
+++ b/net-www/phoenix-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/phoenix-bin
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.20 2003/03/23 17:50:06 phoenix Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/ChangeLog,v 1.21 2003/05/10 06:57:17 george Exp $
+
+*phoenix-bin-0.5-r1 (09 May 2003)
+
+ 09 May 2003; George Shapovalov <george@gentoo.org> phoenix-bin-0.5-r1.ebuild, files/{phoenix-opt,digest-phoenix-bin-0.5-r1} :
+ changed ebuild to install phoenix under /opt per robbat2's request
*phoenix-bin-0.5 (30 Dec 2002)
diff --git a/net-www/phoenix-bin/files/digest-phoenix-bin-0.5-r1 b/net-www/phoenix-bin/files/digest-phoenix-bin-0.5-r1
new file mode 100644
index 000000000000..dd9be5bf8d01
--- /dev/null
+++ b/net-www/phoenix-bin/files/digest-phoenix-bin-0.5-r1
@@ -0,0 +1 @@
+MD5 6cd5cdb4d7106a2d3843e4f907831ab7 phoenix-0.5-i686-pc-linux-gnu.tar.gz 9153046
diff --git a/net-www/phoenix-bin/files/phoenix-opt b/net-www/phoenix-bin/files/phoenix-opt
new file mode 100644
index 000000000000..9b5a4f78ae4f
--- /dev/null
+++ b/net-www/phoenix-bin/files/phoenix-opt
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/files/phoenix-opt,v 1.1 2003/05/10 06:57:17 george Exp $
+
+# This is the Gentoo Phoenix startup script
+# Additions, suggestions?
+# contact phoen][x <phoenix@gentoo.org>
+
+export MOZILLA_FIVE_HOME="/opt/phoenix"
+PHOENIX_PATH="/opt/phoenix"
+
+if [ -z "`/bin/ps x | /bin/grep \"[0-9] ${PHOENIX_PATH}/phoenix-bin\"`" ]; then
+ # No phoenix running
+ ${PHOENIX_PATH}/phoenix $@
+else
+ # phoenix running - open a new window
+ ${PHOENIX_PATH}/phoenix -remote "openURL($@ ,new-window)"
+fi
diff --git a/net-www/phoenix-bin/phoenix-bin-0.5-r1.ebuild b/net-www/phoenix-bin/phoenix-bin-0.5-r1.ebuild
new file mode 100644
index 000000000000..ad85e0df16a4
--- /dev/null
+++ b/net-www/phoenix-bin/phoenix-bin-0.5-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-www/phoenix-bin/phoenix-bin-0.5-r1.ebuild,v 1.1 2003/05/10 06:57:17 george Exp $
+
+IUSE=""
+
+MY_PN=${PN/-bin/}
+S=${WORKDIR}/${MY_PN}
+DESCRIPTION="The Phoenix Web Browser"
+SRC_URI="http://ftp.mozilla.org/pub/${MY_PN}/releases/${PV}/${MY_PN}-${PV}-i686-pc-linux-gnu.tar.gz"
+HOMEPAGE="http://www.mozilla.org/projects/phoenix/"
+RESTRICT="nostrip"
+
+KEYWORDS="~x86 -ppc -sparc -alpha"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+
+DEPEND="virtual/glibc"
+RDEPEND=">=sys-libs/lib-compat-1.0-r2
+ ( gtk2? >=x11-libs/gtk+-2.0.8 :
+ =x11-libs/gtk+-1.2* )
+ virtual/x11
+ !net-www/phoenix-cvs"
+
+src_install() {
+ # Plugin path creation
+ PLUGIN_DIR="/usr/lib/nsbrowser/plugins"
+ dodir /${PLUGIN_DIR}
+
+ dodir /opt
+
+ mv ${S} ${D}/opt
+
+ # Plugin path setup (rescuing the existent plugins)
+ src_mv_plugins /opt/${MY_PN}/plugins
+
+ # Fixing permissions
+ chown -R root.root ${D}/opt/${MY_PN}
+
+ # Truetype fonts
+ cd ${D}/opt/${MY_PN}/defaults/pref
+ einfo "Enabling truetype fonts"
+ patch < ${FILESDIR}/phoenix-0.4-antialiasing-patch
+
+ # Misc stuff
+ cp ${FILESDIR}/phoenix-opt ${WORKDIR}/phoenix
+ dobin ${WORKDIR}/phoenix
+ dosym /opt/libstdc++-libc6.1-1.so.2 /opt/${MY_PN}/libstdc++-libc6.2-2.so.3
+}
+
+pkg_preinst() {
+ # Remove the old plugins dir
+ pkg_mv_plugins /opt/${MY_PN}/plugins
+}