summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2008-05-05 20:42:01 +0000
committerAlfredo Tupone <tupone@gentoo.org>2008-05-05 20:42:01 +0000
commitbb5a75c7c655ea99149f56ae31bb311751f40a9e (patch)
treea1cf9dfe181af74b33dc902542e1d541bc229074 /net-zope
parentamd64 stable, bug #220069 (diff)
downloadgentoo-2-bb5a75c7c655ea99149f56ae31bb311751f40a9e.tar.gz
gentoo-2-bb5a75c7c655ea99149f56ae31bb311751f40a9e.tar.bz2
gentoo-2-bb5a75c7c655ea99149f56ae31bb311751f40a9e.zip
Version bump to 2.10.5
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog7
-rw-r--r--net-zope/zope/zope-2.10.5.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index f54b43ff81a7..683ec77c921d 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.132 2008/03/20 21:42:09 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.133 2008/05/05 20:42:01 tupone Exp $
+
+*zope-2.10.5 (05 May 2008)
+
+ 05 May 2008; Tupone Alfredo <tupone@gentoo.org> +zope-2.10.5.ebuild:
+ Version bump to 2.10.5
*zope-2.9.8 (20 Mar 2008)
diff --git a/net-zope/zope/zope-2.10.5.ebuild b/net-zope/zope/zope-2.10.5.ebuild
new file mode 100644
index 000000000000..3a589e18a6c2
--- /dev/null
+++ b/net-zope/zope/zope-2.10.5.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.10.5.ebuild,v 1.1 2008/05/05 20:42:01 tupone Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="=dev-lang/python-2.4*"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc doc/*.txt
+ docinto PLATFORMS ; dodoc doc/PLATFORMS/*
+ docinto ZEO ; dodoc doc/ZEO/*
+
+ make install prefix="${D}${ZSERVDIR}" || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf "${D}${ZSERVDIR}"/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ insinto "${ZSERVDIR}"/skel
+ doins "${FILESDIR}"/zope.initd
+}
+
+src_test() {
+ einfo "Tests disabled by Gentoo team."
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}