summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2006-12-29 00:19:50 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2006-12-29 00:19:50 +0000
commitf6257b608490f9d5a330351075757202da9c3c5c (patch)
treea0b0b038cb530301ee7bc7463e76430cbf64f902 /net-zope
parentRequire sys-devel/pmake when not using BSD userland. (diff)
downloadgentoo-2-f6257b608490f9d5a330351075757202da9c3c5c.tar.gz
gentoo-2-f6257b608490f9d5a330351075757202da9c3c5c.tar.bz2
gentoo-2-f6257b608490f9d5a330351075757202da9c3c5c.zip
version bump, stays ~x86
(Portage version: 2.1.2_rc4-r1)
Diffstat (limited to 'net-zope')
-rw-r--r--net-zope/zope/ChangeLog9
-rw-r--r--net-zope/zope/files/digest-zope-2.10.13
-rw-r--r--net-zope/zope/files/digest-zope-2.9.63
-rw-r--r--net-zope/zope/zope-2.10.1.ebuild79
-rw-r--r--net-zope/zope/zope-2.9.6.ebuild79
5 files changed, 172 insertions, 1 deletions
diff --git a/net-zope/zope/ChangeLog b/net-zope/zope/ChangeLog
index 977c71cd8ca1..68d97569d449 100644
--- a/net-zope/zope/ChangeLog
+++ b/net-zope/zope/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-zope/zope
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.116 2006/10/21 21:30:06 radek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/ChangeLog,v 1.117 2006/12/29 00:19:49 radek Exp $
+
+*zope-2.10.1 (29 Dec 2006)
+*zope-2.9.6 (29 Dec 2006)
+
+ 29 Dec 2006; Radoslaw Stachowiak <radek@gentoo.org> +zope-2.9.6.ebuild,
+ +zope-2.10.1.ebuild:
+ version bump, stays ~x86
*zope-3.3.0 (21 Oct 2006)
diff --git a/net-zope/zope/files/digest-zope-2.10.1 b/net-zope/zope/files/digest-zope-2.10.1
new file mode 100644
index 000000000000..ee42c792f71c
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.10.1
@@ -0,0 +1,3 @@
+MD5 10733d25719535eeb8ca995dd627106f Zope-2.10.1-final.tgz 7128570
+RMD160 b05c2d4c69a9e19d88f38c36ef5bf4846a7d5d0a Zope-2.10.1-final.tgz 7128570
+SHA256 a759dc9312a9e8ebb87d721fbb0124caafd18a1860e5f5bd2186f1459e68c17b Zope-2.10.1-final.tgz 7128570
diff --git a/net-zope/zope/files/digest-zope-2.9.6 b/net-zope/zope/files/digest-zope-2.9.6
new file mode 100644
index 000000000000..8cc829d34d7c
--- /dev/null
+++ b/net-zope/zope/files/digest-zope-2.9.6
@@ -0,0 +1,3 @@
+MD5 a87008a9e78248072ea5908e1006b269 Zope-2.9.6-final.tgz 6989768
+RMD160 0fc82ae2ee0f2343e6fcd723048f6dfd18dbcd04 Zope-2.9.6-final.tgz 6989768
+SHA256 00ffe561df9ede6543bf5dceeea964048ee005705ba98dd8f8dbfcd8dd64fcc4 Zope-2.9.6-final.tgz 6989768
diff --git a/net-zope/zope/zope-2.10.1.ebuild b/net-zope/zope/zope-2.10.1.ebuild
new file mode 100644
index 000000000000..1a4734e5485a
--- /dev/null
+++ b/net-zope/zope/zope-2.10.1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.10.1.ebuild,v 1.1 2006/12/29 00:19:50 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}
diff --git a/net-zope/zope/zope-2.9.6.ebuild b/net-zope/zope/zope-2.9.6.ebuild
new file mode 100644
index 000000000000..f26241b2780c
--- /dev/null
+++ b/net-zope/zope/zope-2.9.6.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-zope/zope/zope-2.9.6.ebuild,v 1.1 2006/12/29 00:19:50 radek Exp $
+
+inherit eutils multilib
+
+DESCRIPTION="Zope is a web application platform used for building high-performance, dynamic web sites"
+HOMEPAGE="http://www.zope.org"
+SRC_URI="http://www.zope.org/Products/Zope/${PV}/Zope-${PV}-final.tgz"
+
+LICENSE="ZPL"
+SLOT="${PV}"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/python-2.4*"
+
+DEPEND="${RDEPEND}
+virtual/libc
+>=sys-apps/sed-4.0.5"
+
+S="${WORKDIR}/Zope-${PV}-final"
+ZUID=zope
+ZGID=zope
+ZS_DIR=${ROOT%/}/usr/$(get_libdir)
+ZSERVDIR=${ZS_DIR}/${P}
+
+# Narrow the scope of ownership/permissions.
+# Security plan:
+# * ZUID is the superuser for all zope instances.
+# * ZGID is for a single instance's administration.
+# * Other' should not have any access to ${ZSERVDIR},
+# because they can work through the Zope web interface.
+# This should protect our code/data better.
+#
+# UPDATE: ${ZSERVDIR} is a lib directory and should be world readable
+# like e.g /usr/lib/python we do not store any user data there,
+# currently removed all custom permission stuff, for ${ZSERVDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ ./configure --prefix="${D}${ZSERVDIR}" --with-python=/usr/bin/python2.4 || die "Failed to execute ./configure ..."
+ emake || die "Failed to compile."
+}
+
+src_install() {
+ dodoc README.txt
+ dodoc Zope/doc/*.txt
+ docinto PLATFORMS ; dodoc Zope/doc/PLATFORMS/*
+ docinto ZEO ; dodoc Zope/doc/ZEO/*
+
+ make install prefix=${D}${ZSERVDIR} || die "Failed to install into ${D}${ZSERVDIR}"
+ rm -rf ${D}${ZSERVDIR}/doc
+ dosym ../../share/doc/${PF} ${ZSERVDIR}/doc
+
+ # copy the init script skeleton to skel directory of our installation
+ cp ${FILESDIR}/zope.initd ${D}/${ZSERVDIR}/skel/zope.initd
+}
+
+pkg_postinst() {
+ # create the zope user and group for backward compatibility
+ enewgroup ${ZGID} 261
+ usermod -g ${ZGID} ${ZUID} 2>&1 >/dev/null || \
+ enewuser ${ZUID} 261 -1 /var/$(get_libdir)/zope ${ZGID}
+
+ einfo "Be warned that you need at least one zope instance to run zope."
+ einfo "Please emerge zope-config for futher instance management."
+}
+
+pkg_prerm() {
+
+ #need to remove this symlink because portage keeps links to
+ #existing targets
+ rm ${ZSERVDIR}/bin/python
+}