summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2011-03-14 07:07:13 +0000
committerTorsten Veller <tove@gentoo.org>2011-03-14 07:07:13 +0000
commitce9bc2e4da51cfb72d5be423f7e88b780b8103dd (patch)
tree844d0aa3de449ab7857ed8cf1a844d037082f402 /perl-core/DB_File/DB_File-1.822.0.ebuild
parentVersion bump. Switch gnutls USE flag to more generic ssl (but still provided ... (diff)
downloadgentoo-2-ce9bc2e4da51cfb72d5be423f7e88b780b8103dd.tar.gz
gentoo-2-ce9bc2e4da51cfb72d5be423f7e88b780b8103dd.tar.bz2
gentoo-2-ce9bc2e4da51cfb72d5be423f7e88b780b8103dd.zip
[bump] perl-core/DB_File-1.822.0
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'perl-core/DB_File/DB_File-1.822.0.ebuild')
-rw-r--r--perl-core/DB_File/DB_File-1.822.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/perl-core/DB_File/DB_File-1.822.0.ebuild b/perl-core/DB_File/DB_File-1.822.0.ebuild
new file mode 100644
index 000000000000..c4193f850b9a
--- /dev/null
+++ b/perl-core/DB_File/DB_File-1.822.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/DB_File/DB_File-1.822.0.ebuild,v 1.1 2011/03/14 07:07:13 tove Exp $
+
+EAPI=3
+
+MODULE_AUTHOR=PMQS
+MODULE_VERSION=1.822
+inherit perl-module multilib eutils
+
+DESCRIPTION="A Berkeley DB Support Perl Module"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="sys-libs/db"
+DEPEND="${RDEPEND}"
+
+SRC_TEST="do"
+
+src_prepare() {
+ if [[ $(get_libdir) != "lib" ]] ; then
+ sed -i "s:^LIB.*:LIB = /usr/$(get_libdir):" "${S}"/config.in || die
+ fi
+ epatch "${FILESDIR}"/DB_File-MakeMaker.patch
+}