summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-05-25 14:54:32 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-05-25 14:54:32 +0000
commitbf8277eb6792a69aa23675986f7c79e3c2c8f963 (patch)
treeb645dee4b54836296d849292f9f640185a3888fe /perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild
parentNew upstream version. Also enabled gtk+-2.6 features (and moved the gtk requi... (diff)
downloadgentoo-2-bf8277eb6792a69aa23675986f7c79e3c2c8f963.tar.gz
gentoo-2-bf8277eb6792a69aa23675986f7c79e3c2c8f963.tar.bz2
gentoo-2-bf8277eb6792a69aa23675986f7c79e3c2c8f963.zip
dev-perl => perl-core migration
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild')
-rw-r--r--perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild b/perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild
new file mode 100644
index 000000000000..ccc6b665b5fb
--- /dev/null
+++ b/perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/perl-core/Test-Simple/Test-Simple-0.47-r1.ebuild,v 1.1 2005/05/25 14:54:32 mcummings Exp $
+
+inherit perl-module
+
+DESCRIPTION="Basic utilities for writing tests"
+HOMEPAGE="http://search.cpan.org/search?dist=Test-Harness"
+SRC_URI="http://www.cpan.org/authors/id/MSCHWERN/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc s390 sparc x86"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.8.0-r12
+ >=perl-core/Test-Harness-1.23"
+
+mydoc="rfc*.txt"
+myconf="INSTALLDIRS=vendor"
+
+src_compile() {
+ perl-module_src_compile
+ make test || die "Tests didn't work out. Aborting!"
+}