summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2008-08-28 17:55:16 +0000
committerJim Ramsay <lack@gentoo.org>2008-08-28 17:55:16 +0000
commite92a2d755fd19d10157d55f7ab88aa09822dc50a (patch)
tree0e7bfc21dfa61f549331ad1806ab4e4609ccc70b /rox-base/rox
parentUse elisp-compile instead of elisp-comp. Install Emacs byte-code files. Fixes... (diff)
downloadgentoo-2-e92a2d755fd19d10157d55f7ab88aa09822dc50a.tar.gz
gentoo-2-e92a2d755fd19d10157d55f7ab88aa09822dc50a.tar.bz2
gentoo-2-e92a2d755fd19d10157d55f7ab88aa09822dc50a.zip
Marking stable on amd64 (plus some version cleanup)
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo x86_64)
Diffstat (limited to 'rox-base/rox')
-rw-r--r--rox-base/rox/ChangeLog6
-rw-r--r--rox-base/rox/rox-2.7-r2.ebuild149
-rw-r--r--rox-base/rox/rox-2.7.1-r1.ebuild152
-rw-r--r--rox-base/rox/rox-2.7.ebuild4
-rw-r--r--rox-base/rox/rox-2.8.ebuild9
5 files changed, 12 insertions, 308 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index d00a601849a0..8a91b53beb92 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.58 2008/07/29 14:48:59 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.59 2008/08/28 17:55:16 lack Exp $
+
+ 28 Aug 2008; Jim Ramsay <lack@gentoo.org> rox-2.7.ebuild,
+ -rox-2.7-r2.ebuild, -rox-2.7.1-r1.ebuild, rox-2.8.ebuild:
+ Marking stable on amd64 (plus some version cleanup)
29 Jul 2008; Jim Ramsay <lack@gentoo.org> metadata.xml:
Converted use.local.desc to new metadata.xml format
diff --git a/rox-base/rox/rox-2.7-r2.ebuild b/rox-base/rox/rox-2.7-r2.ebuild
deleted file mode 100644
index d4e877500f6e..000000000000
--- a/rox-base/rox/rox-2.7-r2.ebuild
+++ /dev/null
@@ -1,149 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.7-r2.ebuild,v 1.5 2008/01/24 20:08:10 lack Exp $
-
-EAPI=1
-inherit eutils multilib
-
-MY_P="rox-filer-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
-HOMEPAGE="http://rox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="svg +video"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=dev-libs/glib-2.2
- >=dev-libs/libxml2-2.4.23
- >=x11-misc/shared-mime-info-0.14
- svg? ( gnome-base/librsvg )"
-
-PDEPEND="rox-base/mime-editor
- rox-base/thumbs
- video? ( rox-extra/videothumbnail )"
-
-DEPEND="${RDEPEND}
- >=rox-base/zeroinstall-injector-0.31-r1
- >=dev-util/pkgconfig-0.20"
-
-APPNAME="ROX-Filer"
-APPDIR="/usr/$(get_libdir)/rox"
-LIBDIR="/usr/$(get_libdir)/"
-WRAPPERNAME="rox"
-MIMEDIR="/usr/share/mime"
-MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${P}-nostrip.patch
- epatch "${FILESDIR}"/${P}-text_plain.patch
-}
-
-src_compile() {
-
- cd ${APPNAME}
-
- # Most rox self-compiles have a 'read' call to wait for the user to
- # press return if the compile fails.
- # Find and remove this:
- sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
-
- ./AppRun --compile || die "make failed"
-
- # don't need these directories anymore
- if [ -n "${KEEP_SRC}" ]; then
- pushd src
- make clean > /dev/null
- popd
- else
- rm -rf src
- fi
- rm -fr build
-
- # Restore the original AppRun
- mv AppRun.bak AppRun
-}
-
-# new streamlined install
-
-src_install() {
- doman rox.1
-
- dodir ${APPDIR}
- cp -r ${APPNAME}/ "${D}/${APPDIR}"
-
- # add documentation to be proper
- pushd ${APPNAME}/Help
- dodoc Changes README README-es TODO
- popd
-
- # install shell script
- dodir /usr/bin
-
- cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
-#!/bin/sh
-if [ "\${LIBDIRPATH}" ]; then
- export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
-else
- export LIBDIRPATH="${LIBDIR}"
-fi
-
-if [ "\${APPDIRPATH}" ]; then
- export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
-else
- export APPDIRPATH="${APPDIR}"
-fi
-exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
-EOF
-
- cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
-#!/bin/sh
-exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
-EOF
-
- fperms 0755 "/usr/bin/${WRAPPERNAME}"
- fperms 0755 "/usr/bin/${WRAPPERNAME}uri"
-
- # install rox.xml
- insinto ${MIMEDIR}/packages
- doins rox.xml
-
- # CHOICES system is gone. Now use XDG only
- # these are shell scripts and must be +x.
- exeinto ${MIMECONFDIR}/MIME-types
- doexe Choices/MIME-types/*
-
- insinto /usr/share/pixmaps
- newins ${APPNAME}/.DirIcon ${APPNAME}.png
-
- make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME} "System;FileTools;FileManager"
-
- # Install the 0install feed
- local NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
- local ICON_CACHE_DIR="/var/cache/0install.net/interface_icons"
-
- 0distutils ${APPNAME}.xml > tmp.native_feed || die "0distutils feed edit failed"
- insinto "${APPDIR}/${APPNAME}"
- newins tmp.native_feed ${APPNAME}.xml
-
- local feedname
- feedname=$(0distutils -e tmp.native_feed) || die "0distutils URI escape failed"
- dosym "${APPDIR}/${APPNAME}/${APPNAME}.xml" "${NATIVE_FEED_DIR}/${feedname}"
-
- local cachedname
- cachedname=$(0distutils -c tmp.native_feed) || die "0distutils URI escape failed"
- dosym "${APPDIR}/${APPNAME}/.DirIcon" "${ICON_CACHE_DIR}/${cachedname}"
-}
-
-pkg_postinst() {
- update-mime-database ${MIMEDIR}
- einfo "${APPNAME} has been installed in ${APPDIR}."
- einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
- einfo "add it to an .xinit or other script during WM startup."
-}
diff --git a/rox-base/rox/rox-2.7.1-r1.ebuild b/rox-base/rox/rox-2.7.1-r1.ebuild
deleted file mode 100644
index 0aa8e2416366..000000000000
--- a/rox-base/rox/rox-2.7.1-r1.ebuild
+++ /dev/null
@@ -1,152 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.7.1-r1.ebuild,v 1.1 2008/01/24 20:08:10 lack Exp $
-
-EAPI=1
-inherit eutils multilib
-
-MY_P="rox-filer-${PV}"
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="ROX is a desktop environment and filer based on RISC OS."
-HOMEPAGE="http://rox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
-IUSE="svg +video"
-
-RDEPEND=">=x11-libs/gtk+-2.4
- >=dev-libs/glib-2.2
- >=dev-libs/libxml2-2.4.23
- >=x11-misc/shared-mime-info-0.14
- svg? ( gnome-base/librsvg )"
-
-PDEPEND="rox-base/mime-editor
- rox-base/thumbs
- video? ( rox-extra/videothumbnail )"
-
-DEPEND="${RDEPEND}
- >=rox-base/zeroinstall-injector-0.31-r1
- >=dev-util/pkgconfig-0.20"
-
-APPNAME="ROX-Filer"
-APPDIR="/usr/$(get_libdir)/rox"
-LIBDIR="/usr/$(get_libdir)/"
-WRAPPERNAME="rox"
-MIMEDIR="/usr/share/mime"
-MIMECONFDIR="/etc/xdg/rox.sourceforge.net"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-2.7-nostrip.patch
- epatch "${FILESDIR}"/${PN}-2.7-text_plain.patch
-}
-
-src_compile() {
-
- cd ${APPNAME}
-
- # Most rox self-compiles have a 'read' call to wait for the user to
- # press return if the compile fails.
- # Find and remove this:
- sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
-
- ./AppRun --compile || die "make failed"
-
- # don't need these directories anymore
- if [ -n "${KEEP_SRC}" ]; then
- pushd src
- make clean > /dev/null
- popd
- else
- rm -rf src
- fi
- rm -fr build
-
- # Restore the original AppRun
- mv AppRun.bak AppRun
-}
-
-# new streamlined install
-
-src_install() {
- doman rox.1
-
- dodir ${APPDIR}
- cp -r ${APPNAME}/ "${D}/${APPDIR}"
-
- # add documentation to be proper
- pushd ${APPNAME}/Help
- dodoc Changes README README-es TODO
- popd
-
- # install shell script
- dodir /usr/bin
-
- cat >"${D}/usr/bin/${WRAPPERNAME}" <<EOF
-#!/bin/sh
-if [ "\${LIBDIRPATH}" ]; then
- export LIBDIRPATH="\${LIBDIRPATH}:${LIBDIR}"
-else
- export LIBDIRPATH="${LIBDIR}"
-fi
-
-if [ "\${APPDIRPATH}" ]; then
- export APPDIRPATH="\${APPDIRPATH}:${APPDIR}"
-else
- export APPDIRPATH="${APPDIR}"
-fi
-exec "${APPDIR}/${APPNAME}/AppRun" "\$@"
-EOF
-
- cat >"${D}/usr/bin/${WRAPPERNAME}uri" <<EOF
-#!/bin/sh
-exec "${APPDIR}/${APPNAME}/AppRun" -U "\$@"
-EOF
-
- fperms 0755 "/usr/bin/${WRAPPERNAME}"
- fperms 0755 "/usr/bin/${WRAPPERNAME}uri"
-
- # install rox.xml
- insinto ${MIMEDIR}/packages
- doins rox.xml
-
- # CHOICES system is gone. Now use XDG only
- # these are shell scripts and must be +x.
- exeinto ${MIMECONFDIR}/MIME-types
- doexe Choices/MIME-types/*
-
- insinto /usr/share/pixmaps
- newins ${APPNAME}/.DirIcon ${APPNAME}.png
-
- make_desktop_entry ${WRAPPERNAME} ${APPNAME} ${APPNAME} "System;FileTools;FileManager"
- # Add Mime types to the .desktop file:
- echo "MimeType=x-directory/normal;inode/directory" >> \
- "${D}/usr/share/applications/rox-rox.desktop"
-
- # Install the 0install feed
- local NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
- local ICON_CACHE_DIR="/var/cache/0install.net/interface_icons"
-
- 0distutils ${APPNAME}.xml > tmp.native_feed || die "0distutils feed edit failed"
- insinto "${APPDIR}/${APPNAME}"
- newins tmp.native_feed ${APPNAME}.xml
-
- local feedname
- feedname=$(0distutils -e tmp.native_feed) || die "0distutils URI escape failed"
- dosym "${APPDIR}/${APPNAME}/${APPNAME}.xml" "${NATIVE_FEED_DIR}/${feedname}"
-
- local cachedname
- cachedname=$(0distutils -c tmp.native_feed) || die "0distutils URI escape failed"
- dosym "${APPDIR}/${APPNAME}/.DirIcon" "${ICON_CACHE_DIR}/${cachedname}"
-}
-
-pkg_postinst() {
- update-mime-database ${MIMEDIR}
- einfo "${APPNAME} has been installed in ${APPDIR}."
- einfo "To run, you may type ${WRAPPERNAME} at a prompt (within a WM) or"
- einfo "add it to an .xinit or other script during WM startup."
-}
diff --git a/rox-base/rox/rox-2.7.ebuild b/rox-base/rox/rox-2.7.ebuild
index 24eea3d3b348..0f50c9073d93 100644
--- a/rox-base/rox/rox-2.7.ebuild
+++ b/rox-base/rox/rox-2.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.7.ebuild,v 1.4 2008/02/29 20:32:30 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.7.ebuild,v 1.5 2008/08/28 17:55:16 lack Exp $
inherit eutils multilib
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~ppc ~sparc ~x86"
IUSE="svg"
RDEPEND=">=x11-libs/gtk+-2.4
diff --git a/rox-base/rox/rox-2.8.ebuild b/rox-base/rox/rox-2.8.ebuild
index 4ea5045fae1f..a073a363a8fa 100644
--- a/rox-base/rox/rox-2.8.ebuild
+++ b/rox-base/rox/rox-2.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.8.ebuild,v 1.1 2008/05/20 02:58:23 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.8.ebuild,v 1.2 2008/08/28 17:55:16 lack Exp $
EAPI=1
inherit eutils multilib
@@ -14,21 +14,22 @@ SRC_URI="mirror://sourceforge/rox/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~ppc ~sparc ~x86"
IUSE="svg +video"
RDEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/glib-2.2
>=dev-libs/libxml2-2.4.23
>=x11-misc/shared-mime-info-0.14
- svg? ( gnome-base/librsvg )"
+ svg? ( gnome-base/librsvg )
+ >=rox-base/zeroinstall-injector-0.31-r1
+ "
PDEPEND="rox-base/mime-editor
rox-base/thumbs
video? ( rox-extra/videothumbnail )"
DEPEND="${RDEPEND}
- >=rox-base/zeroinstall-injector-0.31-r1
>=dev-util/pkgconfig-0.20"
APPNAME="ROX-Filer"