summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-12-04 17:50:56 +0000
committerJim Ramsay <lack@gentoo.org>2007-12-04 17:50:56 +0000
commitab759b0d7e3fc15eccfa324aadbba6101b099fac (patch)
tree226424939226e4196e97c44095884e0a255d82f9 /rox-base
parentbump to 0.28, fix bug #196218 and add some USE flag documentation (diff)
downloadgentoo-2-ab759b0d7e3fc15eccfa324aadbba6101b099fac.tar.gz
gentoo-2-ab759b0d7e3fc15eccfa324aadbba6101b099fac.tar.bz2
gentoo-2-ab759b0d7e3fc15eccfa324aadbba6101b099fac.zip
Updated to install 0install native feed for new rox-0install eclass
(Portage version: 2.1.3.19)
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox-clib/ChangeLog7
-rw-r--r--rox-base/rox-clib/files/digest-rox-clib-2.1.9-r23
-rw-r--r--rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild71
3 files changed, 80 insertions, 1 deletions
diff --git a/rox-base/rox-clib/ChangeLog b/rox-base/rox-clib/ChangeLog
index 511b07b03d68..f4c3da688aaa 100644
--- a/rox-base/rox-clib/ChangeLog
+++ b/rox-base/rox-clib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for rox-base/rox-clib
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/ChangeLog,v 1.23 2007/11/29 16:15:54 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/ChangeLog,v 1.24 2007/12/04 17:50:56 lack Exp $
+
+*rox-clib-2.1.9-r2 (04 Dec 2007)
+
+ 04 Dec 2007; Jim Ramsay <lack@gentoo.org> +rox-clib-2.1.9-r2.ebuild:
+ Updated to install 0install native feed for new rox-0install eclass
29 Nov 2007; Jim Ramsay <lack@gentoo.org> -rox-clib-2.1.8.ebuild,
-rox-clib-2.1.9.ebuild:
diff --git a/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r2 b/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r2
new file mode 100644
index 000000000000..6fc0e751d372
--- /dev/null
+++ b/rox-base/rox-clib/files/digest-rox-clib-2.1.9-r2
@@ -0,0 +1,3 @@
+MD5 cc494b5763613e9f58a27855f1729cec ROX-CLib-2.1.9.tar.gz 569820
+RMD160 d88f9e35924b8921cd199c7f645cf50925e0a36e ROX-CLib-2.1.9.tar.gz 569820
+SHA256 7cd8aea53948552d940d2a6d9a24b9e65798371e99ea50cb77f7eecd65b1c33c ROX-CLib-2.1.9.tar.gz 569820
diff --git a/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild b/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild
new file mode 100644
index 000000000000..5a089acf1a47
--- /dev/null
+++ b/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox-clib/rox-clib-2.1.9-r2.ebuild,v 1.1 2007/12/04 17:50:56 lack Exp $
+
+inherit multilib
+
+MY_PN="ROX-CLib"
+DESCRIPTION="A library for ROX applications written in C."
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="http://www.kerofin.demon.co.uk/rox/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.0.1
+ >=dev-libs/libxml2-2.4.0"
+
+DEPEND="$RDEPEND
+ >=dev-util/pkgconfig-0.20
+ rox-base/zeroinstall-injector"
+
+S=${WORKDIR}/ROX-CLib
+APPNAME=${MY_PN}
+
+src_compile() {
+ chmod 0755 AppRun
+
+ # Most rox self-compiles have a 'read' call to wait for the user to
+ # press return if the compile fails.
+ # Find and remove this:
+ sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
+
+ ./AppRun --compile || die "Could not make ROX-CLib. Sorry."
+
+ # Restore the original AppRun
+ mv AppRun.bak AppRun
+}
+
+src_install() {
+ local baselibdir="/usr/$(get_libdir)"
+ local NATIVE_FEED_DIR="/usr/share/0install.net/native_feeds"
+ local ICON_CACHE_DIR="/var/cache/0install.net/interface_icons"
+
+ # clean up source instead of remove it!
+ ( cd src && make clean )
+
+ # remove silly .cvs files
+ find . -name '.cvs*' | xargs rm -f >/dev/null 2>&1
+ dodoc ${baselibdir}/${APPNAME}
+ dodir ${baselibdir}/${APPNAME}
+ cp -r . "${D}${baselibdir}/${APPNAME}"
+ (
+ cd Help
+ dodoc Authors Changes ToDo COPYING README Versions
+ )
+
+ 0distutils ROX-CLib.xml > tmp.native_feed || die "0distutilss feed edit failed"
+ insinto "${baselibdir}/ROX-CLib/"
+ newins tmp.native_feed ROX-CLib.xml
+
+ local feedname
+ feedname=$(0distutils -e tmp.native_feed) || "0distutils URI escape failed"
+ dosym "${baselibdir}/ROX-CLib/ROX-CLib.xml" "${NATIVE_FEED_DIR}/${feedname}"
+
+ local cachedname
+ cachedname=$(0distutils -c tmp.native_feed) || "0distutils URI escape failed"
+ dosym "${baselibdir}/ROX-CLib/.DirIcon" "${ICON_CACHE_DIR}/${cachedname}"
+
+}