summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-01-30 22:16:46 +0000
committerJim Ramsay <lack@gentoo.org>2007-01-30 22:16:46 +0000
commitdf45ce22105f832f7f5a22c812f1573e2e526e6c (patch)
treee79c808175049916528ea2315705adcd9d705205 /rox-extra/edit/edit-2.0-r1.ebuild
parentAdded APPCATEGORY so a .desktop file will be installed (diff)
downloadgentoo-2-df45ce22105f832f7f5a22c812f1573e2e526e6c.tar.gz
gentoo-2-df45ce22105f832f7f5a22c812f1573e2e526e6c.tar.bz2
gentoo-2-df45ce22105f832f7f5a22c812f1573e2e526e6c.zip
Added APPCATEGORY so a .desktop file will be installed
(Portage version: 2.1.2-r4)
Diffstat (limited to 'rox-extra/edit/edit-2.0-r1.ebuild')
-rw-r--r--rox-extra/edit/edit-2.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/rox-extra/edit/edit-2.0-r1.ebuild b/rox-extra/edit/edit-2.0-r1.ebuild
new file mode 100644
index 000000000000..8735a8bd5624
--- /dev/null
+++ b/rox-extra/edit/edit-2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/rox-extra/edit/edit-2.0-r1.ebuild,v 1.1 2007/01/30 22:16:46 lack Exp $
+
+ROX_LIB_VER=1.9.14
+inherit rox
+
+APPNAME=Edit
+APPCATEGORY="Utility;TextEditor"
+
+DESCRIPTION="Edit is a simple text editor for ROX Desktop"
+HOMEPAGE="http://rox.sourceforge.net/"
+SRC_URI="mirror://sourceforge/rox/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+# do some cleanup. Edit 2.0 has CVS dirs included
+pkg_preinst() {
+ find ${D}/usr/lib/rox/${APPNAME} -name 'CVS' | xargs rm -fr
+ rm -f ${D}/usr/lib/rox/${APPNAME}/.cvsignore
+ rm -fr ${D}/usr/lib/rox/${APPNAME}/tests
+}