summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2010-06-10 08:58:49 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2010-06-10 08:58:49 +0000
commit319f33b7ec10ed9ee10c06c124fa2e6469cb35cf (patch)
tree206fbf1557f388a3c718ce2293cc7680744c7564 /sci-astronomy/ast/ast-5.3.1-r1.ebuild
parentRemove old (diff)
downloadgentoo-2-319f33b7ec10ed9ee10c06c124fa2e6469cb35cf.tar.gz
gentoo-2-319f33b7ec10ed9ee10c06c124fa2e6469cb35cf.tar.bz2
gentoo-2-319f33b7ec10ed9ee10c06c124fa2e6469cb35cf.zip
Fixing header creation with >=GCC-4.4 wrt bug 322733. Thanks Diego for the report.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/ast/ast-5.3.1-r1.ebuild')
-rw-r--r--sci-astronomy/ast/ast-5.3.1-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-astronomy/ast/ast-5.3.1-r1.ebuild b/sci-astronomy/ast/ast-5.3.1-r1.ebuild
new file mode 100644
index 000000000000..4a3c36cb6773
--- /dev/null
+++ b/sci-astronomy/ast/ast-5.3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/ast/ast-5.3.1-r1.ebuild,v 1.1 2010/06/10 08:58:48 xarthisius Exp $
+
+EAPI=2
+inherit eutils versionator
+
+MYP="${PN}-$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Library for handling World Coordinate Systems in astronomy"
+HOMEPAGE="http://starlink.jach.hawaii.edu/starlink/AST"
+SRC_URI="${HOMEPAGE}?action=AttachFile&do=get&target=${MYP}.tar.gz -> ${MYP}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+RDEPEND="sci-libs/pgplot"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ # dont patch/sed Makefile.am because it requires special upstream automake
+ # not shipped
+ epatch "${FILESDIR}"/${PN}-5.1.0-makefile.in.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ rm -rf "${D}"usr/{docs,help,manifests,news,share} || die
+ dodoc ast.news fac_1521_err
+ if use doc; then
+ dodoc *.ps || die "doc install failed"
+ fi
+}