summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-26 05:51:04 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-26 05:51:04 +0000
commit31922f9a8152d90ef0bf2ca496490ba5b1551cbd (patch)
tree27d6556b2eab75f0da70d13dacecd65c16764a80 /sci-astronomy/casacore/casacore-1.3.0.ebuild
parentFix typo (committed as obvious). (diff)
downloadgentoo-2-31922f9a8152d90ef0bf2ca496490ba5b1551cbd.tar.gz
gentoo-2-31922f9a8152d90ef0bf2ca496490ba5b1551cbd.tar.bz2
gentoo-2-31922f9a8152d90ef0bf2ca496490ba5b1551cbd.zip
Version bump and initial import to the main tree
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy/casacore/casacore-1.3.0.ebuild')
-rw-r--r--sci-astronomy/casacore/casacore-1.3.0.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-astronomy/casacore/casacore-1.3.0.ebuild b/sci-astronomy/casacore/casacore-1.3.0.ebuild
new file mode 100644
index 000000000000..8147c70d2820
--- /dev/null
+++ b/sci-astronomy/casacore/casacore-1.3.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/casacore/casacore-1.3.0.ebuild,v 1.1 2011/11/26 05:51:04 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
+HOMEPAGE="http://code.google.com/p/casacore/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="doc fftw hdf5 threads test"
+
+RDEPEND="sci-libs/cfitsio
+ sci-astronomy/wcslib
+ virtual/blas
+ virtual/lapack
+ sys-libs/readline
+ hdf5? ( sci-libs/hdf5 )
+ fftw? ( >=sci-libs/fftw-3 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}"/${PV}-{headers,implicits,libdir}.patch )
+
+src_configure() {
+ has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
+ mycmakeargs+=(
+ -DENABLE_SHARED=ON
+ -DCMAKE_SKIP_RPATH=ON
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use_use fftw FFTW3)
+ $(cmake-utils_use_use hdf5 HDF5)
+ $(cmake-utils_use_use threads THREADS)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && doxygen doxygen.cfg
+}
+
+src_install(){
+ cmake-utils_src_compile
+ use doc && dohtml -r doc/html
+}