summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-05 17:22:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-05 17:22:29 +0000
commit31e08318f33a573eff44f9e0ded2469e0c4cde61 (patch)
tree6b8120de3b50c707378d576ec30294a0ec83462e /sci-astronomy/cpl
parentversion bump and sync live ebuild. We dropped the --libdir= configure switch ... (diff)
downloadgentoo-2-31e08318f33a573eff44f9e0ded2469e0c4cde61.tar.gz
gentoo-2-31e08318f33a573eff44f9e0ded2469e0c4cde61.tar.bz2
gentoo-2-31e08318f33a573eff44f9e0ded2469e0c4cde61.zip
Version bump
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy/cpl')
-rw-r--r--sci-astronomy/cpl/ChangeLog7
-rw-r--r--sci-astronomy/cpl/cpl-6.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/sci-astronomy/cpl/ChangeLog b/sci-astronomy/cpl/ChangeLog
index f919cc58e8b9..4c0c5d177b9d 100644
--- a/sci-astronomy/cpl/ChangeLog
+++ b/sci-astronomy/cpl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/cpl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.11 2012/09/06 16:34:35 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/ChangeLog,v 1.12 2012/12/05 17:22:29 bicatali Exp $
+
+*cpl-6.2 (05 Dec 2012)
+
+ 05 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> +cpl-6.2.ebuild:
+ Version bump
06 Sep 2012; Sébastien Fabbro <bicatali@gentoo.org> cpl-6.1.1.ebuild:
Compile and install html documentation properly, thanks Peter Weilbacher, bug
diff --git a/sci-astronomy/cpl/cpl-6.2.ebuild b/sci-astronomy/cpl/cpl-6.2.ebuild
new file mode 100644
index 000000000000..c2874e01c2a3
--- /dev/null
+++ b/sci-astronomy/cpl/cpl-6.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/cpl/cpl-6.2.ebuild,v 1.1 2012/12/05 17:22:29 bicatali Exp $
+
+EAPI=4
+
+JAVA_PKG_OPT_USE=gasgano
+AUTOTOOLS_AUTORECONF=1
+
+inherit eutils java-pkg-opt-2 autotools-utils
+
+DESCRIPTION="ESO common pipeline library for astronomical data reduction"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+IUSE="doc gasgano static-libs threads"
+
+RDEPEND="
+ >=sci-astronomy/wcslib-4.8.4
+ >=sci-libs/cfitsio-3.270
+ >=sci-libs/fftw-3.1.2
+ gasgano? ( sci-astronomy/gasgano )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.1.1-check-shared-libs.patch
+ "${FILESDIR}"/${PN}-6.1.1-use-system-ltdl.patch
+)
+
+src_prepare() {
+ # bug 422455 and remove cpu chcking
+ sed -i \
+ -e '/AM_C_PROTOTYPES/d' \
+ -e '/CPL_CHECK_CPU/d' \
+ configure.ac libcext/configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html"
+ --disable-ltdl-install
+ --without-included-ltdl
+ $(use_enable doc maintainer-mode)
+ $(use_enable threads)
+ )
+ if use gasgano; then
+ myeconfargs+=(
+ --enable-gasgano
+ --with-gasgano="${EPREFIX}/usr"
+ --with-gasgano-classpath="${EPREFIX}/usr/share/gasgano/lib"
+ --with-java="$(java-config -O)"
+ )
+ else
+ myeconfargs+=( --disable-gasgano )
+ fi
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ autotools-utils_src_compile all $(use doc && echo html)
+}
+
+src_install() {
+ autotools-utils_src_install all $(use doc && echo install-html)
+}