summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2013-06-07 23:38:01 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2013-06-07 23:38:01 +0000
commit1910e492e5bd8c85f8cfb96e7e120c6d6c4dd669 (patch)
tree13f98a9fde1a1e22a18861567a0477c1317ab4b1 /sci-astronomy/esorex/esorex-3.10.ebuild
parentVersion bump (diff)
downloadgentoo-2-1910e492e5bd8c85f8cfb96e7e120c6d6c4dd669.tar.gz
gentoo-2-1910e492e5bd8c85f8cfb96e7e120c6d6c4dd669.tar.bz2
gentoo-2-1910e492e5bd8c85f8cfb96e7e120c6d6c4dd669.zip
Version bump
(Portage version: 2.2.01.21938-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy/esorex/esorex-3.10.ebuild')
-rw-r--r--sci-astronomy/esorex/esorex-3.10.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-astronomy/esorex/esorex-3.10.ebuild b/sci-astronomy/esorex/esorex-3.10.ebuild
new file mode 100644
index 000000000000..5c5cfbba7452
--- /dev/null
+++ b/sci-astronomy/esorex/esorex-3.10.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/esorex/esorex-3.10.ebuild,v 1.1 2013/06/07 23:38:01 bicatali Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils
+
+DESCRIPTION="ESO Recipe Execution Tool to exec cpl scripts"
+HOMEPAGE="http://www.eso.org/sci/software/cpl/esorex.html"
+SRC_URI="ftp://ftp.eso.org/pub/dfs/pipelines/libraries/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+DEPEND=">=sci-astronomy/cpl-6.3"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.9.6-use-shared-libs.patch )
+
+export CPLDIR="${EPREFIX}/usr"
+
+src_install() {
+ autotools-utils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}