summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHerbie Hopkins <herbs@gentoo.org>2005-08-05 15:37:18 +0000
committerHerbie Hopkins <herbs@gentoo.org>2005-08-05 15:37:18 +0000
commit8cfecc9d3e0d6d7547498dc38b1843759550ae58 (patch)
tree74da8e6deecde1cd64cef9a49917fc7cc2e706dc /sci-astronomy/predict/predict-2.2.2-r3.ebuild
parentFix long option for -S (--split-profile). (diff)
downloadgentoo-2-8cfecc9d3e0d6d7547498dc38b1843759550ae58.tar.gz
gentoo-2-8cfecc9d3e0d6d7547498dc38b1843759550ae58.tar.bz2
gentoo-2-8cfecc9d3e0d6d7547498dc38b1843759550ae58.zip
Marked ~amd64.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-astronomy/predict/predict-2.2.2-r3.ebuild')
-rw-r--r--sci-astronomy/predict/predict-2.2.2-r3.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sci-astronomy/predict/predict-2.2.2-r3.ebuild b/sci-astronomy/predict/predict-2.2.2-r3.ebuild
index 66ba85a6b758..6b576445c960 100644
--- a/sci-astronomy/predict/predict-2.2.2-r3.ebuild
+++ b/sci-astronomy/predict/predict-2.2.2-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.2-r3.ebuild,v 1.2 2005/06/23 02:44:21 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/predict/predict-2.2.2-r3.ebuild,v 1.3 2005/08/05 15:37:18 herbs Exp $
+
+inherit multilib
DESCRIPTION="Satellite tracking and orbital prediction."
HOMEPAGE="http://www.qsl.net/kd2bd/predict.html"
@@ -9,7 +11,7 @@ SRC_URI="http://www.amsat.org/amsat/ftp/software/Linux/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
IUSE="xforms gtk nls"
-KEYWORDS="x86 ~ppc"
+KEYWORDS="~amd64 ~ppc x86"
DEPEND="sys-libs/ncurses
gtk? ( =x11-libs/gtk+-1.2* )
@@ -38,7 +40,7 @@ src_compile() {
# compile predict
einfo "compiling predict"
- ${COMPILER} -L/lib -lm -lncurses -lpthread predict.c -o predict
+ ${COMPILER} -L/$(get_libdir) -lm -lncurses -lpthread predict.c -o predict
# write vocalizer.h
cd vocalizer
@@ -66,7 +68,7 @@ src_compile() {
if use xforms; then
einfo "compiling map"
cd ${S}/clients/map
- TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/lib -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
+ TCOMP="${COMPILER} -I/usr/X11R6/include -L/usr/X11R6/$(get_libdir) -lforms -lX11 -lm map.c map_cb.c map_main.c -o map"
${TCOMP}
fi
@@ -78,7 +80,7 @@ src_compile() {
cd ${S}/clients/gsat-*
./configure --prefix=/usr ${myconf}
cd src
- sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/lib/gsat/plugins/\":" -i globals.h
+ sed -e "s:#define DEFAULTPLUGINSDIR .*:#define DEFAULTPLUGINSDIR \"/usr/$(get_libdir)/gsat/plugins/\":" -i globals.h
sed -e 's:int errno;::' -i globals.h
cd ..
emake
@@ -142,8 +144,8 @@ src_install() {
if use gtk; then
# the install seems broken so do manually...
cd ${S}/clients/gsat-*
- dodir /usr/lib/gsat/plugins
- keepdir /usr/lib/gsat/plugins
+ dodir /usr/$(get_libdir)/gsat/plugins
+ keepdir /usr/$(get_libdir)/gsat/plugins
cd src
dobin gsat
cd ..