summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcus D. Hanwell <cryos@gentoo.org>2005-08-22 13:20:10 +0000
committerMarcus D. Hanwell <cryos@gentoo.org>2005-08-22 13:20:10 +0000
commit78a165686570f31d4a8c9dccd01f94b537eb3494 (patch)
tree701ae719834561b89b8fab3f2ce5467a15178136 /sci-astronomy/setiathome
parentAdd patch to fix miscompilation with gcc4 (#102892). (diff)
downloadgentoo-2-78a165686570f31d4a8c9dccd01f94b537eb3494.tar.gz
gentoo-2-78a165686570f31d4a8c9dccd01f94b537eb3494.tar.bz2
gentoo-2-78a165686570f31d4a8c9dccd01f94b537eb3494.zip
A few small updates to fix a typo and change perms of /var/lib/boinc.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'sci-astronomy/setiathome')
-rw-r--r--sci-astronomy/setiathome/ChangeLog5
-rw-r--r--sci-astronomy/setiathome/setiathome-4.18.ebuild11
2 files changed, 9 insertions, 7 deletions
diff --git a/sci-astronomy/setiathome/ChangeLog b/sci-astronomy/setiathome/ChangeLog
index e48407f4c569..7744d18ef4e1 100644
--- a/sci-astronomy/setiathome/ChangeLog
+++ b/sci-astronomy/setiathome/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/setiathome
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/ChangeLog,v 1.5 2005/08/21 15:25:01 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/ChangeLog,v 1.6 2005/08/22 13:20:10 cryos Exp $
+
+ 22 Aug 2005; Marcus D. Hanwell <marcus@gentoo.org> setiathome-4.18.ebuild:
+ A few small updates to fix a typo and change perms of /var/lib/boinc.
*setiathome-4.18 (21 Aug 2005)
diff --git a/sci-astronomy/setiathome/setiathome-4.18.ebuild b/sci-astronomy/setiathome/setiathome-4.18.ebuild
index de6e5bb479d8..6a72c7d5aa69 100644
--- a/sci-astronomy/setiathome/setiathome-4.18.ebuild
+++ b/sci-astronomy/setiathome/setiathome-4.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18.ebuild,v 1.1 2005/08/21 15:25:01 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/setiathome/setiathome-4.18.ebuild,v 1.2 2005/08/22 13:20:10 cryos Exp $
inherit eutils flag-o-matic
@@ -8,10 +8,8 @@ MY_PN="seti_boinc-client-cvs"
MY_PV="2005-08-20"
BOINC_PN="boinc_public-cvs"
BOINC_PV="2005-08-13"
-INSTDIR="/var/lib/boinc/projects/setiathome.berkeley.edu"
-
-DESCRIPTION="Search for Extraterrestrial Intelligence SETI@Home"
+DESCRIPTION="Search for Extraterrestrial Intelligence SETI@home"
HOMEPAGE="http://setiweb.ssl.berkeley.edu/"
SRC_URI="http://boinc.ssl.berkeley.edu/source/nightly/${BOINC_PN}-${BOINC_PV}.tar.gz
http://setiweb.ssl.berkeley.edu/sah/seti_source/nightly/${MY_PN}-${MY_PV}.tar.gz"
@@ -35,7 +33,8 @@ src_compile() {
}
src_install() {
- BINNAME=setiathome-${PV}.${CHOST}
+ local INSTDIR="/var/lib/boinc/projects/setiathome.berkeley.edu"
+ local BINNAME=setiathome-${PV}.${CHOST}
exeinto ${INSTDIR}
doexe ${S}/client/${BINNAME}
@@ -48,5 +47,5 @@ src_install() {
}
pkg_postinst() {
- chown -R boinc:boinc ${INSTDIR}
+ chown -R boinc:boinc /var/lib/boinc
}