summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:36:41 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-06-30 18:36:41 +0000
commit4bad56dda4e2b5aa783c49f60661db7c301ca5c5 (patch)
tree92a5669457533869192607afda635d05fc97c323 /sci-astronomy
parentVersion bump, bug#514718 (diff)
downloadgentoo-2-4bad56dda4e2b5aa783c49f60661db7c301ca5c5.tar.gz
gentoo-2-4bad56dda4e2b5aa783c49f60661db7c301ca5c5.tar.bz2
gentoo-2-4bad56dda4e2b5aa783c49f60661db7c301ca5c5.zip
Version bump, added python-3 compat
(Portage version: 2.2.10.1-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pyephem/ChangeLog7
-rw-r--r--sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild56
2 files changed, 62 insertions, 1 deletions
diff --git a/sci-astronomy/pyephem/ChangeLog b/sci-astronomy/pyephem/ChangeLog
index 479b23ddc7ac..6410ce4fcd19 100644
--- a/sci-astronomy/pyephem/ChangeLog
+++ b/sci-astronomy/pyephem/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-astronomy/pyephem
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.22 2014/01/28 18:05:57 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/ChangeLog,v 1.23 2014/06/30 18:36:41 bicatali Exp $
+
+*pyephem-3.7.5.3 (30 Jun 2014)
+
+ 30 Jun 2014; Sébastien Fabbro <bicatali@gentoo.org> +pyephem-3.7.5.3.ebuild:
+ Version bump, added python-3 compat
*pyephem-3.7.5.2 (28 Jan 2014)
diff --git a/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild b/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
new file mode 100644
index 000000000000..180900c4f65b
--- /dev/null
+++ b/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/pyephem/pyephem-3.7.5.3.ebuild,v 1.1 2014/06/30 18:36:41 bicatali Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Astronomical routines for the python programming language"
+HOMEPAGE="http://rhodesmill.org/pyephem/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+DEPEND="
+ doc? ( dev-python/sphinx )
+ test? ( virtual/python-unittest2[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+src_prepare() {
+ # don't install rst files
+ sed -i -e "s:'doc/\*\.rst',::" setup.py || die
+ distutils-r1_src_prepare
+}
+
+src_compile() {
+ distutils-r1_src_compile
+ if use doc; then
+ PYTHONPATH=. emake -C ephem/doc html
+ fi
+}
+
+python_test() {
+ if [[ ${PYTHON_ABI} == "2.7" ]]; then
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ ${EPYTHON} -m unittest discover -s src/ephem
+ else
+ PYTHONPATH="$(ls -d ${BUILD_DIR}/lib*)" \
+ unit2 discover -s src/ephem
+ fi
+}
+
+src_install() {
+ distutils-r1_src_install
+ use doc && dohtml -r ephem/doc/_build/html/*
+
+ delete_tests() {
+ rm -r "${D}$(python_get_sitedir)/ephem/tests" || die
+ }
+ python_foreach_impl delete_tests
+}