summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Goller <morfic@gentoo.org>2006-02-16 03:52:17 +0000
committerDaniel Goller <morfic@gentoo.org>2006-02-16 03:52:17 +0000
commit78d0c4c28f3805565c60157284a3219f814e3011 (patch)
tree58baf48c1eb7c9640e358197039cd0e4cf260cfb /sci-astronomy
parentStable on SPARC wrt bug #122721. (diff)
downloadgentoo-2-78d0c4c28f3805565c60157284a3219f814e3011.tar.gz
gentoo-2-78d0c4c28f3805565c60157284a3219f814e3011.tar.bz2
gentoo-2-78d0c4c28f3805565c60157284a3219f814e3011.zip
Change logic for Makefile fix closing bug #122919
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog5
-rw-r--r--sci-astronomy/celestia/celestia-1.4.0.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index c0b345442fc3..bfb575b97aad 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.10 2006/02/01 17:20:48 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.11 2006/02/16 03:52:17 morfic Exp $
+
+ 16 Feb 2006; Daniel Goller <morfic@gentoo.org> celestia-1.4.0.ebuild:
+ Change logic for Makefile fix closing bug #122919
01 Feb 2006; Gustavo Zacarias <gustavoz@gentoo.org> celestia-1.4.0.ebuild:
Keyworded ~sparc
diff --git a/sci-astronomy/celestia/celestia-1.4.0.ebuild b/sci-astronomy/celestia/celestia-1.4.0.ebuild
index 1b154d6b1d76..bfcb40623067 100644
--- a/sci-astronomy/celestia/celestia-1.4.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.6 2006/02/01 17:20:48 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.4.0.ebuild,v 1.7 2006/02/16 03:52:17 morfic Exp $
inherit eutils flag-o-matic gnome2 kde-functions
@@ -66,7 +66,7 @@ src_compile() {
# replaced with dohtml in src_install
sed -i -e "s:manual::g" Makefile.in
- if [ "${mygui}" = "kde" ]; then
+ if [ "${mygui}" == "kde" ]; then
set-kdedir 3
set-qtdir 3
export kde_widgetdir="$KDEDIR/lib/kde3/plugins/designer"
@@ -82,7 +82,7 @@ src_compile() {
|| die "econf failed"
#fix Makefiles to avoid Access Violations while fixing bug #119339
- if ! use gnome ; then
+ if [ "${mygui}" != "gnome" ] ; then
for d in . src data extras textures textures/lores textures/medres textures/hires models shaders fonts po ; do
sed -i -e "s#pkgdatadir = /usr/share/celestia#pkgdatadir = ${D}/usr/share/celestia#" $d/Makefile; done
fi
@@ -91,7 +91,7 @@ src_compile() {
}
src_install() {
- if [ "${mygui}" = "gnome" ]; then
+ if [ "${mygui}" == "gnome" ]; then
gnome2_src_install
else
einstall || die "einstall failed"