summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-07-15 15:16:24 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-07-15 15:16:24 +0000
commit9abe376b03155637cfd3b1545c9a59287b8f2e04 (patch)
treeeb1e3c5922ee7d794bdc275d28660ee60cadc176 /sci-astronomy
parentsparc/x86 stable wrt #231733 (diff)
downloadgentoo-2-9abe376b03155637cfd3b1545c9a59287b8f2e04.tar.gz
gentoo-2-9abe376b03155637cfd3b1545c9a59287b8f2e04.tar.bz2
gentoo-2-9abe376b03155637cfd3b1545c9a59287b8f2e04.zip
Initial import
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/wcslib/ChangeLog10
-rw-r--r--sci-astronomy/wcslib/Manifest4
-rw-r--r--sci-astronomy/wcslib/metadata.xml12
-rw-r--r--sci-astronomy/wcslib/wcslib-4.3.ebuild40
4 files changed, 66 insertions, 0 deletions
diff --git a/sci-astronomy/wcslib/ChangeLog b/sci-astronomy/wcslib/ChangeLog
new file mode 100644
index 000000000000..177e30920ab4
--- /dev/null
+++ b/sci-astronomy/wcslib/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-astronomy/wcslib
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/ChangeLog,v 1.1 2008/07/15 15:16:24 bicatali Exp $
+
+*wcslib-4.3 (15 Jul 2008)
+
+ 15 Jul 2008; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +wcslib-4.3.ebuild:
+ Initial import
+
diff --git a/sci-astronomy/wcslib/Manifest b/sci-astronomy/wcslib/Manifest
new file mode 100644
index 000000000000..bfcc6857e378
--- /dev/null
+++ b/sci-astronomy/wcslib/Manifest
@@ -0,0 +1,4 @@
+DIST wcslib-4.3.tar.gz 606393 RMD160 19b2f2aded2b0ba9841de4d9d7006247fb0619b9 SHA1 4d4370484c1db2159935d599eee6c7eb6d2adf7a SHA256 c8bd43840b1a76774728f3d32d3e79f02586f3b34b0051eb5a861236b23e549f
+EBUILD wcslib-4.3.ebuild 1081 RMD160 357429840ea76a56b8c7a1f5f7258487cea5f86b SHA1 797124b7386e82b4cce9fb5fcebd2028093fe529 SHA256 d45aa3bac28002f2e6a6bb7bb27aee7abdef96b6808acc92c98b129de4db6314
+MISC ChangeLog 258 RMD160 8727b3142dd7355a22b50cd0806c05ef11ef8637 SHA1 2ddd443432cb94995c016f7943c28e815eb5d52a SHA256 be9d3c5a2714d279b180325fec99441611dbeaef0e61e5cc2b0c1b2406387d51
+MISC metadata.xml 526 RMD160 b4130ef4285e199d5c07d9848f095c138b7e5d39 SHA1 17a684cec86c065cec536197709034dcc6a8ae80 SHA256 4819cc3667c7460268fe9ada14c4c69606d30335d6a249da471d5c598b5c1e9e
diff --git a/sci-astronomy/wcslib/metadata.xml b/sci-astronomy/wcslib/metadata.xml
new file mode 100644
index 000000000000..99168ad415db
--- /dev/null
+++ b/sci-astronomy/wcslib/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ WCSLIB is a C library, supplied with a full set of Fortran wrappers,
+ that implements the "World Coordinate System" (WCS) convention in FITS
+ (Flexible Image Transport System). It also includes a PGPLOT-based routine,
+ PGSBOX, for drawing general curvilinear coordinate graticules and a number of
+ utility programs.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-astronomy/wcslib/wcslib-4.3.ebuild b/sci-astronomy/wcslib/wcslib-4.3.ebuild
new file mode 100644
index 000000000000..b3e2e37efd30
--- /dev/null
+++ b/sci-astronomy/wcslib/wcslib-4.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/wcslib/wcslib-4.3.ebuild,v 1.1 2008/07/15 15:16:24 bicatali Exp $
+
+inherit fortran multilib
+
+DESCRIPTION="Astronomical World Coordinate System transformations library"
+HOMEPAGE="http://www.atnf.csiro.au/people/mcalabre/WCS/"
+SRC_URI="ftp://ftp.atnf.csiro.au/pub/software/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+DEPEND="sci-libs/pgplot
+ sci-libs/cfitsio"
+
+FORTRAN="gfortran ifc g77"
+
+src_install () {
+ # make install from makefile is buggy
+
+ dobin utils/{HPXcvt,fitshdr,wcsgrid} || die "dobin failed"
+
+ dolib.a C/libwcs-${PV}.a pgsbox/libpgsbox-${PV}.a
+ dolib.so C/libwcs.so.${PV}
+ dosym libwcs.so.${PV} /usr/$(get_libdir)/libwcs.so
+ dosym libwcs-${PV}.a /usr/$(get_libdir)/libwcs.a
+ dosym libpgsbox-${PV}.a /usr/$(get_libdir)/libpgsbox.a
+
+ insinto /usr/include/${P}
+ doins pgsbox/*.h C/*.h Fortran/*inc || die "headers install failed"
+ dosym ${P} /usr/include/${PN}
+
+ dodoc README
+ newdoc C/CHANGES CHANGES_C
+ newdoc Fortran/CHANGES CHANGES_FORTRAN
+ newdoc pgsbox/CHANGES CHANGES_PGSBOX
+}