summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-07-16 17:47:20 +0000
committerJustin Lecher <jlec@gentoo.org>2011-07-16 17:47:20 +0000
commitf6fd1d8d4e286b3dec66ebf0721d3de4309cadca (patch)
tree37bdbdab934117aa1355b830329102fba8449603 /sci-astronomy
parentx86 stable, bug #372353 (diff)
downloadgentoo-2-f6fd1d8d4e286b3dec66ebf0721d3de4309cadca.tar.gz
gentoo-2-f6fd1d8d4e286b3dec66ebf0721d3de4309cadca.tar.bz2
gentoo-2-f6fd1d8d4e286b3dec66ebf0721d3de4309cadca.zip
Make it gold resistant, #372123
(Portage version: 2.2.0_alpha45/cvs/Linux x86_64)
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/celestia/ChangeLog6
-rw-r--r--sci-astronomy/celestia/celestia-1.6.0.ebuild6
-rw-r--r--sci-astronomy/celestia/celestia-1.6.1.ebuild9
-rw-r--r--sci-astronomy/celestia/files/celestia-1.6.1-gold.patch23
-rw-r--r--sci-astronomy/celestia/metadata.xml4
5 files changed, 41 insertions, 7 deletions
diff --git a/sci-astronomy/celestia/ChangeLog b/sci-astronomy/celestia/ChangeLog
index c72402087357..5e858075bab7 100644
--- a/sci-astronomy/celestia/ChangeLog
+++ b/sci-astronomy/celestia/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-astronomy/celestia
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.70 2011/06/12 10:42:44 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/ChangeLog,v 1.71 2011/07/16 17:47:20 jlec Exp $
+
+ 16 Jul 2011; Justin Lecher <jlec@gentoo.org> celestia-1.6.0.ebuild,
+ celestia-1.6.1.ebuild, +files/celestia-1.6.1-gold.patch, metadata.xml:
+ Make it gold resistant, #372123
*celestia-1.6.1 (12 Jun 2011)
diff --git a/sci-astronomy/celestia/celestia-1.6.0.ebuild b/sci-astronomy/celestia/celestia-1.6.0.ebuild
index 1a6df8e8287a..b31a32b80054 100644
--- a/sci-astronomy/celestia/celestia-1.6.0.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.0.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.19 2011/03/02 21:34:44 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.0.ebuild,v 1.20 2011/07/16 17:47:20 jlec Exp $
EAPI=2
+
inherit eutils flag-o-matic gnome2 autotools
DESCRIPTION="OpenGL 3D space simulator"
@@ -14,7 +15,8 @@ SLOT="0"
KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE="cairo gnome gtk nls pch theora threads"
-RDEPEND="virtual/opengl
+RDEPEND="
+ virtual/opengl
virtual/jpeg
media-libs/libpng
>=dev-lang/lua-5.0
diff --git a/sci-astronomy/celestia/celestia-1.6.1.ebuild b/sci-astronomy/celestia/celestia-1.6.1.ebuild
index 685e116d4e35..2ac03027cd31 100644
--- a/sci-astronomy/celestia/celestia-1.6.1.ebuild
+++ b/sci-astronomy/celestia/celestia-1.6.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.1 2011/06/12 10:42:44 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-astronomy/celestia/celestia-1.6.1.ebuild,v 1.2 2011/07/16 17:47:20 jlec Exp $
EAPI=2
+
inherit eutils flag-o-matic gnome2 autotools
DESCRIPTION="OpenGL 3D space simulator"
@@ -14,7 +15,8 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="cairo gnome gtk nls pch theora threads"
-RDEPEND="virtual/opengl
+RDEPEND="
+ virtual/opengl
virtual/jpeg
media-libs/libpng
>=dev-lang/lua-5.0
@@ -56,6 +58,9 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-as-needed.patch
# fix missing includes for gcc-4.6
epatch "${FILESDIR}"/${P}-gcc46.patch
+ # underlinking fix with USE="-gnome -gtk"
+ epatch "${FILESDIR}"/${P}-gold.patch
+
# remove flags to let the user decide
for cf in -O2 -ffast-math \
-fexpensive-optimizations \
diff --git a/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch b/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch
new file mode 100644
index 000000000000..392523324e09
--- /dev/null
+++ b/sci-astronomy/celestia/files/celestia-1.6.1-gold.patch
@@ -0,0 +1,23 @@
+ src/celestia/Makefile.am | 2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/src/celestia/Makefile.am b/src/celestia/Makefile.am
+index b1e4b3f..b0809a5 100644
+--- a/src/celestia/Makefile.am
++++ b/src/celestia/Makefile.am
+@@ -62,6 +62,7 @@ endif
+
+ if ENABLE_GLUT
+ GLUTSOURCES = glutmain.cpp
++GLUTLIBS = -lGL
+ endif
+
+ if ENABLE_THEORA
+@@ -83,6 +84,7 @@ celestia_LDADD = \
+ $(DL_LIBS) \
+ $(LUA_LIBS) \
+ $(THEORA_LIBS) \
++ $(GLUTLIBS) \
+ ../celengine/libcelengine.a \
+ ../celtxf/libceltxf.a \
+ ../cel3ds/libcel3ds.a \
diff --git a/sci-astronomy/celestia/metadata.xml b/sci-astronomy/celestia/metadata.xml
index 2931b38b9fac..e27f51014154 100644
--- a/sci-astronomy/celestia/metadata.xml
+++ b/sci-astronomy/celestia/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
Celestia is a real-time space simulation that lets you experience
our universe in three dimensions. You can travel throughout the solar
system, to any of over 100,000 stars, or beyond the galaxy. All