summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-06-20 20:48:56 +0000
committerJustin Lecher <jlec@gentoo.org>2012-06-20 20:48:56 +0000
commit5c49999bdbadbef0486d4cc626db73c71609836f (patch)
tree044026ef15f5161ee41030daa46830938ff05e1d /sci-biology/abyss/abyss-1.3.4.ebuild
parentstable for amd64 wrt bug #422473 (diff)
downloadgentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.tar.gz
gentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.tar.bz2
gentoo-2-5c49999bdbadbef0486d4cc626db73c71609836f.zip
sci-biology/abyss: Fix compilation with gcc-4.7, #422599; install docs inside /usr/share/doc/, #297205
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/abyss/abyss-1.3.4.ebuild')
-rw-r--r--sci-biology/abyss/abyss-1.3.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/abyss/abyss-1.3.4.ebuild b/sci-biology/abyss/abyss-1.3.4.ebuild
new file mode 100644
index 000000000000..6ce67798ca99
--- /dev/null
+++ b/sci-biology/abyss/abyss-1.3.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/abyss/abyss-1.3.4.ebuild,v 1.1 2012/06/20 20:48:56 jlec Exp $
+
+EAPI="4"
+
+inherit autotools eutils
+
+DESCRIPTION="Assembly By Short Sequences - a de novo, parallel, paired-end sequence assembler"
+HOMEPAGE="http://www.bcgsc.ca/platform/bioinfo/software/abyss/"
+SRC_URI="http://www.bcgsc.ca/downloads/abyss/${P}.tar.gz"
+
+LICENSE="abyss"
+SLOT="0"
+IUSE="+mpi openmp"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-cpp/sparsehash
+ mpi? ( virtual/mpi )"
+RDEPEND="${DEPEND}"
+
+# todo: --enable-maxk=N configure option
+# todo: fix automagic mpi toggling
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.7.patch
+ sed -i -e "s/-Werror//" configure.ac || die #365195
+ sed -i -e "/dist_pkgdoc_DATA/d" Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable openmp)
+}