summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-20 07:29:19 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-20 07:29:19 +0000
commit284a462d0486c565c0a5c3f72a16a7a6a85d7541 (patch)
treee85b1b5f04fe49763ebae095ae4a4b955b32ffe4 /sci-biology/allpaths/files
parentDropped as it isn't needed anymore (diff)
downloadgentoo-2-284a462d0486c565c0a5c3f72a16a7a6a85d7541.tar.gz
gentoo-2-284a462d0486c565c0a5c3f72a16a7a6a85d7541.tar.bz2
gentoo-2-284a462d0486c565c0a5c3f72a16a7a6a85d7541.zip
superseeded by sci-biology/allpathslg
Upstream wants anybody to move over
Diffstat (limited to 'sci-biology/allpaths/files')
-rw-r--r--sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch30
-rw-r--r--sci-biology/allpaths/files/allpaths-3.1-boost-1.50-2.patch185
-rw-r--r--sci-biology/allpaths/files/allpaths-3.1-boost-1.50.patch47
-rw-r--r--sci-biology/allpaths/files/allpaths-3.1-gcc4.7.patch264
-rw-r--r--sci-biology/allpaths/files/allpaths-3.1-linking.patch173
5 files changed, 0 insertions, 699 deletions
diff --git a/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch b/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch
deleted file mode 100644
index d4fe428efa26..000000000000
--- a/sci-biology/allpaths/files/allpaths-2.0-gcc-x86-no-autocast.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-diff -durr work.orig/SortKmersImpl.h work/SortKmersImpl.h
---- work.orig/SortKmersImpl.h 2009-08-20 11:25:39.336695499 +0000
-+++ work/SortKmersImpl.h 2009-08-20 11:25:51.431932630 +0000
-@@ -98,7 +98,7 @@
- { if ( reads[l].size( ) < KSPAN ) continue;
- unsigned int N = reads[l].size( ) - KSPAN + 1;
- if ( S + 2*N >= R.size( ) ) {
-- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
-+ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
- if ( nn < R.size( ) ) FatalErr( "SortKmers<1>: Unsigned-int overflow (R=" << R.size( ) << ")" );
- R.resize(nn);
- }
-@@ -180,7 +180,7 @@
- }
- if ( q == N ) break;
- if ( S + 2*N >= R.size( ) ) {
-- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
-+ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
- if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
- R.resize(nn);
- }
-@@ -207,7 +207,7 @@
- top += Min( N - top, (unsigned int) 10000 );
-
- if ( S + 20000 >= R.size( ) || S + 2*N >= R.size( ) ) {
-- unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (R.size( ) + 2*N) );
-+ unsigned nn = Max( (long unsigned) ( 1.2 * R.size( ) ), (long unsigned) (R.size( ) + 2*N) );
- if ( nn < R.size( ) ) FatalErr( "SortKmers<10>: Unsigned-int overflow (R=" << R.size( ) << ")" );
- R.resize(nn);
- }
diff --git a/sci-biology/allpaths/files/allpaths-3.1-boost-1.50-2.patch b/sci-biology/allpaths/files/allpaths-3.1-boost-1.50-2.patch
deleted file mode 100644
index 9a90410fe95c..000000000000
--- a/sci-biology/allpaths/files/allpaths-3.1-boost-1.50-2.patch
+++ /dev/null
@@ -1,185 +0,0 @@
- MakeDepend.cc | 9 +++++----
- Makefile.in | 12 ++++++------
- Makefile_g++ | 3 ++-
- TestProgram.cc | 1 +
- lookup/CreateLookupTab.cc | 3 +++
- paths/AlignPairsToHyper3G.cc | 2 ++
- paths/ErrorCorrectJump.cc | 2 ++
- reporting/FastbStats.cc | 1 +
- util/FastaParser.cc | 3 +++
- 9 files changed, 25 insertions(+), 11 deletions(-)
-
-diff --git a/MakeDepend.cc b/MakeDepend.cc
-index 619e6f7..b8d9c72 100644
---- a/MakeDepend.cc
-+++ b/MakeDepend.cc
-@@ -1032,7 +1032,7 @@ void makefile_builder::GenerateMakefileForSharedLibs( ostream &mf )
- mf << " " << dep_iter->Provider();
- mf << "\n";
- mf << "\t" << "mkdir -p $(LIB)" << endl;
-- mf << "\t" << "$(CPLUSPLUS) $(CPPO) $(PIC) $(SYS_SHARED) -o $(LIB)/" << *lib_iter;
-+ mf << "\t" << "$(CPLUSPLUS) $(CPPO) $(PIC) $(SYS_SHARED) $(L_FLAGS) -o $(LIB)/" << *lib_iter;
- for ( vector<dependency>::iterator dep_iter = link_deps.first;
- dep_iter != link_deps.second; ++dep_iter )
- mf << " $(OBJ)/" << dep_iter->Provider();
-@@ -1182,7 +1182,7 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- mf << " $(OBJ)/" << *dep_iter;
- }
- mf << "\n\t$(BIN)/checkLock $(BIN)/$@";
-- mf << "\n\t$(CPLUSPLUS) $(LINK_OPTIONS) -o $(BIN)/$@ ";
-+ mf << "\n\t$(CPLUSPLUS) $(LINK_OPTIONS) $(L_FLAGS) -o $(BIN)/$@ ";
- for ( set<string>::iterator dep_iter = obj_deps.begin();
- dep_iter != obj_deps.end(); ++dep_iter )
- {
-@@ -1195,7 +1195,8 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- mf << " $(OBJ)/" << *dep_iter;
- }
- }
-- mf << " $(OBJ)/LinkTimestamp.o -L. -L$(LIB) -L$(OBJ) $(LINK_LIBS)";
-+ mf << " $(OBJ)/LinkTimestamp.o $(PTHREAD_OBJ) -L. -L$(LIB) -L$(OBJ)";
-+ mf << " -l" << libname;
- for ( set<string>::iterator dep_iter = lib_deps.begin();
- dep_iter != lib_deps.end(); ++dep_iter )
- mf << " " << "$(" << *dep_iter << "_LFLAGS)";
-@@ -1208,7 +1209,7 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- sharedlib_name.erase( sharedlib_name.size() - 3, 3 );
- mf << " -l" << sharedlib_name;
- }
-- mf << " -l" << libname;
-+ mf << " $(LINK_LIBS)";
- mf << "\n\t" << "/bin/rm $(OBJ)/lib" << libname << ".a\n";
- }
- }
-diff --git a/Makefile.in b/Makefile.in
-index f20db27..fe45b4c 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -106,9 +106,9 @@ vpath % $(BIN)
- ##############################################################################
-
- # our boost dependancies
--BOOST_FILESYSTEM_LFLAGS = -lboost_filesystem-@BOOST_TAG@ -lboost_system-@BOOST_TAG@
-+BOOST_FILESYSTEM_LFLAGS = -lboost_filesystem-@BOOST_TAG@ -lboost_system-@BOOST_TAG@ -lboost_system
- BOOST_IOSTREAMS_LFLAGS = -lboost_iostreams-@BOOST_TAG@
--BOOST_SERIALIZATION_LFLAGS = -lboost_serialization-@BOOST_TAG@ -lboost_system-@BOOST_TAG@
-+BOOST_SERIALIZATION_LFLAGS = -lboost_serialization-@BOOST_TAG@ -lboost_system-@BOOST_TAG@ -lboost_system
-
- # PUT OUR GMP FLAGS HERE
- GMP_LFLAGS = @GMP_LIB@
-@@ -340,10 +340,10 @@ LINK_OPTIONS = \
- $(PTHREAD_LINK)
-
- LINK_LIBS = \
-+ @LIBRARIES@ \
- @LIBS@ \
- $(OMP_LIBS) \
-- $(PTHREAD_LIBS) \
-- @LIBRARIES@
-+ $(PTHREAD_LIBS)
-
- CPPO = $(LINK_OPTIONS)
- CPPC = $(CPP_OPTIONS) $(SYS_MEMTRACK)
-@@ -420,10 +420,10 @@ execs_size:
- MakeDepend: MakeDepend.cc
- @ mkdir -p $(BIN)
- echo $(PATH)
-- $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
-+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) $(L_FLAGS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
-
- checkLock: $(SRC)/util/checkLock.cc
-- $(CPLUSPLUS) $(SRC)/util/checkLock.cc -o $(BIN)/checkLock
-+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SRC)/util/checkLock.cc $(L_FLAGS) -o $(BIN)/checkLock
-
- MemTracker.o: MemTracker.cc
- @ mkdir -p $(OBJ)
-diff --git a/Makefile_g++ b/Makefile_g++
-index 8dc8572..2a29ecc 100644
---- a/Makefile_g++
-+++ b/Makefile_g++
-@@ -29,7 +29,8 @@ PIC = -fPIC
- #############################################################
-
- # pThread library
--PTHREAD_LFLAGS = $(OBJ)/system/Threads.o -lpthread
-+PTHREAD_LFLAGS = -lpthread
-+PTHREAD_OBJ = $(OBJ)/system/Threads.o
- PTHREAD_LIB = system/Threads.o
-
- #### Zlib library setup ####
-diff --git a/TestProgram.cc b/TestProgram.cc
-index e779fab..b480add 100644
---- a/TestProgram.cc
-+++ b/TestProgram.cc
-@@ -1,5 +1,6 @@
- // MakeDepend: library BOOST_FILESYSTEM
- // MakeDepend: library GMPXX
-+// MakeDepend: library GMP
- #include <gmpxx.h>
- #include <iostream>
- #include <boost/filesystem/path.hpp>
-diff --git a/lookup/CreateLookupTab.cc b/lookup/CreateLookupTab.cc
-index 44f2579..ac5c3bb 100644
---- a/lookup/CreateLookupTab.cc
-+++ b/lookup/CreateLookupTab.cc
-@@ -18,6 +18,9 @@
- * This program just builds a singly-linked list of Locations for each kmer, and then walks each
- * list to write them out to a feudal file.
- */
-+
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/paths/AlignPairsToHyper3G.cc b/paths/AlignPairsToHyper3G.cc
-index 5a0fda6..7b284a8 100644
---- a/paths/AlignPairsToHyper3G.cc
-+++ b/paths/AlignPairsToHyper3G.cc
-@@ -7,6 +7,8 @@
- // can be responsible for its use, misuse, or functionality. //
- /////////////////////////////////////////////////////////////////////////////
-
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/paths/ErrorCorrectJump.cc b/paths/ErrorCorrectJump.cc
-index 40c8536..bb4d779 100644
---- a/paths/ErrorCorrectJump.cc
-+++ b/paths/ErrorCorrectJump.cc
-@@ -7,6 +7,8 @@
- // can be responsible for its use, misuse, or functionality. //
- /////////////////////////////////////////////////////////////////////////////
-
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/reporting/FastbStats.cc b/reporting/FastbStats.cc
-index f87f295..ba7dbe3 100644
---- a/reporting/FastbStats.cc
-+++ b/reporting/FastbStats.cc
-@@ -8,6 +8,7 @@
- /////////////////////////////////////////////////////////////////////////////
-
- // Basic stats for a fastb file.
-+// MakeDepend: library BOOST_SYSTEM
-
- #include "Basevector.h"
- #include "math/Functions.h"
-diff --git a/util/FastaParser.cc b/util/FastaParser.cc
-index 8b3dbc8..dc1d2cf 100644
---- a/util/FastaParser.cc
-+++ b/util/FastaParser.cc
-@@ -13,6 +13,9 @@
- *
- * \brief Several utility classes for reading FASTA files.
- */
-+
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
diff --git a/sci-biology/allpaths/files/allpaths-3.1-boost-1.50.patch b/sci-biology/allpaths/files/allpaths-3.1-boost-1.50.patch
deleted file mode 100644
index 23c031041e14..000000000000
--- a/sci-biology/allpaths/files/allpaths-3.1-boost-1.50.patch
+++ /dev/null
@@ -1,47 +0,0 @@
- configure | 4 ++--
- system/file/File.h | 6 +++---
- 2 files changed, 5 insertions(+), 5 deletions(-)
-
-diff --git a/configure b/configure
-index 37b9812..b966fd7 100755
---- a/configure
-+++ b/configure
-@@ -9872,8 +9872,8 @@ $as_echo "found boost version $_version" >&6; }
- # using system specifics
-
- # lets use the system library
-- BOOST_WITH_COMP="libboost_filesystem-$CC$GCC_MAJOR_MINOR-mt.a"
-- BOOST_WITHOUT="libboost_filesystem-mt.a"
-+ BOOST_WITH_COMP="libboost_filesystem-$CC$GCC_MAJOR_MINOR-mt.so"
-+ BOOST_WITHOUT="libboost_filesystem-mt.so"
-
- # lets say that we're checking that
- { $as_echo "$as_me:$LINENO: checking for boost library name" >&5
-diff --git a/system/file/File.h b/system/file/File.h
-index da78272..14c9c62 100644
---- a/system/file/File.h
-+++ b/system/file/File.h
-@@ -149,7 +149,7 @@ public:
- /// return the filename portion of the file path
- /// e.g., /home/user/boat/file.txt would return file.txt
- std::string Filename() const
-- { return mPath.filename(); }
-+ { return mPath.filename().string(); }
-
- /// return the path portion of the filename
- /// e.g., /home/user/boat/file.txt would return /home/user/boat
-@@ -163,12 +163,12 @@ public:
- /// return the filename with its final extension (if any) removed
- /// e.g., /home/user/boat/file.txt would return /home/user/boat/file
- std::string Stem() const
-- { return mPath.stem(); }
-+ { return mPath.stem().string(); }
-
- /// return the final extension (empty string, if there is none)
- /// e.g., /home/user/boat/file.txt would return .txt
- std::string Extension() const
-- { return mPath.extension(); }
-+ { return mPath.extension().string(); }
-
- /// make a new File with a path obtained by removing this File's final extension, if any,
- /// and gluing on the newExtension (preceded by a '.' if it doesn't already start with one).
diff --git a/sci-biology/allpaths/files/allpaths-3.1-gcc4.7.patch b/sci-biology/allpaths/files/allpaths-3.1-gcc4.7.patch
deleted file mode 100644
index a2f4b4d37c75..000000000000
--- a/sci-biology/allpaths/files/allpaths-3.1-gcc4.7.patch
+++ /dev/null
@@ -1,264 +0,0 @@
- MakeDepend.cc | 1 +
- Vec.h | 12 ++++++------
- feudal/BinaryStream.h | 4 ++++
- feudal/FeudalControlBlock.cc | 1 +
- feudal/FeudalFileReader.h | 1 +
- feudal/MasterVec.h | 14 +++++++-------
- feudal/SerfVec.h | 4 ++--
- reporting/ScaffoldLayout.cc | 10 +++++-----
- system/ProcBuf.cc | 12 ++++++------
- 9 files changed, 33 insertions(+), 26 deletions(-)
-
-diff --git a/MakeDepend.cc b/MakeDepend.cc
-index 93032e8..619e6f7 100644
---- a/MakeDepend.cc
-+++ b/MakeDepend.cc
-@@ -25,6 +25,7 @@
- #include <iterator>
- #include <iostream>
- #include <ctype.h>
-+#include <unistd.h>
-
- using namespace std;
-
-diff --git a/Vec.h b/Vec.h
-index f26f3f4..e2d26a4 100644
---- a/Vec.h
-+++ b/Vec.h
-@@ -259,11 +259,11 @@ template <class T> class vec : public vector<T> {
-
- template <class U>
- void append( const vec<U>& y )
-- { insert( this->end( ), y.begin( ), y.end( ) ); }
-+ { this->insert( this->end( ), y.begin( ), y.end( ) ); }
-
- void append( const vec<T>& y, size_type i, size_type j ) {
-- if ( j == y.size( ) ) insert( this->end( ), y.begin( ) + i, y.end( ) );
-- else insert( this->end( ), y.begin( ) + i, y.begin( ) + j );
-+ if ( j == y.size( ) ) this->insert( this->end( ), y.begin( ) + i, y.end( ) );
-+ else this->insert( this->end( ), y.begin( ) + i, y.begin( ) + j );
- }
-
- // appends values in y, but only those whose indices are in entries
-@@ -339,7 +339,7 @@ template <class T> class vec : public vector<T> {
-
- void SetToRangeOf( const vec<T>& v, size_type i, size_type j ) {
- AssertLe( i, j );
-- assign(v.begin() + i, v.begin() + j);
-+ this->assign(v.begin() + i, v.begin() + j);
- }
-
- inline friend vec<T> RangeOf( const vec<T>& v, size_type i, size_type j ) {
-@@ -397,12 +397,12 @@ template <class T> class vec : public vector<T> {
- /// Erase: erase range of elements, where range is given by half-open interval.
-
- void Erase( size_type start, size_type stop ) {
-- erase( this->begin( ) + start, this->begin( ) + stop );
-+ this->erase( this->begin( ) + start, this->begin( ) + stop );
- }
-
- /// EraseValue: erase all entries having the given value.
- void EraseValue( const T& x ) {
-- erase(remove(this->begin(), this->end(), x), this->end());
-+ this->erase(remove(this->begin(), this->end(), x), this->end());
- }
-
- /// print values to ostream, separated by sep.
-diff --git a/feudal/BinaryStream.h b/feudal/BinaryStream.h
-index f54d8a9..c61469b 100644
---- a/feudal/BinaryStream.h
-+++ b/feudal/BinaryStream.h
-@@ -144,6 +144,10 @@ private:
- std::ostream& mOS;
- };
-
-+template <typename T1, typename T2>
-+inline size_t serializedSizeof( std::pair<T1,T2>* );
-+
-+
- /// Reader of binary streams.
- class BinaryReader
- {
-diff --git a/feudal/FeudalControlBlock.cc b/feudal/FeudalControlBlock.cc
-index bc64ecd..a709320 100644
---- a/feudal/FeudalControlBlock.cc
-+++ b/feudal/FeudalControlBlock.cc
-@@ -24,6 +24,7 @@
- #include <string.h>
- #include <errno.h>
- #include <iostream>
-+#include <unistd.h>
-
- using std::cout;
- using std::endl;
-diff --git a/feudal/FeudalFileReader.h b/feudal/FeudalFileReader.h
-index b71bf6d..073a1a1 100644
---- a/feudal/FeudalFileReader.h
-+++ b/feudal/FeudalFileReader.h
-@@ -13,6 +13,7 @@
- #include <string>
- #include <cassert>
- #include <sstream>
-+#include <unistd.h>
- #include "feudal/BinaryStream.h"
-
- /**
-diff --git a/feudal/MasterVec.h b/feudal/MasterVec.h
-index e6477d9..b88e9fe 100644
---- a/feudal/MasterVec.h
-+++ b/feudal/MasterVec.h
-@@ -60,20 +60,20 @@ public:
- /// This function is deprecated: Use reserve() instead.
- /// The pool size argument is ignored, anyway.
- MasterVec& Reserve( unsigned long raw_mem_size_ignored, size_type capacity )
-- { reserve(capacity); return *this; }
-+ { this->reserve(capacity); return *this; }
-
- /// This function is deprecated: Use clear().shrink_to_fit().
- MasterVec& destroy() { BaseT::clear(); BaseT::shrink_to_fit(); return *this; }
-
- /// This function is deprecated: Use push_back().
- MasterVec& push_back_external( T const& val )
-- { push_back(val); return *this; }
-+ { this->push_back(val); return *this; }
-
- /// This function is deprecated: Use push_back().
- MasterVec& push_back_reserve( T const& val,
- size_type growthIncr = 0,
- float growthFact = 1.3f )
-- { push_back(val,growthFact,growthIncr); return *this; }
-+ { this->push_back(val,growthFact,growthIncr); return *this; }
-
- /// This function is deprecated: Use append().
- MasterVec& Append( MasterVec const& that )
-@@ -81,7 +81,7 @@ public:
-
- /// This function is deprecated: Use append().
- MasterVec& Append( MasterVec const& that, size_type from, size_type to )
-- { append(that.begin(from),that.begin(to)); return *this; }
-+ { this->append(that.begin(from),that.begin(to)); return *this; }
-
- MasterVec const& WriteAll( String const& fileName ) const
- { return WriteRange(fileName,0UL,BaseT::size()); return *this; }
-@@ -99,7 +99,7 @@ public:
- { if ( !append ) BaseT::clear();
- FeudalFileReader rdr(fileName.c_str(),T::fixedDataLen());
- size_type siz = rdr.getNElements();
-- reserve(BaseT::size()+siz);
-+ this->reserve(BaseT::size()+siz);
- for ( size_type iii = 0; iii < siz; ++iii )
- appendFromReader(rdr,iii);
- return *this; }
-@@ -148,7 +148,7 @@ public:
- vec<int> const& entries,
- int /*extra*/ = 0, Bool /*pre_reserved*/ = False )
- { VirtualMasterVec<T> vVec(fileName.c_str());
-- if ( BaseT::size() < vVec.size() ) resize(vVec.size());
-+ if ( BaseT::size() < vVec.size() ) this->resize(vVec.size());
- vec<int>::const_iterator end(entries.end());
- for ( vec<int>::const_iterator itr(entries.begin()); itr != end; ++itr )
- { BaseT::operator[](*itr) = vVec[*itr]; }
-@@ -158,7 +158,7 @@ public:
- size_t from, size_t to,
- int /* extra */ = 0 )
- { VirtualMasterVec<T> vVec(fileName.c_str());
-- if ( BaseT::size() < vVec.size() ) resize(vVec.size());
-+ if ( BaseT::size() < vVec.size() ) this->resize(vVec.size());
- for ( ; from < to; ++from ) (*this)[from] = vVec[from];
- return *this; }
-
-diff --git a/feudal/SerfVec.h b/feudal/SerfVec.h
-index e91847c..d5f053d 100644
---- a/feudal/SerfVec.h
-+++ b/feudal/SerfVec.h
-@@ -79,10 +79,10 @@ public:
- /// Deprecated: Use assign().
- SerfVec& SetToSubOf( SerfVec const& that, size_type pos, size_type len )
- { if ( this != &that )
-- { assign(that.begin(pos),that.begin(pos+len)); }
-+ { this->assign(that.begin(pos),that.begin(pos+len)); }
- else
- { assert(that.size()>=pos+len);
-- erase(BaseT::begin(),BaseT::begin(pos));
-+ this->erase(BaseT::begin(),BaseT::begin(pos));
- BaseT::resize(len); }
- return *this; }
-
-diff --git a/reporting/ScaffoldLayout.cc b/reporting/ScaffoldLayout.cc
-index 7c39718..646b106 100644
---- a/reporting/ScaffoldLayout.cc
-+++ b/reporting/ScaffoldLayout.cc
-@@ -66,13 +66,13 @@ int main(int argc, char **argv)
- // This version finds the first and last non-ambiguous sequences of
- // END_SIZE_MIN <= length <= end_size_max
- // --bruce
-- int j, k;
-+ int l, k;
- int end_size_max = min(END_SIZE_MAX, scaffold_size/2);
-- for (j = k = 0; k < scaffold_size; k++) {
-+ for (l = k = 0; k < scaffold_size; k++) {
- if (assembly_amb[i][k]) {
-- if (k-j >= END_SIZE_MIN) break;
-- else j = k+1;
-- } else if (k-j >= end_size_max) break;
-+ if (k-l >= END_SIZE_MIN) break;
-+ else l = k+1;
-+ } else if (k-l >= end_size_max) break;
- }
- e.SetToSubOf( assembly[i], j, k-j );
- ENDS.push_back_reserve(e);
-diff --git a/system/ProcBuf.cc b/system/ProcBuf.cc
-index 748cc6b..5b91ed3 100644
---- a/system/ProcBuf.cc
-+++ b/system/ProcBuf.cc
-@@ -189,12 +189,12 @@ basic_procbuf<charT,traits>::overflow( int_type c )
- Assert(M_internal_put_buffer == NULL);
- M_internal_put_buffer = new char_type [DEFAULT_PUT_BUFFER_SIZE];
- M_internal_put_buffer_end = M_internal_put_buffer+DEFAULT_PUT_BUFFER_SIZE;
-- setp(M_internal_put_buffer,
-+ this->setp(M_internal_put_buffer,
- M_internal_put_buffer_end);
- } else if (!flush())
- return traits_type::eof();
- if (!traits_type::eq_int_type(c, traits_type::eof()))
-- return sputc(c);
-+ return this->sputc(c);
- else
- return traits_type::not_eof(c);
- }
-@@ -234,7 +234,7 @@ basic_procbuf<charT,traits>::pbackfail( int_type c )
- // (which is start of buffer)
- std::copy_backward(this->eback(), this->egptr(), this->egptr()+1);
- *(this->gptr()) = traits_type::to_char_type(c);
-- setg(this->eback(), this->gptr(), this->egptr()+1);
-+ this->setg(this->eback(), this->gptr(), this->egptr()+1);
- return traits_type::not_eof(c);
- } else
- return traits_type::eof();
-@@ -263,7 +263,7 @@ basic_procbuf<charT,traits>::flush( )
- // doing wchars and we write an odd # of bytes?
- return false;
- } else {
-- setp(this->pbase(), this->epptr());
-+ this->setp(this->pbase(), this->epptr());
- return true;
- }
- }
-@@ -277,7 +277,7 @@ basic_procbuf<charT,traits>::fill( )
- Assert(M_internal_get_buffer == NULL);
- M_internal_get_buffer = new char_type[DEFAULT_GET_BUFFER_SIZE];
- M_internal_get_buffer_end = M_internal_get_buffer + DEFAULT_GET_BUFFER_SIZE;
-- setg(M_internal_get_buffer, M_internal_get_buffer_end, M_internal_get_buffer_end);
-+ this->setg(M_internal_get_buffer, M_internal_get_buffer_end, M_internal_get_buffer_end);
- }
- // The "get" pointer should be at the end of the buffer - that's
- // why we need to fill it.
-@@ -312,7 +312,7 @@ basic_procbuf<charT,traits>::fill( )
- //
- // reset the get pointers
- //
-- setg(M_internal_get_buffer,
-+ this->setg(M_internal_get_buffer,
- M_internal_get_buffer,
- M_internal_get_buffer+numusable/sizeof(char_type));
- return true;
diff --git a/sci-biology/allpaths/files/allpaths-3.1-linking.patch b/sci-biology/allpaths/files/allpaths-3.1-linking.patch
deleted file mode 100644
index ccb54ea24530..000000000000
--- a/sci-biology/allpaths/files/allpaths-3.1-linking.patch
+++ /dev/null
@@ -1,173 +0,0 @@
- MakeDepend.cc | 9 +++++----
- Makefile.in | 9 +++++----
- Makefile_g++ | 3 ++-
- TestProgram.cc | 1 +
- lookup/CreateLookupTab.cc | 3 +++
- paths/AlignPairsToHyper3G.cc | 2 ++
- paths/ErrorCorrectJump.cc | 2 ++
- reporting/FastbStats.cc | 1 +
- util/FastaParser.cc | 3 +++
- 9 files changed, 24 insertions(+), 9 deletions(-)
-
-diff --git a/MakeDepend.cc b/MakeDepend.cc
-index 619e6f7..b8d9c72 100644
---- a/MakeDepend.cc
-+++ b/MakeDepend.cc
-@@ -1032,7 +1032,7 @@ void makefile_builder::GenerateMakefileForSharedLibs( ostream &mf )
- mf << " " << dep_iter->Provider();
- mf << "\n";
- mf << "\t" << "mkdir -p $(LIB)" << endl;
-- mf << "\t" << "$(CPLUSPLUS) $(CPPO) $(PIC) $(SYS_SHARED) -o $(LIB)/" << *lib_iter;
-+ mf << "\t" << "$(CPLUSPLUS) $(CPPO) $(PIC) $(SYS_SHARED) $(L_FLAGS) -o $(LIB)/" << *lib_iter;
- for ( vector<dependency>::iterator dep_iter = link_deps.first;
- dep_iter != link_deps.second; ++dep_iter )
- mf << " $(OBJ)/" << dep_iter->Provider();
-@@ -1182,7 +1182,7 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- mf << " $(OBJ)/" << *dep_iter;
- }
- mf << "\n\t$(BIN)/checkLock $(BIN)/$@";
-- mf << "\n\t$(CPLUSPLUS) $(LINK_OPTIONS) -o $(BIN)/$@ ";
-+ mf << "\n\t$(CPLUSPLUS) $(LINK_OPTIONS) $(L_FLAGS) -o $(BIN)/$@ ";
- for ( set<string>::iterator dep_iter = obj_deps.begin();
- dep_iter != obj_deps.end(); ++dep_iter )
- {
-@@ -1195,7 +1195,8 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- mf << " $(OBJ)/" << *dep_iter;
- }
- }
-- mf << " $(OBJ)/LinkTimestamp.o -L. -L$(LIB) -L$(OBJ) $(LINK_LIBS)";
-+ mf << " $(OBJ)/LinkTimestamp.o $(PTHREAD_OBJ) -L. -L$(LIB) -L$(OBJ)";
-+ mf << " -l" << libname;
- for ( set<string>::iterator dep_iter = lib_deps.begin();
- dep_iter != lib_deps.end(); ++dep_iter )
- mf << " " << "$(" << *dep_iter << "_LFLAGS)";
-@@ -1208,7 +1209,7 @@ void makefile_builder::GenerateMakefileForExecutables( ostream &mf )
- sharedlib_name.erase( sharedlib_name.size() - 3, 3 );
- mf << " -l" << sharedlib_name;
- }
-- mf << " -l" << libname;
-+ mf << " $(LINK_LIBS)";
- mf << "\n\t" << "/bin/rm $(OBJ)/lib" << libname << ".a\n";
- }
- }
-diff --git a/Makefile.in b/Makefile.in
-index f20db27..289af1c 100644
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -106,9 +106,10 @@ vpath % $(BIN)
- ##############################################################################
-
- # our boost dependancies
--BOOST_FILESYSTEM_LFLAGS = -lboost_filesystem-@BOOST_TAG@ -lboost_system-@BOOST_TAG@
-+BOOST_SYSTEM = -lboost_system
-+BOOST_FILESYSTEM_LFLAGS = -lboost_filesystem-@BOOST_TAG@ -lboost_system-@BOOST_TAG@ -lboost_system
- BOOST_IOSTREAMS_LFLAGS = -lboost_iostreams-@BOOST_TAG@
--BOOST_SERIALIZATION_LFLAGS = -lboost_serialization-@BOOST_TAG@ -lboost_system-@BOOST_TAG@
-+BOOST_SERIALIZATION_LFLAGS = -lboost_serialization-@BOOST_TAG@ -lboost_system-@BOOST_TAG@ -lboost_system
-
- # PUT OUR GMP FLAGS HERE
- GMP_LFLAGS = @GMP_LIB@
-@@ -420,10 +421,10 @@ execs_size:
- MakeDepend: MakeDepend.cc
- @ mkdir -p $(BIN)
- echo $(PATH)
-- $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
-+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SYS_LANG) $(MAKEDEPEND_OPTS) $(L_FLAGS) -o $(BIN)/MakeDepend $(SRC)/MakeDepend.cc
-
- checkLock: $(SRC)/util/checkLock.cc
-- $(CPLUSPLUS) $(SRC)/util/checkLock.cc -o $(BIN)/checkLock
-+ $(CPLUSPLUS) $(CPPO) $(CPPC) $(SRC)/util/checkLock.cc $(L_FLAGS) -o $(BIN)/checkLock
-
- MemTracker.o: MemTracker.cc
- @ mkdir -p $(OBJ)
-diff --git a/Makefile_g++ b/Makefile_g++
-index 8dc8572..2a29ecc 100644
---- a/Makefile_g++
-+++ b/Makefile_g++
-@@ -29,7 +29,8 @@ PIC = -fPIC
- #############################################################
-
- # pThread library
--PTHREAD_LFLAGS = $(OBJ)/system/Threads.o -lpthread
-+PTHREAD_LFLAGS = -lpthread
-+PTHREAD_OBJ = $(OBJ)/system/Threads.o
- PTHREAD_LIB = system/Threads.o
-
- #### Zlib library setup ####
-diff --git a/TestProgram.cc b/TestProgram.cc
-index e779fab..b480add 100644
---- a/TestProgram.cc
-+++ b/TestProgram.cc
-@@ -1,5 +1,6 @@
- // MakeDepend: library BOOST_FILESYSTEM
- // MakeDepend: library GMPXX
-+// MakeDepend: library GMP
- #include <gmpxx.h>
- #include <iostream>
- #include <boost/filesystem/path.hpp>
-diff --git a/lookup/CreateLookupTab.cc b/lookup/CreateLookupTab.cc
-index 44f2579..ac5c3bb 100644
---- a/lookup/CreateLookupTab.cc
-+++ b/lookup/CreateLookupTab.cc
-@@ -18,6 +18,9 @@
- * This program just builds a singly-linked list of Locations for each kmer, and then walks each
- * list to write them out to a feudal file.
- */
-+
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/paths/AlignPairsToHyper3G.cc b/paths/AlignPairsToHyper3G.cc
-index 5a0fda6..7b284a8 100644
---- a/paths/AlignPairsToHyper3G.cc
-+++ b/paths/AlignPairsToHyper3G.cc
-@@ -7,6 +7,8 @@
- // can be responsible for its use, misuse, or functionality. //
- /////////////////////////////////////////////////////////////////////////////
-
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/paths/ErrorCorrectJump.cc b/paths/ErrorCorrectJump.cc
-index 40c8536..bb4d779 100644
---- a/paths/ErrorCorrectJump.cc
-+++ b/paths/ErrorCorrectJump.cc
-@@ -7,6 +7,8 @@
- // can be responsible for its use, misuse, or functionality. //
- /////////////////////////////////////////////////////////////////////////////
-
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif
-diff --git a/reporting/FastbStats.cc b/reporting/FastbStats.cc
-index f87f295..ba7dbe3 100644
---- a/reporting/FastbStats.cc
-+++ b/reporting/FastbStats.cc
-@@ -8,6 +8,7 @@
- /////////////////////////////////////////////////////////////////////////////
-
- // Basic stats for a fastb file.
-+// MakeDepend: library BOOST_SYSTEM
-
- #include "Basevector.h"
- #include "math/Functions.h"
-diff --git a/util/FastaParser.cc b/util/FastaParser.cc
-index 8b3dbc8..dc1d2cf 100644
---- a/util/FastaParser.cc
-+++ b/util/FastaParser.cc
-@@ -13,6 +13,9 @@
- *
- * \brief Several utility classes for reading FASTA files.
- */
-+
-+// MakeDepend: library BOOST_SYSTEM
-+
- #ifndef FORCE_DEBUG
- #define NDEBUG
- #endif