summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-07-21 14:45:20 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-07-21 14:45:20 +0000
commit10634d473bd08d984d420eb2be693ec577fbc976 (patch)
treedf09091b7d5fa2ed7b982b3d08ed50d49141ae39 /sci-biology/emboss
parentAdd java-ant-2. (diff)
downloadgentoo-2-10634d473bd08d984d420eb2be693ec577fbc976.tar.gz
gentoo-2-10634d473bd08d984d420eb2be693ec577fbc976.tar.bz2
gentoo-2-10634d473bd08d984d420eb2be693ec577fbc976.zip
New upstream version
(Portage version: 2.1-r1)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog8
-rw-r--r--sci-biology/emboss/emboss-4.0.0.ebuild84
-rw-r--r--sci-biology/emboss/files/digest-emboss-4.0.03
3 files changed, 94 insertions, 1 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index a0ea73cb44fd..77c5c6ff683d 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/emboss
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.33 2006/04/20 01:09:45 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.34 2006/07/21 14:45:20 ribosome Exp $
+
+*emboss-4.0.0 (21 Jul 2006)
+
+ 21 Jul 2006; Olivier Fisette <ribosome@gentoo.org> +emboss-4.0.0.ebuild:
+ New upstream version. See change log:
+ "http://emboss.sourceforge.net/developers/changelog.html".
20 Apr 2006; Olivier Fisette <ribosome@gentoo.org> -emboss-3.0.0.ebuild:
Removed old revision.
diff --git a/sci-biology/emboss/emboss-4.0.0.ebuild b/sci-biology/emboss/emboss-4.0.0.ebuild
new file mode 100644
index 000000000000..fc86b785eff1
--- /dev/null
+++ b/sci-biology/emboss/emboss-4.0.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-4.0.0.ebuild,v 1.1 2006/07/21 14:45:20 ribosome Exp $
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+HOMEPAGE="http://emboss.sourceforge.net/"
+SRC_URI="ftp://${PN}.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+LICENSE="GPL-2 LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc-macos ~ppc64 ~x86"
+IUSE="X png minimal"
+
+DEPEND="X? ( || ( x11-libs/libXt virtual/x11 ) )
+ png? (
+ sys-libs/zlib
+ media-libs/libpng
+ >=media-libs/gd-1.8
+ )
+ !minimal? (
+ sci-biology/primer3
+ sci-biology/clustalw
+ )
+ !<dev-util/pscan-20000721-r1"
+
+PDEPEND="!minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ >=sci-biology/prosite-19.7
+ >=sci-biology/rebase-601-r1
+ sci-biology/transfac
+ )"
+
+S="${WORKDIR}/EMBOSS-${PV}"
+
+src_compile() {
+ EXTRA_CONF="--includedir=${D}/usr/include/emboss"
+ ! use X && EXTRA_CONF="${EXTRA_CONF} --without-x"
+ ! use png && EXTRA_CONF="${EXTRA_CONF} --without-pngdriver"
+
+ econf ${EXTRA_CONF} || die
+ # Do not install the JEMBOSS component (the --without-java configure option
+ # does not work). JEMBOSS will eventually be available as a separate package.
+ sed -i -e 's/SUBDIRS = plplot ajax nucleus emboss test doc jemboss/SUBDIRS = plplot ajax nucleus emboss test doc/' \
+ Makefile || die
+ emake || die
+}
+
+src_install() {
+ einstall || die "Failed to install program files."
+
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS "${FILESDIR}"/README.Gentoo \
+ || die "Failed to install documentation."
+
+ # Install env file for setting libplplot and acd files path.
+ insinto /etc/env.d
+ newins ${FILESDIR}/22emboss-r1 22emboss || \
+ die "Failed to install environment file."
+
+ # Symlink preinstalled docs to /usr/share/doc.
+ dosym /usr/share/EMBOSS/doc/manuals /usr/share/doc/${PF}/manuals || die
+ dosym /usr/share/EMBOSS/doc/programs /usr/share/doc/${PF}/programs || die
+ dosym /usr/share/EMBOSS/doc/tutorials /usr/share/doc/${PF}/tutorials || die
+ dosym /usr/share/EMBOSS/doc/html /usr/share/doc/${PF}/html || die
+
+ # Remove useless dummy files from the image.
+ rm "${D}"/usr/share/EMBOSS/data/{AAINDEX,PRINTS,PROSITE,REBASE}/dummyfile \
+ || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.Gentoo".
+ mv "${D}"/usr/share/EMBOSS/data/CODONS \
+ "${D}"/usr/share/EMBOSS/data/CODONS.orig || \
+ die "Failed to move CODON directory."
+
+ # Move the provided restriction enzyme prototypes file to a different name.
+ # This will avoid file collisions with future versions of rebase that will
+ # install their own enzyme prototypes file (see bug #118832).
+ mv "${D}"/usr/share/EMBOSS/data/embossre.equ \
+ "${D}"/usr/share/EMBOSS/data/embossre.equ.orig || \
+ die "Failed to move enzyme equivalence file."
+}
diff --git a/sci-biology/emboss/files/digest-emboss-4.0.0 b/sci-biology/emboss/files/digest-emboss-4.0.0
new file mode 100644
index 000000000000..ffad1f9b9096
--- /dev/null
+++ b/sci-biology/emboss/files/digest-emboss-4.0.0
@@ -0,0 +1,3 @@
+MD5 2ef912cfde4903129f2424d23d6da0d2 EMBOSS-4.0.0.tar.gz 17651607
+RMD160 5b29ac2946a1315928581bf0e40a0f6b5023c599 EMBOSS-4.0.0.tar.gz 17651607
+SHA256 bbfd127adc064a5211542f3b5400cbb13c7f74d9171fd16b8531cee9fd11b231 EMBOSS-4.0.0.tar.gz 17651607