summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-28 17:03:16 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-28 17:03:16 +0000
commita89cf77bdab31c23d9d2f71f08a3598d0953e0de (patch)
treeb360f9dda2e2ced3db04a267256b9dc0a276ca52 /sci-biology/emboss
parentDrop obsolete eclass and add new version, thanks Ted Tanberry for the work (diff)
downloadgentoo-2-a89cf77bdab31c23d9d2f71f08a3598d0953e0de.tar.gz
gentoo-2-a89cf77bdab31c23d9d2f71f08a3598d0953e0de.tar.bz2
gentoo-2-a89cf77bdab31c23d9d2f71f08a3598d0953e0de.zip
Import latest changes from science overlay, thanks Ted Tanberry for the work; fixes #504680
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/emboss')
-rw-r--r--sci-biology/emboss/ChangeLog14
-rw-r--r--sci-biology/emboss/emboss-6.6.0.ebuild59
-rw-r--r--sci-biology/emboss/files/README.gentoo34
-rw-r--r--sci-biology/emboss/files/emboss-6.6.0_FORTIFY_SOURCE-fix.patch11
-rw-r--r--sci-biology/emboss/files/emboss-6.6.0_fix-build-system.patch368
-rw-r--r--sci-biology/emboss/files/emboss-6.6.0_plplot-declarations.patch61
-rw-r--r--sci-biology/emboss/files/emboss-6.6.0_qa-implicit-declarations.patch74
-rw-r--r--sci-biology/emboss/metadata.xml4
8 files changed, 621 insertions, 4 deletions
diff --git a/sci-biology/emboss/ChangeLog b/sci-biology/emboss/ChangeLog
index 7608647f1e7d..10c9731636aa 100644
--- a/sci-biology/emboss/ChangeLog
+++ b/sci-biology/emboss/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-biology/emboss
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.71 2014/12/28 16:46:09 titanofold Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/ChangeLog,v 1.72 2015/03/28 17:03:16 jlec Exp $
+
+*emboss-6.6.0 (28 Mar 2015)
+
+ 28 Mar 2015; Justin Lecher <jlec@gentoo.org> +emboss-6.6.0.ebuild,
+ +files/README.gentoo, +files/emboss-6.6.0_FORTIFY_SOURCE-fix.patch,
+ +files/emboss-6.6.0_fix-build-system.patch,
+ +files/emboss-6.6.0_plplot-declarations.patch,
+ +files/emboss-6.6.0_qa-implicit-declarations.patch, metadata.xml:
+ Import latest changes from science overlay, thanks Ted Tanberry for the work;
+ fixes #504680
28 Dec 2014; Aaron W. Swenson <titanofold@gentoo.org> emboss-6.3.1_p4.ebuild,
emboss-6.3.1_p4-r1.ebuild:
diff --git a/sci-biology/emboss/emboss-6.6.0.ebuild b/sci-biology/emboss/emboss-6.6.0.ebuild
new file mode 100644
index 000000000000..5343130d128e
--- /dev/null
+++ b/sci-biology/emboss/emboss-6.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/emboss/emboss-6.6.0.ebuild,v 1.1 2015/03/28 17:03:16 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-utils emboss-r1 eutils readme.gentoo
+
+DESCRIPTION="The European Molecular Biology Open Software Suite - A sequence analysis package"
+SRC_URI="ftp://emboss.open-bio.org/pub/EMBOSS/EMBOSS-${PV}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE+=" minimal"
+
+RDEPEND+=" !sys-devel/cons"
+PDEPEND+="
+ !minimal? (
+ sci-biology/aaindex
+ sci-biology/cutg
+ sci-biology/prints
+ sci-biology/prosite
+ sci-biology/rebase
+ )"
+
+S="${WORKDIR}"/EMBOSS-${PV}
+
+DOCS=( ChangeLog AUTHORS NEWS THANKS FAQ )
+
+PATCHES=(
+ "${FILESDIR}"/${P}_fix-build-system.patch
+ "${FILESDIR}"/${P}_FORTIFY_SOURCE-fix.patch
+ "${FILESDIR}"/${P}_plplot-declarations.patch
+ "${FILESDIR}"/${P}_qa-implicit-declarations.patch
+)
+
+src_install() {
+ # Use autotools-utils_* to remove useless *.la files
+ autotools-utils_src_install
+
+ readme.gentoo_create_doc
+
+ # Install env file for setting libplplot and acd files path.
+ cat > 22emboss <<- EOF
+ # ACD files location
+ EMBOSS_ACDROOT="${EPREFIX}/usr/share/EMBOSS/acd"
+ EMBOSS_DATA="${EPREFIX}/usr/share/EMBOSS/data"
+ EOF
+ doenvd 22emboss
+
+ # Remove useless dummy files
+ find "${ED}"/usr/share/EMBOSS -name dummyfile -delete || die "Failed to remove dummy files."
+
+ # Move the provided codon files to a different directory. This will avoid
+ # user confusion and file collisions on case-insensitive file systems (see
+ # bug #115446). This change is documented in "README.gentoo".
+ mv "${ED}"/usr/share/EMBOSS/data/CODONS{,.orig} || \
+ die "Failed to move CODON directory."
+}
diff --git a/sci-biology/emboss/files/README.gentoo b/sci-biology/emboss/files/README.gentoo
new file mode 100644
index 000000000000..d1879bd0811c
--- /dev/null
+++ b/sci-biology/emboss/files/README.gentoo
@@ -0,0 +1,34 @@
+Administrating EMBOSS on Gentoo systems
+=======================================
+
+
+Codon data files location
+-------------------------
+
+The codon data files that are distributed with EMBOSS are installed in the
+``EPREFIX/usr/share/EMBOSS/data/CODONS.orig`` directory instead of the usual
+``EPREFIX/usr/share/EMBOSS/data/CODONS``. This is done to avoid confusion between
+these codon files and those installed with the CUTG database. The names of
+these files sometimes vary only by their case. Having both sets of files in
+the same directory is also impossible on systems such as MacOSX, where the
+root filesystem is case insensitive. If you do not have the CUTG database
+installed and want to use the codon files distributed with EMBOSS, you can
+symlink the ``CODONS.orig`` directory to ``CODONS``::
+
+ # cd ${EPREFIX}/usr/share/EMBOSS/data
+ # ln -s CODONS.orig CODONS
+
+
+Restriction enzymes equivalence file location
+---------------------------------------------
+
+The restriction enzymes equivalence file distributed with EMBOSS is installed
+as ``EPREFIX/usr/share/EMBOSS/data/embossre.equ.orig`` rather than the usual
+``EPREFIX/usr/share/EMBOSS/data/embossre.equ``. This is done to avoid a file
+collision with the equivalence file provided by the Rebase database. If you do
+not have the Rebase database installed and want to use the equivalence file
+distributed with EMBOSS, you can symlink the ``embossre.equ.orig`` file to
+``embossre.equ``::
+
+ # cd ${EPREFIX}/usr/share/EMBOSS/data
+ # ln -s embossre.equ.orig embossre.equ
diff --git a/sci-biology/emboss/files/emboss-6.6.0_FORTIFY_SOURCE-fix.patch b/sci-biology/emboss/files/emboss-6.6.0_FORTIFY_SOURCE-fix.patch
new file mode 100644
index 000000000000..7704873e9d26
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.6.0_FORTIFY_SOURCE-fix.patch
@@ -0,0 +1,11 @@
+--- EMBOSS-6.6.0/emboss/embossversion.c
++++ EMBOSS-6.6.0/emboss/embossversion.c
+@@ -415,7 +415,7 @@
+ ajFmtPrintF(outfile, "X_DISPLAY_MISSING %d\n", X_DISPLAY_MISSING);
+ #endif
+ #ifdef _FORTIFY_SOURCE
+- ajFmtPrintF(outfile, "_FORTIFY_SOURCE %d\n", _FORTIFY_SOURCE);
++ ajFmtPrintF(outfile, "_FORTIFY_SOURCE %d\n", __USE_FORTIFY_LEVEL);
+ #endif
+ ajFmtPrintF(outfile, "\n");
+ ajFmtPrintF(outfile, "Sizes (bytes):\n");
diff --git a/sci-biology/emboss/files/emboss-6.6.0_fix-build-system.patch b/sci-biology/emboss/files/emboss-6.6.0_fix-build-system.patch
new file mode 100644
index 000000000000..c831c3ba7e28
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.6.0_fix-build-system.patch
@@ -0,0 +1,368 @@
+--- EMBOSS-6.6.0/ajax/acd/Makefile.am
++++ EMBOSS-6.6.0/ajax/acd/Makefile.am
+@@ -3,16 +3,20 @@
+ lib_LTLIBRARIES = libacd.la
+
+ libacd_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libacd_la_LIBADD = ../core/libajax.la ../graphics/libajaxg.la
+
+ libacd_la_CPPFLAGS = -I$(top_srcdir)/ajax/ajaxdb
++libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/core
+ libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/ensembl
+ libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/graphics
+-libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ if !ESYSTEMLIBS
++libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ libacd_la_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
+-endif
+ libacd_la_CPPFLAGS += -I$(top_srcdir)/plplot
++else
++libacd_la_CFLAGS += $(PLPLOT_CFLAGS)
++endif
+ libacd_la_CPPFLAGS += $(JAVA_CPPFLAGS)
+
+ libacd_la_LDFLAGS = -version-info 6:5:0
+--- EMBOSS-6.6.0/ajax/ajaxdb/Makefile.am
++++ EMBOSS-6.6.0/ajax/ajaxdb/Makefile.am
+@@ -3,14 +3,16 @@
+ lib_LTLIBRARIES = libajaxdb.la
+
+ libajaxdb_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libajaxdb_la_LIBADD = ../core/libajax.la ../ensembl/libensembl.la
+
+ libajaxdb_la_CPPFLAGS = -I$(top_srcdir)/ajax/ensembl
+-libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
++libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/ajax/core
+ if !ESYSTEMLIBS
++libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
+-endif
+ libajaxdb_la_CPPFLAGS += -I$(top_srcdir)/plplot
++endif
+ libajaxdb_la_CPPFLAGS += $(AXIS2C_CPPFLAGS)
+ libajaxdb_la_CPPFLAGS += $(JAVA_CPPFLAGS)
+
+--- EMBOSS-6.6.0/ajax/core/ajreg.h
++++ EMBOSS-6.6.0/ajax/core/ajreg.h
+@@ -39,9 +39,8 @@
+ #include "ajdefine.h"
+ #include "ajstr.h"
+
+-#include "pcre_config.h"
+-#include "pcre_internal.h"
+-#include "pcreposix.h"
++#include <pcre.h>
++#include <pcreposix.h>
+
+ AJ_BEGIN_DECLS
+
+@@ -84,7 +83,7 @@
+
+ typedef struct AjSRegexp
+ {
+- real_pcre *pcre;
++ struct real_pcre *pcre;
+ pcre_extra *extra;
+ int *ovector;
+ const char* orig;
+--- EMBOSS-6.6.0/ajax/core/Makefile.am
++++ EMBOSS-6.6.0/ajax/core/Makefile.am
+@@ -3,13 +3,15 @@
+ lib_LTLIBRARIES = libajax.la
+
+ libajax_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libajax_la_LIBADD = $(EXPAT_LIBS) $(PCRE_LIBS) $(ZLIB_LIBS)
+
+-libajax_la_CPPFLAGS = -I$(top_srcdir)/ajax/pcre
++libajax_la_CPPFLAGS =
+ if !ESYSTEMLIBS
++libajax_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libajax_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ libajax_la_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
+-endif
+ libajax_la_CPPFLAGS += -I$(top_srcdir)/plplot
++endif
+ libajax_la_CPPFLAGS += $(JAVA_CPPFLAGS)
+ libajax_la_CPPFLAGS += $(MYSQL_CPPFLAGS)
+ libajax_la_CPPFLAGS += $(POSTGRESQL_CPPFLAGS)
+--- EMBOSS-6.6.0/ajax/ensembl/Makefile.am
++++ EMBOSS-6.6.0/ajax/ensembl/Makefile.am
+@@ -3,13 +3,15 @@
+ lib_LTLIBRARIES = libensembl.la
+
+ libensembl_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libensembl_la_LIBADD = ../core/libajax.la
+
+-libensembl_la_CPPFLAGS = -I$(top_srcdir)/ajax/pcre
++libensembl_la_CPPFLAGS = -I$(top_srcdir)/ajax/core
+ if !ESYSTEMLIBS
++libensembl_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libensembl_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ libensembl_la_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
+-endif
+ libensembl_la_CPPFLAGS += -I$(top_srcdir)/plplot
++endif
+ libensembl_la_CPPFLAGS += $(JAVA_CPPFLAGS)
+
+ libensembl_la_LDFLAGS = -version-info 6:5:0
+--- EMBOSS-6.6.0/ajax/graphics/Makefile.am
++++ EMBOSS-6.6.0/ajax/graphics/Makefile.am
+@@ -3,12 +3,16 @@
+ lib_LTLIBRARIES = libajaxg.la
+
+ libajaxg_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libajaxg_la_LIBADD = ../core/libajax.la $(PLPLOT_LIBS)
+
+-libajaxg_la_CPPFLAGS = -I$(top_srcdir)/ajax/pcre
++libajaxg_la_CPPFLAGS = -I$(top_srcdir)/ajax/core
+ if !ESYSTEMLIBS
++libajaxg_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libajaxg_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+-endif
+ libajaxg_la_CPPFLAGS += -I$(top_srcdir)/plplot
++else
++libajaxg_la_CFLAGS += $(PLPLOT_CFLAGS)
++endif
+ libajaxg_la_CPPFLAGS += $(JAVA_CPPFLAGS)
+
+ libajaxg_la_LDFLAGS = -version-info 6:5:0
+--- EMBOSS-6.6.0/ajax/Makefile.am
++++ EMBOSS-6.6.0/ajax/Makefile.am
+@@ -1,7 +1,7 @@
+ ## Process this file with automake to produce Makefile.in
+
+-SUBDIRS = pcre
++SUBDIRS =
+ if !ESYSTEMLIBS
+-SUBDIRS += expat zlib
++SUBDIRS += pcre expat zlib
+ endif
+ SUBDIRS += core graphics ensembl ajaxdb acd
+--- EMBOSS-6.6.0/configure.ac
++++ EMBOSS-6.6.0/configure.ac
+@@ -629,32 +629,6 @@
+
+
+
+-
+-dnl PCRE library definitions - see the MAJOR and MINOR values
+-dnl to see which version's configure.in these lines come from
+-
+-dnl Provide the current PCRE version information. Do not use numbers
+-dnl with leading zeros for the minor version, as they end up in a C
+-dnl macro, and may be treated as octal constants. Stick to single
+-dnl digits for minor numbers less than 10. There are unlikely to be
+-dnl that many releases anyway.
+-
+-PCRE_MAJOR="7"
+-PCRE_MINOR="9"
+-PCRE_DATE="11-Apr-2009"
+-PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
+-
+-dnl Default values for miscellaneous macros
+-
+-POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
+-
+-dnl Provide versioning information for libtool shared libraries that
+-dnl are built by default on Unix systems.
+-
+-PCRE_LIB_VERSION="0:1:0"
+-PCRE_POSIXLIB_VERSION="0:0:0"
+-
+-
+ dnl Define where the EMBOSS package is located
+ AC_SUBST([AJAX_FIXED_ROOT])
+ AJAX_FIXED_ROOT="\\\"`pwd`/emboss\\\""
+@@ -743,17 +717,7 @@
+
+
+
+-dnl "Export" these variables for PCRE
+
+-AC_SUBST([HAVE_MEMMOVE])
+-AC_SUBST([HAVE_STRERROR])
+-AC_SUBST([PCRE_MAJOR])
+-AC_SUBST([PCRE_MINOR])
+-AC_SUBST([PCRE_DATE])
+-AC_SUBST([PCRE_VERSION])
+-AC_SUBST([PCRE_LIB_VERSION])
+-AC_SUBST([PCRE_POSIXLIB_VERSION])
+-AC_SUBST([POSIX_MALLOC_THRESHOLD])
+
+
+
+@@ -849,7 +813,51 @@
+
+ AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+
+-
++AS_IF([test "x${enable_systemlibs}" = "xyes"],
++[
++dnl using system libraries
++ PKG_CHECK_MODULES([PCRE], [libpcre])
++ PKG_CHECK_MODULES([EXPAT], [expat])
++ PKG_CHECK_MODULES([ZLIB], [zlib])
++ PKG_CHECK_MODULES([PLPLOT], [plplotd])
++],
++[
++dnl using bundled libraries
++ dnl PCRE library definitions - see the MAJOR and MINOR values
++ dnl to see which version's configure.ac these lines come from
++
++ dnl Provide the current PCRE version information. Do not use numbers
++ dnl with leading zeros for the minor version, as they end up in a C
++ dnl macro, and may be treated as octal constants. Stick to single
++ dnl digits for minor numbers less than 10. There are unlikely to be
++ dnl that many releases anyway.
++
++ PCRE_MAJOR="7"
++ PCRE_MINOR="9"
++ PCRE_DATE="11-Apr-2009"
++ PCRE_VERSION="${PCRE_MAJOR}.${PCRE_MINOR}"
++
++ dnl Default values for miscellaneous macros
++
++ POSIX_MALLOC_THRESHOLD="-DPOSIX_MALLOC_THRESHOLD=10"
++
++ dnl Provide versioning information for libtool shared libraries that
++ dnl are built by default on Unix systems.
++
++ PCRE_LIB_VERSION="0:1:0"
++ PCRE_POSIXLIB_VERSION="0:0:0"
++
++ dnl "Export" these variables for PCRE
++ AC_SUBST([HAVE_MEMMOVE])
++ AC_SUBST([HAVE_STRERROR])
++ AC_SUBST([PCRE_MAJOR])
++ AC_SUBST([PCRE_MINOR])
++ AC_SUBST([PCRE_DATE])
++ AC_SUBST([PCRE_VERSION])
++ AC_SUBST([PCRE_LIB_VERSION])
++ AC_SUBST([PCRE_POSIXLIB_VERSION])
++ AC_SUBST([POSIX_MALLOC_THRESHOLD])
++])
+
+
+ # Enable the purify tool: --enable-purify, sets CC and LIBTOOL
+--- EMBOSS-6.6.0/emboss/Makefile.am
++++ EMBOSS-6.6.0/emboss/Makefile.am
+@@ -28,15 +28,18 @@
+
+ AM_CPPFLAGS = -I$(top_srcdir)/ajax/acd
+ AM_CPPFLAGS += -I$(top_srcdir)/ajax/ajaxdb
++AM_CPPFLAGS += -I$(top_srcdir)/ajax/core
+ AM_CPPFLAGS += -I$(top_srcdir)/ajax/ensembl
+ AM_CPPFLAGS += -I$(top_srcdir)/ajax/graphics
+-AM_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ if !ESYSTEMLIBS
++AM_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ AM_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ AM_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
++AM_CPPFLAGS += -I$(top_srcdir)/plplot
++else
++AM_CFLAGS += $(PLPLOT_CFLAGS)
+ endif
+ AM_CPPFLAGS += -I$(top_srcdir)/nucleus
+-AM_CPPFLAGS += -I$(top_srcdir)/plplot
+ AM_CPPFLAGS += $(AXIS2C_CPPFLAGS)
+ AM_CPPFLAGS += $(JAVA_CPPFLAGS)
+
+@@ -49,9 +52,11 @@
+ if !ESYSTEMLIBS
+ LDADD += ../ajax/zlib/libezlib.la
+ LDADD += ../ajax/expat/libeexpat.la
+-endif
+ LDADD += ../ajax/pcre/libepcre.la
+ LDADD += ../plplot/libeplplot.la
++else
++LDADD += $(EXPAT_LIBS) $(PCRE_LIBS) $(ZLIB_LIBS) $(PLPLOT_LIBS)
++endif
+ LDADD += $(XLIB)
+
+ #if PURIFY
+--- EMBOSS-6.6.0/jemboss/lib/Makefile.am
++++ EMBOSS-6.6.0/jemboss/lib/Makefile.am
+@@ -12,7 +12,7 @@
+ jalviewApplet.jar \
+ jemboss.jar
+
+-jemboss.jar:../org/emboss/jemboss/server/JembossFile*Server.java
++jemboss.jar:$(srcdir)/../org/emboss/jemboss/server/JembossFile*Server.java
+ if JAVA_BUILD
+ $(ANT) -f ../build.xml package -Demboss.data=../emboss/data -Dname=jemboss -Djar.dir=lib -Dnotformemboss=yes;
+ endif
+--- EMBOSS-6.6.0/m4/idxdbs.m4
++++ EMBOSS-6.6.0/m4/idxdbs.m4
+@@ -1,17 +1,8 @@
+ AC_DEFUN([CHECK_IDXDBS],
+ [
+-AC_MSG_CHECKING(for EMBOSS pre-indexed databases)
++AC_MSG_NOTICE(checking for EMBOSS pre-indexed databases)
+
+-
+-if test -f ./emboss/index/edam.xac; then
+-AC_MSG_RESULT(yes)
+-else
+-AC_MSG_RESULT(no)
+-echo ""
+-echo "Pre-indexed edam, taxon + drcat databases not found."
+-echo "Please download them from within this directory using:"
+-echo " rsync -av rsync://emboss.open-bio.org/EMBOSS/ ."
+-echo "and then repeat the configure step."
+-exit 1
+-fi
++AC_CHECK_FILE([$srcdir/emboss/index/edam.xac],
++ [],
++ [AC_MSG_ERROR([cannot find pre-indexed edam, taxon + drcat databases])])
+ ])
+--- EMBOSS-6.6.0/Makefile.am
++++ EMBOSS-6.6.0/Makefile.am
+@@ -12,8 +12,11 @@
+ ONEWS \
+ PROBLEMS
+
+-SUBDIRS = \
+-plplot \
++SUBDIRS =
++if !ESYSTEMLIBS
++SUBDIRS += plplot
++endif
++SUBDIRS += \
+ ajax \
+ nucleus \
+ emboss \
+@@ -33,5 +36,3 @@
+ tar cBf - doc | ( cd $(distdir); tar xBf - ; find doc -name CVS | xargs rm -rf; )
+ tar cBf - jemboss | ( cd $(distdir); tar xBf - ; find jemboss -name CVS | xargs rm -rf; find jemboss -name Makefile | xargs rm -rf; find jemboss -name .cvsignore | xargs rm -rf )
+
+-install-exec-hook:
+- $(bindir)/embossupdate
+--- EMBOSS-6.6.0/nucleus/Makefile.am
++++ EMBOSS-6.6.0/nucleus/Makefile.am
+@@ -3,6 +3,7 @@
+ lib_LTLIBRARIES = libnucleus.la
+
+ libnucleus_la_CFLAGS = $(WARN_CFLAGS) $(DEVWARN_CFLAGS) $(JAVA_CFLAGS)
++libnucleus_la_LIBADD = ../ajax/core/libajax.la ../ajax/ajaxdb/libajaxdb.la ../ajax/acd/libacd.la
+
+ if ISSHARED
+ if ISAIXIA64
+@@ -10,11 +11,14 @@
+ endif
+ endif
+
+-libnucleus_la_CPPFLAGS = -I$(top_srcdir)/plplot
+-libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
++libnucleus_la_CPPFLAGS = -I$(top_srcdir)/ajax/core
+ if !ESYSTEMLIBS
++libnucleus_la_CPPFLAGS += -I$(top_srcdir)/plplot
++libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/pcre
+ libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/expat
+ libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/zlib
++else
++libnucleus_la_CFLAGS += $(PLPLOT_CFLAGS)
+ endif
+ libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/graphics
+ libnucleus_la_CPPFLAGS += -I$(top_srcdir)/ajax/ensembl
diff --git a/sci-biology/emboss/files/emboss-6.6.0_plplot-declarations.patch b/sci-biology/emboss/files/emboss-6.6.0_plplot-declarations.patch
new file mode 100644
index 000000000000..15f5f967a07d
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.6.0_plplot-declarations.patch
@@ -0,0 +1,61 @@
+--- EMBOSS-6.6.0/ajax/graphics/ajgraph.c
++++ EMBOSS-6.6.0/ajax/graphics/ajgraph.c
+@@ -49,7 +49,7 @@
+
+ #define GRAPH_DEBUG 1
+
+-#include "plplotP.h"
++#include <plplotP.h>
+
+
+ static void GraphArray(ajuint numofpoints,
+@@ -964,10 +964,10 @@
+ if(!thys->ready)
+ {
+ #if GRAPH_DEBUG
+- ajDebug("=g= plxsfnam ('%S', '%s')\n", txt, ext);
++ ajDebug("=g= plsfnam ('%S')\n", txt);
+ #endif
+
+- plxsfnam(ajStrGetPtr(txt), ext);
++ plsfnam(ajStrGetPtr(txt));
+ ajStrAssignS(&graphBasename, txt);
+ ajStrAssignC(&graphExtension, ext);
+ if(ajStrGetCharFirst(graphExtension) == '.')
+@@ -1213,10 +1213,10 @@
+ void ajGraphicsSetPenwidth(float penwidth)
+ {
+ #if GRAPH_DEBUG
+- ajDebug("=g= plwid(%.2f) [width]\n", penwidth);
++ ajDebug("=g= c_plwidth(%.2f) [width]\n", penwidth);
+ #endif
+
+- plwid((PLINT)penwidth);
++ c_plwidth((PLINT)penwidth);
+
+ return;
+ }
+@@ -1538,10 +1538,10 @@
+ static void GraphSetPen(ajint colour)
+ {
+ #if GRAPH_DEBUG
+- ajDebug("=g= plcol(%d '%s') [colour]\n", colour, graphColourName[colour]);
++ ajDebug("=g= plcol0(%d '%s') [colour]\n", colour, graphColourName[colour]);
+ #endif
+
+- plcol((PLINT)colour);
++ plcol0((PLINT)colour);
+
+ return;
+ }
+--- EMBOSS-6.6.0/ajax/graphics/ajgraph.h
++++ EMBOSS-6.6.0/ajax/graphics/ajgraph.h
+@@ -32,7 +32,7 @@
+ /* ========================================================================= */
+
+ #include "ajdefine.h"
+-#include "plplot.h"
++#include <plplot.h>
+ #include "ajgraphstruct.h"
+ #include "ajdefine.h"
+ #include "ajstr.h"
diff --git a/sci-biology/emboss/files/emboss-6.6.0_qa-implicit-declarations.patch b/sci-biology/emboss/files/emboss-6.6.0_qa-implicit-declarations.patch
new file mode 100644
index 000000000000..eff10b2e6700
--- /dev/null
+++ b/sci-biology/emboss/files/emboss-6.6.0_qa-implicit-declarations.patch
@@ -0,0 +1,74 @@
+--- EMBOSS-6.6.0/ajax/core/ajfeatread.c
++++ EMBOSS-6.6.0/ajax/core/ajfeatread.c
+@@ -45,6 +45,7 @@
+
+ #include <limits.h>
+ #include <math.h>
++#include <string.h>
+ #include <errno.h>
+
+ #ifdef WIN32
+--- EMBOSS-6.6.0/ajax/core/ajfeatwrite.c
++++ EMBOSS-6.6.0/ajax/core/ajfeatwrite.c
+@@ -43,7 +43,7 @@
+
+ #include <limits.h>
+ #include <math.h>
+-
++#include <string.h>
+
+ static AjPRegexp featoutRegUfoFmt = NULL;
+ static AjPRegexp featoutRegUfoFile = NULL;
+--- EMBOSS-6.6.0/ajax/core/ajpdbio.c
++++ EMBOSS-6.6.0/ajax/core/ajpdbio.c
+@@ -37,7 +37,7 @@
+
+ #include <limits.h>
+ #include <math.h>
+-
++#include <string.h>
+
+
+
+--- EMBOSS-6.6.0/ajax/core/ajreg.c
++++ EMBOSS-6.6.0/ajax/core/ajreg.c
+@@ -32,6 +32,7 @@
+ #include "ajlib.h"
+
+ #include "ajreg.h"
++#include <string.h>
+
+
+
+--- EMBOSS-6.6.0/ajax/core/ajseqtype.c
++++ EMBOSS-6.6.0/ajax/core/ajseqtype.c
+@@ -32,7 +32,7 @@
+ #include "ajfeat.h"
+ #include "ajfile.h"
+ #include "ajreg.h"
+-
++#include <string.h>
+
+
+
+--- EMBOSS-6.6.0/nucleus/embindex.c
++++ EMBOSS-6.6.0/nucleus/embindex.c
+@@ -35,6 +35,7 @@
+ #include "ajnam.h"
+
+ #include <errno.h>
++#include <string.h>
+
+ #define BTENTRYFILE ".ent"
+ #define KWLIMIT 12
+--- EMBOSS-6.6.0/nucleus/embword.c
++++ EMBOSS-6.6.0/nucleus/embword.c
+@@ -36,7 +36,7 @@
+ #include "ajutil.h"
+
+ #include <math.h>
+-
++#include <string.h>
+
+
+
diff --git a/sci-biology/emboss/metadata.xml b/sci-biology/emboss/metadata.xml
index b85761d07029..3af936dc1564 100644
--- a/sci-biology/emboss/metadata.xml
+++ b/sci-biology/emboss/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci-biology</herd>
- <longdescription>
+ <herd>sci-biology</herd>
+ <longdescription>
EMBOSS is "The European Molecular Biology Open Software Suite".
EMBOSS is a free Open Source software analysis package specially
developed for the needs of the molecular biology (e.g. EMBnet) user