summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-11-23 08:23:08 +0000
committerJustin Lecher <jlec@gentoo.org>2011-11-23 08:23:08 +0000
commitc2588f12fe34b3f039227481117244f29867a235 (patch)
tree073f36ab569d797978a72c872f1daa138a539f37 /sci-biology/last
parentDropped old, respect LDFLAGS, don't mix CFLAGS and CXXFLAGS, move KEYWORDS an... (diff)
downloadgentoo-2-c2588f12fe34b3f039227481117244f29867a235.tar.gz
gentoo-2-c2588f12fe34b3f039227481117244f29867a235.tar.bz2
gentoo-2-c2588f12fe34b3f039227481117244f29867a235.zip
Dropped old, respect LDFLAGS
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/last')
-rw-r--r--sci-biology/last/ChangeLog6
-rw-r--r--sci-biology/last/last-162.ebuild35
-rw-r--r--sci-biology/last/last-184.ebuild18
3 files changed, 17 insertions, 42 deletions
diff --git a/sci-biology/last/ChangeLog b/sci-biology/last/ChangeLog
index 25be0283f21f..d6c2d1a5844e 100644
--- a/sci-biology/last/ChangeLog
+++ b/sci-biology/last/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/last
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.15 2011/09/25 22:45:35 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/ChangeLog,v 1.16 2011/11/23 08:23:08 jlec Exp $
+
+ 23 Nov 2011; Justin Lecher <jlec@gentoo.org> -last-162.ebuild,
+ last-184.ebuild:
+ Dropped old, respect LDFLAGS
*last-184 (25 Sep 2011)
diff --git a/sci-biology/last/last-162.ebuild b/sci-biology/last/last-162.ebuild
deleted file mode 100644
index 092a985fb3ac..000000000000
--- a/sci-biology/last/last-162.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-162.ebuild,v 1.2 2011/04/25 11:00:59 jlec Exp $
-
-EAPI="2"
-
-inherit toolchain-funcs
-
-DESCRIPTION="Genome-scale comparison of biological sequences"
-HOMEPAGE="http://last.cbrc.jp/"
-SRC_URI="http://last.cbrc.jp/archive/${P}.zip"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE=""
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PV}-gcc46.patch
-}
-src_compile() {
- emake -e -C src CXX="$(tc-getCXX)" \
- STRICT="${LDFLAGS}" || die
-}
-
-src_install() {
- dobin src/last{al,db} || die
- exeinto /usr/share/${PN}/scripts
- doexe scripts/* || die
- dodoc doc/*.txt ChangeLog.txt README.txt || die
-}
diff --git a/sci-biology/last/last-184.ebuild b/sci-biology/last/last-184.ebuild
index ca42a0e6d0a5..c2258dbd69f0 100644
--- a/sci-biology/last/last-184.ebuild
+++ b/sci-biology/last/last-184.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-184.ebuild,v 1.1 2011/09/25 22:45:35 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/last/last-184.ebuild,v 1.2 2011/11/23 08:23:08 jlec Exp $
-EAPI="2"
+EAPI=4
inherit eutils toolchain-funcs
@@ -18,14 +18,20 @@ KEYWORDS="~amd64 ~x86"
DEPEND="app-arch/unzip"
RDEPEND=""
+src_prepare() {
+ sed \
+ -e 's:-o $@:$(LDFLAGS) -o $@:g' \
+ -i src/makefile || die
+}
+
src_compile() {
emake -e -C src CXX="$(tc-getCXX)" \
- STRICT="${LDFLAGS}" || die
+ STRICT="" || die
}
src_install() {
- dobin src/last{al,db,ex} || die
+ dobin src/last{al,db,ex}
exeinto /usr/share/${PN}/scripts
- doexe scripts/* || die
- dodoc doc/*.txt ChangeLog.txt README.txt || die
+ doexe scripts/*
+ dodoc doc/*.txt ChangeLog.txt README.txt
}