summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-03-09 15:48:51 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-03-09 15:48:51 +0000
commit9f139d0ffd609027c3a5ce6177aad411687acbfe (patch)
tree7cebd29d8e3ab1a5db560c2880f738587a473804 /sci-biology/mummer
parentFixes symlink attack (#250554), sets CC (#243660), CFLAGS (#240078) and insta... (diff)
downloadgentoo-2-9f139d0ffd609027c3a5ce6177aad411687acbfe.tar.gz
gentoo-2-9f139d0ffd609027c3a5ce6177aad411687acbfe.tar.bz2
gentoo-2-9f139d0ffd609027c3a5ce6177aad411687acbfe.zip
QA fixes
(Portage version: 2.2_rc20/cvs/Linux 2.6.26-gentoo-r4 x86_64)
Diffstat (limited to 'sci-biology/mummer')
-rw-r--r--sci-biology/mummer/ChangeLog6
-rw-r--r--sci-biology/mummer/mummer-3.20.ebuild5
-rw-r--r--sci-biology/mummer/mummer-3.21.ebuild9
3 files changed, 17 insertions, 3 deletions
diff --git a/sci-biology/mummer/ChangeLog b/sci-biology/mummer/ChangeLog
index 25d6a6eaf080..842dc09641d4 100644
--- a/sci-biology/mummer/ChangeLog
+++ b/sci-biology/mummer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/mummer
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/ChangeLog,v 1.3 2009/03/09 15:29:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/ChangeLog,v 1.4 2009/03/09 15:48:51 weaver Exp $
+
+ 09 Mar 2009; Andrey Kislyuk <weaver@gentoo.org> mummer-3.20.ebuild,
+ mummer-3.21.ebuild:
+ QA fixes (cflags)
*mummer-3.21 (09 Mar 2009)
diff --git a/sci-biology/mummer/mummer-3.20.ebuild b/sci-biology/mummer/mummer-3.20.ebuild
index 136a810a7bd8..1bc5dd166676 100644
--- a/sci-biology/mummer/mummer-3.20.ebuild
+++ b/sci-biology/mummer/mummer-3.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.20.ebuild,v 1.4 2009/03/09 15:29:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.20.ebuild,v 1.5 2009/03/09 15:48:51 weaver Exp $
inherit eutils
@@ -23,6 +23,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gcc43.patch
+ # Warning: package uses CPPFLAGS on c in addition to cpp, despite the name
+ sed -i -e 's/CPPFLAGS =/CPPFLAGS = ${CFLAGS} /' \
+ -e 's/LDFLAGS =$//' "${S}/Makefile"
}
src_compile() {
diff --git a/sci-biology/mummer/mummer-3.21.ebuild b/sci-biology/mummer/mummer-3.21.ebuild
index 7f0061d50651..dbf16cb8728f 100644
--- a/sci-biology/mummer/mummer-3.21.ebuild
+++ b/sci-biology/mummer/mummer-3.21.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.1 2009/03/09 15:29:37 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/mummer/mummer-3.21.ebuild,v 1.2 2009/03/09 15:48:51 weaver Exp $
inherit eutils
@@ -19,6 +19,13 @@ RDEPEND=""
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ # Warning: package uses CPPFLAGS on c in addition to cpp, despite the name
+ sed -i -e 's/CPPFLAGS =/CPPFLAGS = ${CFLAGS} /' \
+ -e 's/LDFLAGS =$//' "${S}/Makefile"
+}
+
src_compile() {
emake || die "emake failed"