summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-13 11:17:41 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-13 11:17:41 +0000
commitf7b2512d3fcc463ae73c22c0763c14a9f4feb83b (patch)
tree3d470909bb1085bfb8aa1c3c7d2e7066bf51d842 /sci-biology/probcons
parentRemove mplayer useflag as it only adds a dependency (diff)
downloadgentoo-2-f7b2512d3fcc463ae73c22c0763c14a9f4feb83b.tar.gz
gentoo-2-f7b2512d3fcc463ae73c22c0763c14a9f4feb83b.tar.bz2
gentoo-2-f7b2512d3fcc463ae73c22c0763c14a9f4feb83b.zip
Make it gcc46 resistant, #370471
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology/probcons')
-rw-r--r--sci-biology/probcons/ChangeLog8
-rw-r--r--sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch15
-rw-r--r--sci-biology/probcons/probcons-1.12-r1.ebuild12
3 files changed, 28 insertions, 7 deletions
diff --git a/sci-biology/probcons/ChangeLog b/sci-biology/probcons/ChangeLog
index 213e53a0183e..88f28e5ade22 100644
--- a/sci-biology/probcons/ChangeLog
+++ b/sci-biology/probcons/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/probcons
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.13 2010/07/16 22:01:47 hwoarang Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/ChangeLog,v 1.14 2011/06/13 11:17:41 jlec Exp $
+
+ 13 Jun 2011; Justin Lecher <jlec@gentoo.org> probcons-1.12-r1.ebuild,
+ +files/probcons-1.12-gcc-4.6.patch:
+ Make it gcc46 resistant, #370471
16 Jul 2010; Markos Chandras <hwoarang@gentoo.org>
probcons-1.12-r1.ebuild:
diff --git a/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch b/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch
new file mode 100644
index 000000000000..1596f3b31916
--- /dev/null
+++ b/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch
@@ -0,0 +1,15 @@
+ SafeVector.h | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/SafeVector.h b/SafeVector.h
+index abf4b64..9c3292e 100644
+--- a/SafeVector.h
++++ b/SafeVector.h
+@@ -8,6 +8,7 @@
+ #ifndef SAFEVECTOR_H
+ #define SAFEVECTOR_H
+
++#include <cstddef>
+ #include <cassert>
+ #include <vector>
+
diff --git a/sci-biology/probcons/probcons-1.12-r1.ebuild b/sci-biology/probcons/probcons-1.12-r1.ebuild
index 174d25d332cb..6acfffefbe43 100644
--- a/sci-biology/probcons/probcons-1.12-r1.ebuild
+++ b/sci-biology/probcons/probcons-1.12-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12-r1.ebuild,v 1.4 2010/07/16 22:01:47 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/probcons/probcons-1.12-r1.ebuild,v 1.5 2011/06/13 11:17:41 jlec Exp $
-EAPI="3"
+EAPI=3
inherit eutils toolchain-funcs
@@ -26,8 +26,10 @@ DEPEND=""
S="${WORKDIR}/${PN}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-cxxflags.patch
- epatch "${FILESDIR}"/gcc-4.3.patch
+ epatch \
+ "${FILESDIR}"/${P}-cxxflags.patch \
+ "${FILESDIR}"/gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.6.patch
}
src_compile() {