summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-08 16:53:27 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-08 16:53:27 +0000
commit68b3c41dd3d2b2f4d86dcc4a148dce27735bb920 (patch)
tree5e696c29cef768324eacd7ab8bc8a0c233c63010 /sci-biology/rebase
parentVersion bump to 0.77. Fix security bug 545946. (diff)
downloadgentoo-2-68b3c41dd3d2b2f4d86dcc4a148dce27735bb920.tar.gz
gentoo-2-68b3c41dd3d2b2f4d86dcc4a148dce27735bb920.tar.bz2
gentoo-2-68b3c41dd3d2b2f4d86dcc4a148dce27735bb920.zip
Restore -1503 that was just marked stable, bug #545982.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sci-biology/rebase')
-rw-r--r--sci-biology/rebase/ChangeLog7
-rw-r--r--sci-biology/rebase/rebase-1503.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/sci-biology/rebase/ChangeLog b/sci-biology/rebase/ChangeLog
index a57ba1db947e..c9987432d3f4 100644
--- a/sci-biology/rebase/ChangeLog
+++ b/sci-biology/rebase/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/rebase
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.153 2015/04/08 14:19:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/ChangeLog,v 1.154 2015/04/08 16:53:27 mgorny Exp $
+
+*rebase-1503 (08 Apr 2015)
+
+ 08 Apr 2015; Michał Górny <mgorny@gentoo.org> +rebase-1503.ebuild:
+ Restore -1503 that was just marked stable, bug #545982.
08 Apr 2015; Justin Lecher <jlec@gentoo.org> -rebase-1502.ebuild,
-rebase-1503.ebuild:
diff --git a/sci-biology/rebase/rebase-1503.ebuild b/sci-biology/rebase/rebase-1503.ebuild
new file mode 100644
index 000000000000..c1698349fee8
--- /dev/null
+++ b/sci-biology/rebase/rebase-1503.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/rebase/rebase-1503.ebuild,v 1.5 2015/04/08 16:53:27 mgorny Exp $
+
+EAPI=5
+
+MY_PV=${PV#1}
+
+DESCRIPTION="A restriction enzyme database"
+HOMEPAGE="http://rebase.neb.com"
+SRC_URI="http://dev.gentoo.org/~jlec/distfiles/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="public-domain"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="emboss minimal"
+
+RDEPEND="emboss? ( >=sci-biology/emboss-5.0.0 )"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+src_compile() {
+ if use emboss; then
+ echo; einfo "Indexing Rebase for usage with EMBOSS."
+ mkdir REBASE || die
+ EMBOSS_DATA="." rebaseextract -auto -infile withrefm.${MY_PV} \
+ -protofile proto.${MY_PV} -equivalences \
+ || die "Indexing Rebase failed."
+ echo
+ fi
+}
+
+src_install() {
+ if ! use minimal; then
+ insinto /usr/share/${PN}
+ doins withrefm.${MY_PV} proto.${MY_PV}
+ fi
+ newdoc REBASE.DOC README
+ if use emboss; then
+ insinto /usr/share/EMBOSS/data/REBASE
+ doins REBASE/embossre.{enz,ref,sup}
+ insinto /usr/share/EMBOSS/data
+ doins REBASE/embossre.equ
+ fi
+}