summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-29 13:10:18 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-29 13:10:18 +0000
commitd061b9659b7fd2e818aa65f160fd2f22fbfd266a (patch)
tree950bb260322672b52f0002cab2ad265b55043166 /sci-biology/t-coffee
parentBump, remove old apache 2.2 directives, remove old versions. (diff)
downloadgentoo-2-d061b9659b7fd2e818aa65f160fd2f22fbfd266a.tar.gz
gentoo-2-d061b9659b7fd2e818aa65f160fd2f22fbfd266a.tar.bz2
gentoo-2-d061b9659b7fd2e818aa65f160fd2f22fbfd266a.zip
Version Bump; drop old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology/t-coffee')
-rw-r--r--sci-biology/t-coffee/ChangeLog8
-rw-r--r--sci-biology/t-coffee/t-coffee-11.00.ebuild54
-rw-r--r--sci-biology/t-coffee/t-coffee-8.93.ebuild66
3 files changed, 61 insertions, 67 deletions
diff --git a/sci-biology/t-coffee/ChangeLog b/sci-biology/t-coffee/ChangeLog
index cb65b7b1e108..2a02b731b129 100644
--- a/sci-biology/t-coffee/ChangeLog
+++ b/sci-biology/t-coffee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/t-coffee
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.53 2015/02/09 12:50:38 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/ChangeLog,v 1.54 2015/03/29 13:10:18 jlec Exp $
+
+*t-coffee-11.00 (29 Mar 2015)
+
+ 29 Mar 2015; Justin Lecher <jlec@gentoo.org> +t-coffee-11.00.ebuild,
+ -t-coffee-8.93.ebuild:
+ Version Bump; drop old
09 Feb 2015; Anthony G. Basile <blueness@gentoo.org> t-coffee-8.69.ebuild,
t-coffee-8.93.ebuild, t-coffee-9.03.1318-r1.ebuild:
diff --git a/sci-biology/t-coffee/t-coffee-11.00.ebuild b/sci-biology/t-coffee/t-coffee-11.00.ebuild
new file mode 100644
index 000000000000..a6b447d81942
--- /dev/null
+++ b/sci-biology/t-coffee/t-coffee-11.00.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-11.00.ebuild,v 1.1 2015/03/29 13:10:18 jlec Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+MY_HASH="8cbe486"
+MY_PV="${PV}.${MY_HASH}"
+MY_P="T-COFFEE_distribution_Version_${MY_PV}"
+
+DESCRIPTION="A multiple sequence alignment package"
+HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
+SRC_URI="http://www.tcoffee.org/Packages/Stable/Version_${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+RDEPEND="
+ sci-biology/clustalw
+ sci-chemistry/tm-align"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ sed \
+ -e '/@/s:.*;:\t:g' \
+ -e '/Linking/s:$(CC):$(CC) $(CFLAGS) $(LDFLAGS):g' \
+ -i t_coffee_source/makefile || die
+}
+
+src_compile() {
+ [[ $(gcc-version) == "3.4" ]] || \
+ [[ $(gcc-version) == "4.1" ]] && \
+ append-flags -fno-unit-at-a-time
+ emake \
+ V=1 \
+ CC="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS} -Wno-write-strings -Wno-unused-result" \
+ -C t_coffee_source t_coffee
+}
+
+src_install() {
+ dobin t_coffee_source/t_coffee
+
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r example
+ fi
+}
diff --git a/sci-biology/t-coffee/t-coffee-8.93.ebuild b/sci-biology/t-coffee/t-coffee-8.93.ebuild
deleted file mode 100644
index 2092ec91c026..000000000000
--- a/sci-biology/t-coffee/t-coffee-8.93.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/t-coffee/t-coffee-8.93.ebuild,v 1.3 2015/02/09 12:50:38 blueness Exp $
-
-EAPI="2"
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="A multiple sequence alignment package"
-HOMEPAGE="http://www.tcoffee.org/Projects_home_page/t_coffee_home_page.html"
-SRC_URI="http://www.tcoffee.org/Packages/T-COFFEE_distribution_Version_${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="sci-biology/clustalw"
-DEPEND="${DEPEND}
- test? ( dev-lang/perl )"
-
-S="${WORKDIR}/T-COFFEE_distribution_Version_${PV}"
-
-die_compile() {
- echo
- eerror "If you experience an internal compiler error (consult the above"
- eerror "messages), try compiling t-coffee using very modest compiler flags."
- eerror "See bug #114745 on the Gentoo Bugzilla for more details."
- die "Compilation failed"
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/8.69-flags.patch
- epatch "${FILESDIR}"/8.69-test.patch
-}
-
-src_compile() {
- [[ $(gcc-version) == "3.4" ]] && append-flags -fno-unit-at-a-time
- [[ $(gcc-version) == "4.1" ]] && append-flags -fno-unit-at-a-time
- emake \
- CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
- -C t_coffee_source || die_compile
-}
-
-src_test() {
- cd "${TCDIR}"
- perl bin/test.pl || die
-}
-
-src_install() {
- dobin t_coffee_source/t_coffee || die "Failed to install program."
-
-# insinto /usr/share/${PN}/lib/html
-# doins html/* || die "Failed to install Web interface files."
-
- dodoc doc/*.txt || die "Failed to install text documentation."
- dohtml doc/*.htm || die "Failed to install HTML documentation."
-
- insinto /usr/share/doc/${PF}
- doins doc/*.doc || die "Failed to install DOC documentation."
-
- if use examples; then
- insinto /usr/share/${PN}
- doins -r example || die "Failed to install example files."
- fi
-}