summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-21 03:29:14 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-21 03:29:14 +0000
commit19d73294a81806c4e59f65eb9201ebd91deb3fdc (patch)
tree2df6a1f13d0a9f1eb6cdc640e5a0e8eb3c77b931 /sci-biology
parentWorkaround entity parsing issue with openjade #238785 by Robert Wohlrab. (diff)
downloadgentoo-2-19d73294a81806c4e59f65eb9201ebd91deb3fdc.tar.gz
gentoo-2-19d73294a81806c4e59f65eb9201ebd91deb3fdc.tar.bz2
gentoo-2-19d73294a81806c4e59f65eb9201ebd91deb3fdc.zip
Version bump. Set SUPPORT_PYTHON_ABIS.
(Portage version: 15123-svn/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/biopython/ChangeLog8
-rw-r--r--sci-biology/biopython/biopython-1.53.ebuild59
2 files changed, 66 insertions, 1 deletions
diff --git a/sci-biology/biopython/ChangeLog b/sci-biology/biopython/ChangeLog
index e05ced52d1f6..f9a198987706 100644
--- a/sci-biology/biopython/ChangeLog
+++ b/sci-biology/biopython/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-biology/biopython
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.38 2009/10/31 17:56:54 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/ChangeLog,v 1.39 2009/12/21 03:29:14 arfrever Exp $
+
+*biopython-1.53 (21 Dec 2009)
+
+ 21 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +biopython-1.53.ebuild:
+ Version bump. Set SUPPORT_PYTHON_ABIS.
31 Oct 2009; Markus Meier <maekke@gentoo.org> biopython-1.52.ebuild:
amd64/x86 stable, bug #290931
diff --git a/sci-biology/biopython/biopython-1.53.ebuild b/sci-biology/biopython/biopython-1.53.ebuild
new file mode 100644
index 000000000000..9c53a58fc9c6
--- /dev/null
+++ b/sci-biology/biopython/biopython-1.53.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/biopython/biopython-1.53.ebuild,v 1.1 2009/12/21 03:29:14 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit base distutils eutils
+
+DESCRIPTION="Biopython - Python modules for computational molecular biology"
+HOMEPAGE="http://www.biopython.org http://pypi.python.org/pypi/biopython"
+SRC_URI="http://www.biopython.org/DIST/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+RDEPEND="dev-python/numpy
+ >=dev-python/reportlab-2.0
+ mysql? ( dev-python/mysql-python )
+ postgres? ( dev-python/psycopg )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+RESTRICT_PYTHON_ABIS="3.*"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.51-flex.patch"
+)
+
+DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
+DOCS="CONTRIB DEPRECATED NEWS README"
+PYTHON_MODNAME="Bio BioSQL"
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_test() {
+ cd Tests
+
+ testing() {
+ PYTHONPATH="$(ls -d ../build/lib.*)" "$(PYTHON)" run_tests.py
+ }
+ python_execute_function -s testing
+}
+
+src_install() {
+ distutils_src_install
+
+ dodir "/usr/share/doc/${PF}"
+ cp -r Doc/* "${D}/usr/share/doc/${PF}/" || \
+ die "Failed to install documentation."
+ dodir "/usr/share/${PN}"
+ rm -f Tests/*.pyc || \
+ die "Failed to remove precompiled test files."
+ cp -r --preserve=mode Scripts Tests "${D}/usr/share/${PN}/" || \
+ die "Failed to install shared files."
+}