summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-03-06 09:46:50 +0000
committerJustin Lecher <jlec@gentoo.org>2014-03-06 09:46:50 +0000
commit9bb1dad6704005ed8edc5bdef9c5a1e8b4bfd21d (patch)
treee52532244dc9c198fc877786bef0d635530e73e7 /sci-biology
parentsci-biology/tophat: Version Bump, #502532; thanks José María Fernández Go... (diff)
downloadgentoo-2-9bb1dad6704005ed8edc5bdef9c5a1e8b4bfd21d.tar.gz
gentoo-2-9bb1dad6704005ed8edc5bdef9c5a1e8b4bfd21d.tar.bz2
gentoo-2-9bb1dad6704005ed8edc5bdef9c5a1e8b4bfd21d.zip
sci-biology/tophat: Version Bump, #502532; thanks José María Fernández González for the new ebuild
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/tophat/ChangeLog11
-rw-r--r--sci-biology/tophat/files/tophat-2.0.9-flags.patch109
-rw-r--r--sci-biology/tophat/tophat-2.0.9.ebuild46
3 files changed, 164 insertions, 2 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
index 90c6c4831dd3..7fdca2b3f069 100644
--- a/sci-biology/tophat/ChangeLog
+++ b/sci-biology/tophat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-biology/tophat
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.11 2013/03/13 16:33:37 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.12 2014/03/06 09:46:50 jlec Exp $
+
+*tophat-2.0.9 (06 Mar 2014)
+
+ 06 Mar 2014; Justin Lecher <jlec@gentoo.org> +tophat-2.0.9.ebuild,
+ +files/tophat-2.0.9-flags.patch:
+ Version Bump, #502532; thanks José María Fernández González for the new
+ ebuild
*tophat-2.0.8 (13 Mar 2013)
diff --git a/sci-biology/tophat/files/tophat-2.0.9-flags.patch b/sci-biology/tophat/files/tophat-2.0.9-flags.patch
new file mode 100644
index 000000000000..af89e72084bf
--- /dev/null
+++ b/sci-biology/tophat/files/tophat-2.0.9-flags.patch
@@ -0,0 +1,109 @@
+ configure.ac | 3 ++-
+ src/Makefile.am | 50 +++++++++++++++++++++++++-------------------------
+ 2 files changed, 27 insertions(+), 26 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 75e9218..98b05d2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -68,7 +68,8 @@ AC_CANONICAL_HOST
+ # set CFLAGS and CXXFLAGS
+ #user_CFLAGS="${CXXFLAGS}"
+ user_CFLAGS=${CFLAGS}
+-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
++#generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
++generic_CFLAGS=""
+ ext_CFLAGS=""
+ debug_CFLAGS=""
+ user_LDFLAGS="$LDFLAGS"
+diff --git a/src/Makefile.am b/src/Makefile.am
+index dde692e..ebb9fcd 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -545,10 +545,10 @@ CLEANFILES = \
+ tophat2
+
+ tophat2: tophat2.in
+- sed -e 's|__PREFIX__|$(prefix)|' tophat2.in > tophat2
++ sed -e 's|__PREFIX__|$(prefix)|' $(top_srcdir)/src/tophat2.in > tophat2
+
+ tophat: tophat.py
+- sed -e 's|__VERSION__|$(VERSION)|' tophat.py > tophat
++ sed -e 's|__VERSION__|$(VERSION)|' $(top_srcdir)/src/tophat.py > tophat
+
+ #SUFFIXES = .py
+ #.py:
+@@ -617,49 +617,49 @@ libgc_a_SOURCES = \
+ #-- program sources
+
+ prep_reads_SOURCES = prep_reads.cpp
+-prep_reads_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
+-prep_reads_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++prep_reads_LDADD = libtophat.a $(BAM_LIB)
++prep_reads_LDFLAGS = $(BAM_LDFLAGS)
+
+ segment_juncs_SOURCES = segment_juncs.cpp
+-segment_juncs_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
+-segment_juncs_LDFLAGS = $(LDFLAGS) $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
++segment_juncs_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
++segment_juncs_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ long_spanning_reads_SOURCES = long_spanning_reads.cpp
+-long_spanning_reads_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
+-long_spanning_reads_LDFLAGS = $(LDFLAGS) $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
++long_spanning_reads_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
++long_spanning_reads_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ gtf_juncs_SOURCES = gtf_juncs.cpp
+-gtf_juncs_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
+-gtf_juncs_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++gtf_juncs_LDADD = libtophat.a libgc.a $(BAM_LIB)
++gtf_juncs_LDFLAGS = $(BAM_LDFLAGS)
+
+ juncs_db_SOURCES = juncs_db.cpp
+-juncs_db_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
+-juncs_db_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++juncs_db_LDADD = libtophat.a $(BAM_LIB)
++juncs_db_LDFLAGS = $(BAM_LDFLAGS)
+
+ tophat_reports_SOURCES = tophat_reports.cpp
+-tophat_reports_LDADD = $(top_builddir)/src/libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
+-tophat_reports_LDFLAGS = $(LDFLAGS) $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
++tophat_reports_LDADD = libtophat.a $(BOOST_THREAD_LIB) $(BOOST_SYSTEM_LIB) $(BAM_LIB)
++tophat_reports_LDFLAGS = $(BOOST_LDFLAGS) $(BAM_LDFLAGS)
+
+ fix_map_ordering_SOURCES = fix_map_ordering.cpp
+-fix_map_ordering_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
+-fix_map_ordering_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++fix_map_ordering_LDADD = libtophat.a $(BAM_LIB)
++fix_map_ordering_LDFLAGS = $(BAM_LDFLAGS)
+
+ bam2fastx_SOURCES = bam2fastx.cpp
+-bam2fastx_LDADD = $(top_builddir)/src/libgc.a $(BAM_LIB)
+-bam2fastx_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++bam2fastx_LDADD = libgc.a $(BAM_LIB)
++bam2fastx_LDFLAGS = $(BAM_LDFLAGS)
+
+ bam_merge_SOURCES = bam_merge.cpp
+-bam_merge_LDADD = $(top_builddir)/src/libtophat.a $(top_builddir)/src/libgc.a $(BAM_LIB)
+-bam_merge_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++bam_merge_LDADD = libtophat.a libgc.a $(BAM_LIB)
++bam_merge_LDFLAGS = $(BAM_LDFLAGS)
+
+ sam_juncs_SOURCES = sam_juncs.cpp
+-sam_juncs_LDADD = $(top_builddir)/src/libtophat.a $(BAM_LIB)
+-sam_juncs_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++sam_juncs_LDADD = libtophat.a $(BAM_LIB)
++sam_juncs_LDFLAGS = $(BAM_LDFLAGS)
+
+ map2gtf_SOURCES = map2gtf.cpp
+-map2gtf_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
+-map2gtf_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++map2gtf_LDADD = libtophat.a libgc.a $(BAM_LIB)
++map2gtf_LDFLAGS = $(BAM_LDFLAGS)
+
+ gtf_to_fasta_SOURCES = GTFToFasta.cpp FastaTools.cpp
+-gtf_to_fasta_LDADD = $(top_builddir)/src/libtophat.a libgc.a $(BAM_LIB)
+-gtf_to_fasta_LDFLAGS = $(LDFLAGS) $(BAM_LDFLAGS)
++gtf_to_fasta_LDADD = libtophat.a libgc.a $(BAM_LIB)
++gtf_to_fasta_LDFLAGS = $(BAM_LDFLAGS)
diff --git a/sci-biology/tophat/tophat-2.0.9.ebuild b/sci-biology/tophat/tophat-2.0.9.ebuild
new file mode 100644
index 000000000000..3f63f7f88d7b
--- /dev/null
+++ b/sci-biology/tophat/tophat-2.0.9.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-2.0.9.ebuild,v 1.1 2014/03/06 09:46:50 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-single-r1
+
+DESCRIPTION="A fast splice junction mapper for RNA-Seq reads"
+HOMEPAGE="http://tophat.cbcb.umd.edu/"
+SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/boost
+ sci-biology/samtools
+ sci-biology/seqan"
+RDEPEND="${DEPEND}
+ sci-biology/bowtie"
+
+PATCHES=( "${FILESDIR}"/${P}-flags.patch )
+
+src_prepare() {
+ rm -rf src/SeqAn* || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-optim
+ $(use_enable debug)
+ )
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ python_fix_shebang "${ED}"/usr/bin/tophat
+}