summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:42:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-08-05 19:42:00 +0000
commit9faa0650c49e9dc196d93e3b19907f518e0aa9e1 (patch)
tree08830c0d932cdbbff71b996599d3b8caad299577 /sci-biology
parentKeywording for ppc. (diff)
downloadgentoo-2-9faa0650c49e9dc196d93e3b19907f518e0aa9e1.tar.gz
gentoo-2-9faa0650c49e9dc196d93e3b19907f518e0aa9e1.tar.bz2
gentoo-2-9faa0650c49e9dc196d93e3b19907f518e0aa9e1.zip
Fix building with GLIBC 2.10+ wrt #278307.
(Portage version: 2.2_rc36/cvs/Linux x86_64)
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/wise/ChangeLog8
-rw-r--r--sci-biology/wise/files/wise-2.2.0-glibc-2.10.patch301
-rw-r--r--sci-biology/wise/wise-2.2.0.ebuild8
3 files changed, 312 insertions, 5 deletions
diff --git a/sci-biology/wise/ChangeLog b/sci-biology/wise/ChangeLog
index 8b12e0883680..c6f4c2a0cfa0 100644
--- a/sci-biology/wise/ChangeLog
+++ b/sci-biology/wise/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-biology/wise
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/wise/ChangeLog,v 1.13 2008/06/09 10:12:00 markusle Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/wise/ChangeLog,v 1.14 2009/08/05 19:42:00 ssuominen Exp $
+
+ 05 Aug 2009; Samuli Suominen <ssuominen@gentoo.org> wise-2.2.0.ebuild,
+ +files/wise-2.2.0-glibc-2.10.patch:
+ Fix building with GLIBC 2.10+ wrt #278307.
09 Jun 2008; Markus Dittrich <markusle@gentoo.org> wise-2.2.0.ebuild:
Switched virtual/tetex -> virtual/latex-base and added amd64
diff --git a/sci-biology/wise/files/wise-2.2.0-glibc-2.10.patch b/sci-biology/wise/files/wise-2.2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..1ec433f19227
--- /dev/null
+++ b/sci-biology/wise/files/wise-2.2.0-glibc-2.10.patch
@@ -0,0 +1,301 @@
+diff -ur wise2.2.0.orig/src/HMMer2/sqio.c wise2.2.0/src/HMMer2/sqio.c
+--- wise2.2.0.orig/src/HMMer2/sqio.c 2001-06-18 16:59:51.000000000 +0300
++++ wise2.2.0/src/HMMer2/sqio.c 2009-08-05 22:39:04.000000000 +0300
+@@ -213,7 +213,7 @@
+ }
+ }
+
+-/* Function: getline()
++/* Function: get_line()
+ * Date: SRE, Tue Mar 3 08:30:01 1998 [St. Louis]
+ *
+ * Purpose: read a line from a sequence file into V->sbuffer.
+@@ -229,7 +229,7 @@
+ * Returns: (void)
+ */
+ static void
+-getline(struct ReadSeqVars *V)
++get_line(struct ReadSeqVars *V)
+ {
+ char *cp;
+
+@@ -299,7 +299,7 @@
+ V->seqlen = 0;
+ if (addfirst) addseq(V->sbuffer, V);
+ do {
+- getline(V);
++ get_line(V);
+ /* feof() alone is a bug; files not necessarily \n terminated */
+ if (*(V->sbuffer) == '\0' && feof(V->f))
+ done = TRUE;
+@@ -327,7 +327,7 @@
+ char *sptr;
+ /* load first line of entry */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ENTRY", 5) != 0)
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) return;
+
+ if ((sptr = strtok(V->sbuffer + 15, "\n\t ")) != NULL)
+@@ -336,7 +336,7 @@
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_ID);
+ }
+ do {
+- getline(V);
++ get_line(V);
+ if (!feof(V->f) && strncmp(V->sbuffer, "TITLE", 5) == 0)
+ SetSeqinfoString(V->sqinfo, V->sbuffer+15, SQINFO_DESC);
+ else if (!feof(V->f) && strncmp(V->sbuffer, "ACCESSION", 9) == 0)
+@@ -345,7 +345,7 @@
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_ACC);
+ }
+ } while (! feof(V->f) && (strncmp(V->sbuffer,"SEQUENCE", 8) != 0));
+- getline(V); /* skip next line, coords */
++ get_line(V); /* skip next line, coords */
+
+ readLoop(0, endPIR, V);
+
+@@ -359,7 +359,7 @@
+ /* get next line
+ */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ENTRY", 5) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -377,7 +377,7 @@
+ char *nm;
+ /* position past ';' comments */
+ do {
+- getline(V);
++ get_line(V);
+ } while (! (feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer != ';')) ));
+
+ if (!feof(V->f))
+@@ -389,7 +389,7 @@
+ }
+
+ while (!(feof(V->f) || ((*V->sbuffer != '\0') && (*V->sbuffer == ';'))))
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -411,7 +411,7 @@
+ if ((nm = strtok(V->sbuffer+16, ",\n\t ")) != NULL)
+ SetSeqinfoString(V->sqinfo, nm, SQINFO_NAME);
+ }
+- getline(V);
++ get_line(V);
+ }
+
+ if (! feof(V->f))
+@@ -420,7 +420,7 @@
+ /* load next line
+ */
+ while ((!feof(V->f)) && (*V->sbuffer != ';'))
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -438,7 +438,7 @@
+ int in_definition;
+
+ while (strncmp(V->sbuffer, "LOCUS", 5) != 0)
+- getline(V);
++ get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+12, "\n\t ")) != NULL)
+ {
+@@ -449,7 +449,7 @@
+ in_definition = FALSE;
+ while (! feof(V->f))
+ {
+- getline(V);
++ get_line(V);
+ if (! feof(V->f) && strstr(V->sbuffer, "DEFINITION") == V->sbuffer)
+ {
+ if ((sptr = strtok(V->sbuffer+12, "\n")) != NULL)
+@@ -482,11 +482,11 @@
+
+
+ while (!(feof(V->f) || ((*V->sbuffer!=0) && (strstr(V->sbuffer,"LOCUS") == V->sbuffer))))
+- getline(V);
++ get_line(V);
+ /* SRE: V->s now holds "//", so sequential
+ reads are wedged: fixed Tue Jul 13 1993 */
+ while (!feof(V->f) && strstr(V->sbuffer, "LOCUS ") != V->sbuffer)
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -515,7 +515,7 @@
+ Die("bogus GCGdata format? %s", V->sbuffer);
+
+ /* second line contains free text description */
+- getline(V);
++ get_line(V);
+ SetSeqinfoString(V->sqinfo, V->sbuffer, SQINFO_DESC);
+
+ if (binary) {
+@@ -535,7 +535,7 @@
+ else readLoop(0, endGCGdata, V);
+
+ while (!(feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer == '>'))))
+- getline(V);
++ get_line(V);
+ }
+
+ static int
+@@ -555,12 +555,12 @@
+ if ((sptr = strtok(NULL, "\n")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_DESC);
+ /* workaround for long NCBI NR lines */
+- while (V->longline && ! feof(V->f)) getline(V);
++ while (V->longline && ! feof(V->f)) get_line(V);
+
+ readLoop(0, endPearson, V);
+
+ while (!(feof(V->f) || ((*V->sbuffer != 0) && (*V->sbuffer == '>'))))
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -587,7 +587,7 @@
+
+ /* make sure we have first line */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ID ", 4) != 0)
+- getline(V);
++ get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+5, "\n\t ")) != NULL)
+ {
+@@ -596,7 +596,7 @@
+ }
+
+ do {
+- getline(V);
++ get_line(V);
+ if (!feof(V->f) && strstr(V->sbuffer, "AC ") == V->sbuffer)
+ {
+ if ((sptr = strtok(V->sbuffer+5, "; \t\n")) != NULL)
+@@ -620,7 +620,7 @@
+
+ /* load next record's ID line */
+ while (!feof(V->f) && strncmp(V->sbuffer, "ID ", 4) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -636,7 +636,7 @@
+ {
+ char *sptr;
+
+- getline(V); /*s == "seqLen seqid string..."*/
++ get_line(V); /*s == "seqLen seqid string..."*/
+
+ if ((sptr = strtok(V->sbuffer+6, " \t\n")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_NAME);
+@@ -647,7 +647,7 @@
+ readLoop(0, endZuker, V);
+
+ while (!(feof(V->f) | ((*V->sbuffer != '\0') & (*V->sbuffer == '('))))
+- getline(V);
++ get_line(V);
+ }
+
+ static void
+@@ -669,7 +669,7 @@
+
+ do {
+ done = feof(V->f);
+- getline(V);
++ get_line(V);
+ if (! done) addseq(V->sbuffer, V);
+ } while (!done);
+ }
+@@ -681,7 +681,7 @@
+ char *sptr;
+ int dostruc = FALSE;
+
+- while (strncmp(V->sbuffer, "NAM ", 4) != 0) getline(V);
++ while (strncmp(V->sbuffer, "NAM ", 4) != 0) get_line(V);
+
+ if ((sptr = strtok(V->sbuffer+4, "\n\t ")) != NULL)
+ SetSeqinfoString(V->sqinfo, sptr, SQINFO_NAME);
+@@ -689,7 +689,7 @@
+ /*CONSTCOND*/
+ while (1)
+ {
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) {squid_errno = SQERR_FORMAT; return; }
+
+ if (strncmp(V->sbuffer, "SRC ", 4) == 0)
+@@ -721,14 +721,14 @@
+ while (1)
+ {
+ /* sequence line */
+- getline(V);
++ get_line(V);
+ if (feof(V->f) || strncmp(V->sbuffer, "++", 2) == 0)
+ break;
+ addseq(V->sbuffer, V);
+ /* structure line */
+ if (dostruc)
+ {
+- getline(V);
++ get_line(V);
+ if (feof(V->f)) { squid_errno = SQERR_FORMAT; return; }
+ addstruc(V->sbuffer, V);
+ }
+@@ -736,7 +736,7 @@
+
+
+ while (!feof(V->f) && strncmp(V->sbuffer, "NAM ", 4) != 0)
+- getline(V);
++ get_line(V);
+ }
+
+
+@@ -816,7 +816,7 @@
+
+ /* Load the first line.
+ */
+- getline(dbfp);
++ get_line(dbfp);
+
+ return dbfp;
+ }
+@@ -833,7 +833,7 @@
+ Die("SeqfilePosition() failed: in a nonrewindable data file or stream");
+
+ fseek(sqfp->f, offset, SEEK_SET);
+- getline(sqfp);
++ get_line(sqfp);
+ }
+
+
+@@ -853,7 +853,7 @@
+ if (sqfp->ali_aseqs != NULL) sqfp->ali_curridx = 0;
+ else {
+ rewind(sqfp->f);
+- getline(sqfp);
++ get_line(sqfp);
+ }
+ }
+
+@@ -949,7 +949,7 @@
+ do { /* skip leading comments on GCG file */
+ gotuw = (strstr(V->sbuffer,"..") != NULL);
+ if (gotuw) readUWGCG(V);
+- getline(V);
++ get_line(V);
+ } while (! feof(V->f));
+ break;
+
diff --git a/sci-biology/wise/wise-2.2.0.ebuild b/sci-biology/wise/wise-2.2.0.ebuild
index f59d09a928a9..da6d2419950e 100644
--- a/sci-biology/wise/wise-2.2.0.ebuild
+++ b/sci-biology/wise/wise-2.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/wise/wise-2.2.0.ebuild,v 1.9 2008/06/09 10:12:00 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/wise/wise-2.2.0.ebuild,v 1.10 2009/08/05 19:42:00 ssuominen Exp $
inherit eutils toolchain-funcs
@@ -20,10 +20,12 @@ DEPEND="${RDEPEND}
dev-lang/perl
virtual/latex-base"
-S="${WORKDIR}/${PN}${PV}"
+S=${WORKDIR}/${PN}${PV}
src_unpack() {
unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
cd "${S}"/src
# if use threads; then
# append-flags "-DPTHREAD"