summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-07-06 15:40:42 +0000
committerJeroen Roovers <jer@gentoo.org>2013-07-06 15:40:42 +0000
commit330ca91a5597e7d2b0066356777732b3cb86cb27 (patch)
treeb042cd71640dac984aadb81b19b14c7e90ac1901 /sci-calculators/units
parentManifests (diff)
downloadgentoo-2-330ca91a5597e7d2b0066356777732b3cb86cb27.tar.gz
gentoo-2-330ca91a5597e7d2b0066356777732b3cb86cb27.tar.bz2
gentoo-2-330ca91a5597e7d2b0066356777732b3cb86cb27.zip
Update patch to remove the proper node from the element tree.
(Portage version: 2.2.0_alpha186/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sci-calculators/units')
-rw-r--r--sci-calculators/units/ChangeLog8
-rw-r--r--sci-calculators/units/files/units-2.01_cur.patch6
-rw-r--r--sci-calculators/units/units-2.01-r2.ebuild (renamed from sci-calculators/units/units-2.01-r1.ebuild)2
3 files changed, 11 insertions, 5 deletions
diff --git a/sci-calculators/units/ChangeLog b/sci-calculators/units/ChangeLog
index caf4b1c0b746..efd9cdc3f47c 100644
--- a/sci-calculators/units/ChangeLog
+++ b/sci-calculators/units/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-calculators/units
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.55 2013/07/06 15:08:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/ChangeLog,v 1.56 2013/07/06 15:40:41 jer Exp $
+
+*units-2.01-r2 (06 Jul 2013)
+
+ 06 Jul 2013; Jeroen Roovers <jer@gentoo.org> +units-2.01-r2.ebuild,
+ -units-2.01-r1.ebuild, files/units-2.01_cur.patch:
+ Update patch to remove the proper node from the element tree.
06 Jul 2013; Jeroen Roovers <jer@gentoo.org> units-2.01-r1.ebuild:
Update dev-lang/python dependency.
diff --git a/sci-calculators/units/files/units-2.01_cur.patch b/sci-calculators/units/files/units-2.01_cur.patch
index 8cf9c9c939be..03e09f77c9fa 100644
--- a/sci-calculators/units/files/units-2.01_cur.patch
+++ b/sci-calculators/units/files/units-2.01_cur.patch
@@ -1,5 +1,5 @@
---- a/units-2.01/units_cur
-+++ b/units-2.01/units_cur
+--- a/units_cur
++++ b/units_cur
@@ -1,10 +1,11 @@
-#!/usr/bin/python
+#!/usr/bin/python2
@@ -71,7 +71,7 @@
+for datum in data:
+ if datum.find('code').text == 'USD':
+ usdval = datum.find('rate').text[2:]
-+ datum.remove
++ data.remove(datum)
now = datetime.datetime.now()
output.write('\n# Currency exchange rates from Time Genie (www.timegenie.com)\n')
diff --git a/sci-calculators/units/units-2.01-r1.ebuild b/sci-calculators/units/units-2.01-r2.ebuild
index 46f0f7bf3f5d..74de3f9c120d 100644
--- a/sci-calculators/units/units-2.01-r1.ebuild
+++ b/sci-calculators/units/units-2.01-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.01-r1.ebuild,v 1.2 2013/07/06 15:08:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/units/units-2.01-r2.ebuild,v 1.1 2013/07/06 15:40:41 jer Exp $
EAPI=5
inherit autotools eutils