summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2005-12-24 14:58:00 +0000
committerTony Vroon <chainsaw@gentoo.org>2005-12-24 14:58:00 +0000
commit0c6b65d8eb1c28ad121a5030fd40550b81457b18 (patch)
tree52b119f21be3bbb7fdb95d6dd20a0496e6254c87 /sci-calculators
parentNew version, more changes will follow later (diff)
downloadgentoo-2-0c6b65d8eb1c28ad121a5030fd40550b81457b18.tar.gz
gentoo-2-0c6b65d8eb1c28ad121a5030fd40550b81457b18.tar.bz2
gentoo-2-0c6b65d8eb1c28ad121a5030fd40550b81457b18.zip
Initial commit, closes bug #62492 by Marius Konitzer. Ebuild by Yaakov S <yselkowitz@hotmail.com>.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/gonvert/ChangeLog11
-rw-r--r--sci-calculators/gonvert/Manifest4
-rw-r--r--sci-calculators/gonvert/files/0.2.12-about.patch12
-rw-r--r--sci-calculators/gonvert/files/digest-gonvert-0.2.121
-rw-r--r--sci-calculators/gonvert/gonvert-0.2.12.ebuild37
-rw-r--r--sci-calculators/gonvert/metadata.xml9
6 files changed, 74 insertions, 0 deletions
diff --git a/sci-calculators/gonvert/ChangeLog b/sci-calculators/gonvert/ChangeLog
new file mode 100644
index 000000000000..123b94afe4de
--- /dev/null
+++ b/sci-calculators/gonvert/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-calculators/gonvert
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/gonvert/ChangeLog,v 1.1 2005/12/24 14:58:00 chainsaw Exp $
+
+*gonvert-0.2.12 (24 Dec 2005)
+
+ 24 Dec 2005; <chainsaw@gentoo.org> +files/0.2.12-about.patch,
+ +metadata.xml, +gonvert-0.2.12.ebuild:
+ Initial commit, closes bug #62492 by Marius Konitzer. Ebuild by Yaakov S
+ <yselkowitz@hotmail.com>.
+
diff --git a/sci-calculators/gonvert/Manifest b/sci-calculators/gonvert/Manifest
new file mode 100644
index 000000000000..0321124b9a01
--- /dev/null
+++ b/sci-calculators/gonvert/Manifest
@@ -0,0 +1,4 @@
+MD5 7a256b70c07c8427561f42bb27b312e4 files/0.2.12-about.patch 540
+MD5 76f8a1799e14eda8add1a5f2d99ab94c files/digest-gonvert-0.2.12 66
+MD5 a5110450be7e57645fadcd7c6a674ae6 gonvert-0.2.12.ebuild 934
+MD5 21fbda69ea690869a8d2812f140bb3c7 metadata.xml 246
diff --git a/sci-calculators/gonvert/files/0.2.12-about.patch b/sci-calculators/gonvert/files/0.2.12-about.patch
new file mode 100644
index 000000000000..c98b5fc2c847
--- /dev/null
+++ b/sci-calculators/gonvert/files/0.2.12-about.patch
@@ -0,0 +1,12 @@
+diff -urN gonvert-0.2.11-orig/gonvert gonvert-0.2.11/gonvert
+--- gonvert-0.2.11-orig/gonvert 2004-09-03 07:00:20.000000000 -0400
++++ gonvert-0.2.11/gonvert 2004-11-28 20:05:34.000000000 -0500
+@@ -997,7 +997,7 @@
+ books_window = widgets.get_widget('books_window')
+
+ about_image = widgets.get_widget('about_image')
+-about_image.set_from_file(homepath +'pixmaps/gonvert_picture.png')
++about_image.set_from_file(homepath +'../pixmaps/gonvert_picture.png')
+ versionlabel = widgets.get_widget('versionlabel')
+ versionlabel.set_text(version)
+
diff --git a/sci-calculators/gonvert/files/digest-gonvert-0.2.12 b/sci-calculators/gonvert/files/digest-gonvert-0.2.12
new file mode 100644
index 000000000000..8588acda536e
--- /dev/null
+++ b/sci-calculators/gonvert/files/digest-gonvert-0.2.12
@@ -0,0 +1 @@
+MD5 ef958ba92b5133beb45982ad556fdf21 gonvert-0.2.12.tar.gz 163490
diff --git a/sci-calculators/gonvert/gonvert-0.2.12.ebuild b/sci-calculators/gonvert/gonvert-0.2.12.ebuild
new file mode 100644
index 000000000000..828b6f9a5e20
--- /dev/null
+++ b/sci-calculators/gonvert/gonvert-0.2.12.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-calculators/gonvert/gonvert-0.2.12.ebuild,v 1.1 2005/12/24 14:58:00 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Unit conversion utility written in PyGTK"
+HOMEPAGE="http://unihedron.com/projects/gonvert/gonvert.php"
+SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="=dev-python/pygtk-2*"
+
+pkg_setup() {
+ # see Gentoo Bugzilla bug 2272
+ built_with_use "=dev-python/pygtk-2*" gnome ||
+ { eerror "PyGTK must be compiled with libglade support for gonvert to run."
+ eerror "Please reemerge pygtk with the \"gnome\" USE flag."
+ die "No libglade support in pygtk."
+ }
+}
+
+src_unpack () {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-about.patch || die
+}
+
+src_install () {
+ make install DESTDIR="${D}" prefix=/usr || die
+ rm -fr "${D}/usr/share/doc/${PN}"
+ dodoc doc/CHANGELOG doc/FAQ doc/README doc/THANKS doc/TODO
+}
diff --git a/sci-calculators/gonvert/metadata.xml b/sci-calculators/gonvert/metadata.xml
new file mode 100644
index 000000000000..0f3109173ffa
--- /dev/null
+++ b/sci-calculators/gonvert/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>chainsaw@gentoo.org</email>
+ <name>Tony Vroon</name>
+</maintainer>
+</pkgmetadata>