summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-12 17:29:36 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-12 17:29:36 +0000
commit713d7fcc708918d27cf1c23027ea1339c1b72cd3 (patch)
tree60f2be0de9eaa84f41aa2a0085f106c01d96adcd /sci-chemistry/caver
parentMask KDE 4.4.0 also here because of ~arm in kdelibs. (diff)
downloadgentoo-2-713d7fcc708918d27cf1c23027ea1339c1b72cd3.tar.gz
gentoo-2-713d7fcc708918d27cf1c23027ea1339c1b72cd3.tar.bz2
gentoo-2-713d7fcc708918d27cf1c23027ea1339c1b72cd3.zip
Version Bump
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-chemistry/caver')
-rw-r--r--sci-chemistry/caver/ChangeLog10
-rw-r--r--sci-chemistry/caver/caver-2.0.003.ebuild64
2 files changed, 72 insertions, 2 deletions
diff --git a/sci-chemistry/caver/ChangeLog b/sci-chemistry/caver/ChangeLog
index 06bb22ef047c..b717b8732f09 100644
--- a/sci-chemistry/caver/ChangeLog
+++ b/sci-chemistry/caver/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-chemistry/caver
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.12 2009/07/07 23:14:33 flameeyes Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/ChangeLog,v 1.13 2010/02/12 17:29:36 jlec Exp $
+
+*caver-2.0.003 (12 Feb 2010)
+
+ 12 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net>
+ +caver-2.0.003.ebuild:
+ Version bump
07 Jul 2009; Diego E. Pettenò <flameeyes@gentoo.org> caver-0.99.4.ebuild:
Use elog for fetch error.
diff --git a/sci-chemistry/caver/caver-2.0.003.ebuild b/sci-chemistry/caver/caver-2.0.003.ebuild
new file mode 100644
index 000000000000..daceb7b5e283
--- /dev/null
+++ b/sci-chemistry/caver/caver-2.0.003.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/caver/caver-2.0.003.ebuild,v 1.1 2010/02/12 17:29:36 jlec Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit multilib python eutils versionator java-utils-2
+
+MY_PV="$(replace_version_separator 2 -v $(replace_version_separator 1 _ ${PV}))"
+MY_P="${PN}${MY_PV}_pymol_plugin"
+
+DESCRIPTION="Calculation of pathways from buried cavities to outside solvent in protein structures"
+HOMEPAGE="http://loschmidt.chemi.muni.cz/caver/"
+SRC_URI="${MY_P}.zip"
+
+LICENSE="CAVER"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6
+ sci-chemistry/pymol"
+DEPEND="app-arch/unzip"
+
+RESTRICT="fetch"
+
+S="${WORKDIR}/Caver${MY_PV}"/linux_mac
+
+pkg_nofetch() {
+ elog "Download ${MY_P}.tar.gz"
+ elog "from ${HOMEPAGE}. This requires registration."
+ elog "Place tarballs in ${DISTDIR}."
+}
+
+src_prepare() {
+ python_copy_sources --no-link
+}
+
+src_install() {
+ java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/*.jar
+
+ java-pkg_jarinto /usr/share/${PN}/lib/
+ java-pkg_dojar Caver$(replace_all_version_separators _ ${PV})/lib/*.jar
+
+ installation() {
+ sed \
+ -e "s:directory/where/jar/with/plugin/is/located:/usr/share/${PN}/lib/:g" \
+ -i Caver$(replace_all_version_separators _ ${PV}).py || die
+
+ insinto $(python_get_sitedir)/pmg_tk/startup/
+ doins Caver$(replace_all_version_separators _ ${PV}).py || die
+ }
+ python_execute_function -s installation
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}