summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-18 08:27:49 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-18 08:27:49 +0000
commit07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8 (patch)
treeaa78c35ff8e75865fe6e9d3d15493e85746568cf /sci-chemistry/cluster
parentKeyword ~ppc64 wrt #321937. (diff)
downloadgentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.tar.gz
gentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.tar.bz2
gentoo-2-07bfeb2a4e97731c1cff7dd86b9f62e9b5610ed8.zip
New Addition
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/cluster')
-rw-r--r--sci-chemistry/cluster/ChangeLog11
-rw-r--r--sci-chemistry/cluster/cluster-1.3.081231.ebuild38
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-includes.patch12
-rw-r--r--sci-chemistry/cluster/files/1.3.081231-ldflags.patch35
-rw-r--r--sci-chemistry/cluster/metadata.xml18
5 files changed, 114 insertions, 0 deletions
diff --git a/sci-chemistry/cluster/ChangeLog b/sci-chemistry/cluster/ChangeLog
new file mode 100644
index 000000000000..f0708558c099
--- /dev/null
+++ b/sci-chemistry/cluster/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-chemistry/cluster
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/ChangeLog,v 1.1 2010/07/18 08:27:49 jlec Exp $
+
+*cluster-1.3.081231 (18 Jul 2010)
+
+ 18 Jul 2010; Justin Lecher <jlec@gentoo.org>
+ +files/1.3.081231-includes.patch, +files/1.3.081231-ldflags.patch,
+ +cluster-1.3.081231.ebuild, +metadata.xml:
+ New Addition
+
diff --git a/sci-chemistry/cluster/cluster-1.3.081231.ebuild b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
new file mode 100644
index 000000000000..4d3d59c17599
--- /dev/null
+++ b/sci-chemistry/cluster/cluster-1.3.081231.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/cluster/cluster-1.3.081231.ebuild,v 1.1 2010/07/18 08:27:49 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Build lists of collections of interacting items"
+HOMEPAGE="http://kinemage.biochem.duke.edu/software/index.php"
+SRC_URI="http://kinemage.biochem.duke.edu/downloads/software/${PN}/${PN}.${PV}.src.tgz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="richardson"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}1.3src
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-ldflags.patch \
+ "${FILESDIR}"/${PV}-includes.patch
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ || die
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc README.cluster || die
+}
diff --git a/sci-chemistry/cluster/files/1.3.081231-includes.patch b/sci-chemistry/cluster/files/1.3.081231-includes.patch
new file mode 100644
index 000000000000..a5586a540a4f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-includes.patch
@@ -0,0 +1,12 @@
+diff --git a/cluster.cpp b/cluster.cpp
+index 0a8c3c1..1384949 100644
+--- a/cluster.cpp
++++ b/cluster.cpp
+@@ -24,6 +24,7 @@
+ #include <iostream>
+ #include <vector>
+ #include <string>
++#include <cstring>
+
+ #include <iostream>
+ #include <fstream>
diff --git a/sci-chemistry/cluster/files/1.3.081231-ldflags.patch b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
new file mode 100644
index 000000000000..d407e0bc8b8f
--- /dev/null
+++ b/sci-chemistry/cluster/files/1.3.081231-ldflags.patch
@@ -0,0 +1,35 @@
+diff --git a/Makefile b/Makefile
+index 7892054..938a8c8 100644
+--- a/Makefile
++++ b/Makefile
+@@ -3,7 +3,7 @@ PROG_FLGS = -D BOOLPREDEFINED
+
+ SRCS = cluster.cpp DisjointSets.cpp utility.cpp
+
+-CFLAGS = $(OPT) $(DEBUG) $(PROG_FLGS)
++CXXFLAGS += $(OPT) $(DEBUG) $(PROG_FLGS)
+
+ LFLAGS =
+
+@@ -12,7 +12,7 @@ OBJLIST = cluster.o DisjointSets.o utility.o
+ CXX = g++
+
+ .cpp.o:
+- $(CXX) -c $*.cpp $(CFLAGS)
++ $(CXX) $(CXXFLAGS) -c $*.cpp
+
+ OPT = -O3
+ DEBUG = $(CXXDEBUGFLAGS)
+@@ -20,10 +20,10 @@ DEBUG = $(CXXDEBUGFLAGS)
+ all: cluster
+
+ cluster: $(OBJLIST)
+- $(CXX) -o $@ $(OBJLIST) $(LFLAGS)
++ $(CXX) $(LDFLAGS) -o $@ $(OBJLIST)
+
+ depend:
+- makedepend -- $(CFLAGS) -- $(SRCS)
++ makedepend -- $(CXXFLAGS) -- $(SRCS)
+
+ clean:
+ @rm -rf *.o *.ckp ii_files
diff --git a/sci-chemistry/cluster/metadata.xml b/sci-chemistry/cluster/metadata.xml
new file mode 100644
index 000000000000..6950f7c61ee3
--- /dev/null
+++ b/sci-chemistry/cluster/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+<longdescription>
+Cluster is a simple UNIX C++ program to build lists of collections
+of interacting items from records containing interacting pairs
+and larger fragments.
+
+It reads in lines consisting of two or more names and output
+connected clusters of names. Each line of output is
+prefixed with a cluster number, the size of the cluster
+and an optional name string.
+</longdescription>
+</pkgmetadata>