summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-05-14 09:28:33 +0000
committerJustin Lecher <jlec@gentoo.org>2014-05-14 09:28:33 +0000
commitf91feb545caef3f5ae32a019a1e16af8d05a9f10 (patch)
tree7b095234b53b1c0fa13a0a6f687a6626dd374de1 /sci-chemistry/dssp
parentversion 2.6.x bump fix #508190 (diff)
downloadgentoo-2-f91feb545caef3f5ae32a019a1e16af8d05a9f10.tar.gz
gentoo-2-f91feb545caef3f5ae32a019a1e16af8d05a9f10.tar.bz2
gentoo-2-f91feb545caef3f5ae32a019a1e16af8d05a9f10.zip
sci-chemistry/dssp: Version Bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-chemistry/dssp')
-rw-r--r--sci-chemistry/dssp/ChangeLog9
-rw-r--r--sci-chemistry/dssp/dssp-2.2.1.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sci-chemistry/dssp/ChangeLog b/sci-chemistry/dssp/ChangeLog
index c3ba844e229c..fd6cde576ba9 100644
--- a/sci-chemistry/dssp/ChangeLog
+++ b/sci-chemistry/dssp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/dssp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/ChangeLog,v 1.11 2013/07/09 08:34:28 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/ChangeLog,v 1.12 2014/05/14 09:28:33 jlec Exp $
+
+*dssp-2.2.1 (14 May 2014)
+
+ 14 May 2014; Justin Lecher <jlec@gentoo.org> +dssp-2.2.1.ebuild:
+ Version Bump
09 Jul 2013; Justin Lecher <jlec@gentoo.org> dssp-2.1.0.ebuild:
Add subslot for boost
diff --git a/sci-chemistry/dssp/dssp-2.2.1.ebuild b/sci-chemistry/dssp/dssp-2.2.1.ebuild
new file mode 100644
index 000000000000..5e91a9a8591f
--- /dev/null
+++ b/sci-chemistry/dssp/dssp-2.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/dssp/dssp-2.2.1.ebuild,v 1.1 2014/05/14 09:28:33 jlec Exp $
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="The protein secondary structure standard"
+HOMEPAGE="http://swift.cmbi.ru.nl/gv/dssp/"
+SRC_URI="ftp://ftp.cmbi.ru.nl/pub/molbio/software/dssp-2/${P}.tgz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ tc-export CXX
+
+ cat >> make.config <<- EOF
+ BOOST_LIB_SUFFIX = -mt
+ BOOST_LIB_DIR = "${EPREFIX}/usr/$(get_libdir)"
+ BOOST_INC_DIR = "${EPREFIX}/usr/include"
+ EOF
+
+ epatch \
+ "${FILESDIR}"/${PN}-2.1.0-gentoo.patch
+}
+
+src_install() {
+ dobin mkdssp
+ dosym mkdssp /usr/bin/dssp
+ doman doc/mkdssp.1
+ dodoc README.txt changelog
+
+ cat >> "${T}"/30-${PN} <<- EOF
+ DSSP="${EPRFIX}"/usr/bin/${PN}
+ EOF
+ doenvd "${T}"/30-${PN}
+}