summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-01-30 16:28:26 +0000
committerJustin Lecher <jlec@gentoo.org>2011-01-30 16:28:26 +0000
commit9e246c837a1fe25d1125a603991c8fd7366581de (patch)
tree80202ed95c32401ad38c9eb8b97022410e6f849d /sci-chemistry/gabedit
parentVersion bump. (diff)
downloadgentoo-2-9e246c837a1fe25d1125a603991c8fd7366581de.tar.gz
gentoo-2-9e246c837a1fe25d1125a603991c8fd7366581de.tar.bz2
gentoo-2-9e246c837a1fe25d1125a603991c8fd7366581de.zip
Version Bump, prepared by Max
(Portage version: 2.2.0_alpha19/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/gabedit')
-rw-r--r--sci-chemistry/gabedit/ChangeLog7
-rw-r--r--sci-chemistry/gabedit/gabedit-2.3.5.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/sci-chemistry/gabedit/ChangeLog b/sci-chemistry/gabedit/ChangeLog
index 398a2e3a25e8..012a01d43406 100644
--- a/sci-chemistry/gabedit/ChangeLog
+++ b/sci-chemistry/gabedit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-chemistry/gabedit
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.3 2011/01/03 13:16:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/ChangeLog,v 1.4 2011/01/30 16:28:26 jlec Exp $
+
+*gabedit-2.3.5 (30 Jan 2011)
+
+ 30 Jan 2011; Justin Lecher <jlec@gentoo.org> +gabedit-2.3.5.ebuild:
+ Version Bump, prepared by Max
*gabedit-2.3.4 (03 Jan 2011)
diff --git a/sci-chemistry/gabedit/gabedit-2.3.5.ebuild b/sci-chemistry/gabedit/gabedit-2.3.5.ebuild
new file mode 100644
index 000000000000..d3f3aea54ee7
--- /dev/null
+++ b/sci-chemistry/gabedit/gabedit-2.3.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/gabedit/gabedit-2.3.5.ebuild,v 1.1 2011/01/30 16:28:26 jlec Exp $
+
+EAPI=2
+
+inherit toolchain-funcs versionator
+
+MY_PN=${PN/g/G}
+MY_PV=$(delete_all_version_separators)
+MY_P="${MY_PN}Src${MY_PV}"
+
+DESCRIPTION="GUI for computational chemistry packages"
+HOMEPAGE="http://gabedit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}/${MY_PN}${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="openmp"
+
+RDEPEND=">=x11-libs/gtk+-2.4
+ x11-libs/gtkglext
+ x11-libs/gl2ps
+ virtual/opengl
+ virtual/glu"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ sed -i "/rmdir tmp/d" "${S}"/Makefile
+ sed -e "/GTK_DISABLE_DEPRECATED/s:define:undef:g" \
+ -i "${S}/Config.h" || die
+ cp "${FILESDIR}"/CONFIG.Gentoo "${S}"/CONFIG
+
+ if use openmp && tc-has-openmp; then
+ cat <<- EOF >> "${S}/CONFIG"
+ OMPLIB=-L/usr/$(get_libdir) -lgomp
+ OMPCFLAGS=-DENABLE_OMP -fopenmp
+ EOF
+ fi
+ echo "COMMONCFLAGS = ${CFLAGS} -DENABLE_DEPRECATED \$(OMPCFLAGS) \$(DRAWGEOMGL)" >> CONFIG
+}
+
+src_compile() {
+ emake external_gl2ps=1 || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die
+ dodoc ChangeLog || die
+}