summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-07 11:00:06 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-07 11:00:06 +0000
commit8d62ea754d0023a549ca676216c676269ebede60 (patch)
tree1322ae732f233cc6f84381325bd0506b37dbbaa0 /sci-chemistry/ksdssp
parentC++ lib to handle pdb files (diff)
downloadgentoo-2-8d62ea754d0023a549ca676216c676269ebede60.tar.gz
gentoo-2-8d62ea754d0023a549ca676216c676269ebede60.tar.bz2
gentoo-2-8d62ea754d0023a549ca676216c676269ebede60.zip
ksdssp is an open source implementation of the algorithm described in Wolfgang Kabsch and Christian Sander, "Dictionary of Protein SecondaryStructure: Pattern Recognition of Hydrogen-Bonded and Geometrical Features," Biopolymers, 22, 2577-2637 (1983)
(Portage version: 2.2_rc65/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/ksdssp')
-rw-r--r--sci-chemistry/ksdssp/ChangeLog13
-rw-r--r--sci-chemistry/ksdssp/ksdssp-040728.ebuild45
-rw-r--r--sci-chemistry/ksdssp/metadata.xml8
3 files changed, 66 insertions, 0 deletions
diff --git a/sci-chemistry/ksdssp/ChangeLog b/sci-chemistry/ksdssp/ChangeLog
new file mode 100644
index 000000000000..85ba3343707b
--- /dev/null
+++ b/sci-chemistry/ksdssp/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for sci-chemistry/ksdssp
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ksdssp/ChangeLog,v 1.1 2010/03/07 11:00:06 jlec Exp $
+
+*ksdssp-040728 (07 Mar 2010)
+
+ 07 Mar 2010; Justin Lecher (jlec) <jlec@gentoo.org> +ksdssp-040728.ebuild,
+ +metadata.xml:
+ ksdssp is an open source implementation of the algorithm described in
+ Wolfgang Kabsch and Christian Sander, "Dictionary of Protein Secondary
+ Structure: Pattern Recognition of Hydrogen-Bonded and Geometrical
+ Features," Biopolymers, 22, 2577-2637 (1983).
+
diff --git a/sci-chemistry/ksdssp/ksdssp-040728.ebuild b/sci-chemistry/ksdssp/ksdssp-040728.ebuild
new file mode 100644
index 000000000000..08c748ad09b2
--- /dev/null
+++ b/sci-chemistry/ksdssp/ksdssp-040728.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/ksdssp/ksdssp-040728.ebuild,v 1.1 2010/03/07 11:00:06 jlec Exp $
+
+EAPI="3"
+
+inherit toolchain-funcs
+
+DESCRIPTION="ksdssp is an open source implementation of dssp"
+HOMEPAGE="http://www.cgl.ucsf.edu/Overview/software.html"
+SRC_URI="mirror://gentoo/${P}.shar"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="as-is"
+IUSE=""
+
+RDEPEND="sci-libs/libpdb++"
+DEPEND="
+ ${RDEPEND}
+ app-arch/sharutils"
+
+S="${WORKDIR}"/${PN}
+
+src_unpack() {
+ "${EPREFIX}"/usr/bin/unshar "${DISTDIR}"/${A}
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ PDBINCDIR="${EPREFIX}/usr/include/libpdb++" \
+ BINDIR="${EPREFIX}/usr/bin" \
+ .TARGET="${PN}.csh" \
+ .CURDIR="${S}" \
+ CC="$(tc-getCXX)" \
+ LINKER="$(tc-getCXX)" \
+ OPT="${CXXFLAGS}" \
+ LFLAGS="${LDFLAGS}" \
+ ${PN} ${PN}.csh || die
+}
+
+src_install() {
+ dobin ${PN}{,.csh} || die
+}
diff --git a/sci-chemistry/ksdssp/metadata.xml b/sci-chemistry/ksdssp/metadata.xml
new file mode 100644
index 000000000000..c6856dc7f2cf
--- /dev/null
+++ b/sci-chemistry/ksdssp/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>