summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-03-26 15:31:01 +0000
committerJustin Lecher <jlec@gentoo.org>2011-03-26 15:31:01 +0000
commit60edde5e3376299b673558fea99f7cef1b6acb76 (patch)
tree6005a77a8a64ea8b332a943adb2256870038aa46 /sci-chemistry/openbabel/openbabel-2.3.0.ebuild
parentDepend on virtual/ffmpeg instead of media-video/ffmpeg. (diff)
downloadgentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.tar.gz
gentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.tar.bz2
gentoo-2-60edde5e3376299b673558fea99f7cef1b6acb76.zip
Version Bump, mainly prepared by rei4dan, #345093
(Portage version: 2.2.0_alpha28/cvs/Linux x86_64)
Diffstat (limited to 'sci-chemistry/openbabel/openbabel-2.3.0.ebuild')
-rw-r--r--sci-chemistry/openbabel/openbabel-2.3.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/sci-chemistry/openbabel/openbabel-2.3.0.ebuild b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
new file mode 100644
index 000000000000..993f96ed4d41
--- /dev/null
+++ b/sci-chemistry/openbabel/openbabel-2.3.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/openbabel/openbabel-2.3.0.ebuild,v 1.1 2011/03/26 15:31:01 jlec Exp $
+
+EAPI="3"
+
+WX_GTK_VER="2.8"
+
+inherit cmake-utils eutils wxwidgets
+
+DESCRIPTION="Interconverts file formats used in molecular modeling"
+HOMEPAGE="http://openbabel.sourceforge.net/"
+SRC_URI="mirror://sourceforge/openbabel/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc wxwidgets"
+
+RDEPEND="
+ dev-cpp/eigen:2
+ dev-libs/libxml2:2
+ !sci-chemistry/babel
+ sci-libs/inchi
+ sys-libs/zlib
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4.8"
+
+DOCS="AUTHORS ChangeLog NEWS README THANKS doc/*.inc doc/README* doc/*.mol2"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-test_lib_path.patch
+}
+
+src_configure() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use wxwidgets BUILD_GUI)"
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ dohtml doc/{*.html,*.png} || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/API/html
+ doins doc/API/html/* || die
+ fi
+ cmake-utils_src_install
+}
+
+src_test() {
+ local mycmakeargs=""
+ mycmakeargs="${mycmakeargs}
+ -DOPENBABEL_USE_SYSTEM_INCHI=ON
+ $(cmake-utils_use wxwidgets BUILD_GUI)
+ $(cmake-utils_use_enable test TESTS)"
+
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
+}